Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

6700 VHF frequency error details

ka7gzrka7gzr Member ✭✭
edited June 23 in SmartSDR for Windows

I joined the 2MLDPA VHF amplifier club as it arrived in the mail today. It looks very nice sitting next to my 6700. The software version is v1.10.16.91.

I have been reading through the forum today trying to get smart on its interface to the 6700. I do see that the 6700 has a frequency error problem on VHF. The issue generated a problem report #3333.

Is there a way I can read this? I ran access my own PRs but it appears that I can't read others.

I'm looking for a summary of this issue. It's unclear to me if this is a Tx/Rx problem and is it intermittent? Will a GPSDO equipped 6700 exhibit the same problem? How long has this problem existed? It appears it was reported a couple of years ago.


TIA,

Jim

ka7gzr

Open for Comments · Last Updated

Comments

  • RiaRia Member ✭✭
    edited November 2019
    Hi Jim, Flex's bug tracking database is for their internal use only and they do not give access to customers. You're going to have to contact them directly if you want some specific info. Sorry :( Ria
  • ka7gzrka7gzr Member ✭✭
    edited June 2017

    Thanks Ria..

    I am contacting them directly as I can, via this post. :)

    Jim

  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited August 2017
    This is the Community, not a direct way to contact FlexRadio regarding a specific issue.  Please open a HelpDesk ticket for that purpose.

    In regard to defect #3333, it is still pending.  It is slated to be addressed in a future release of SmartSDR.
  • Mike_VE3CKOMike_VE3CKO Member ✭✭
    edited June 23
    A temporary workaround is that you will have to manually enable both RIT and XIT using the x/RIT button on the slice. For my 6700 & 2MLDPA I had to set RIT to 500 and XIT to 300 for suitable 2m SSB usage. I am fortunate to have a 5000A with VHF/UHF so it made it easier to find the correct offset. Unfortunately at this time it can't be saved so it must be done every time you open up 2m panadapter. Would be nice to have a temporary fix, the ability to save RIT XIT into global profiles as it seems that would not be as much development as the real fix, ability to calibrate VHF in the Radio Setup.
  • ka7gzrka7gzr Member ✭✭
    edited April 2019

    Thanks Mike. I don't really notice much error on Rx but just got it running yesterday. I will be wiser as I use it more. Do you have a GPSDO in your Flex?

    Thanks,

    Jim 

  • ka7gzrka7gzr Member ✭✭
    edited June 2017
    OK Tim.
  • Mike_VE3CKOMike_VE3CKO Member ✭✭
    edited June 2017
    No I don't have GPSDO Jim.
  • ka7gzrka7gzr Member ✭✭
    edited August 2017

    Hi Mike,

    I ran some Rx frequency tests with my 6700 with GPSDO, DEMI 2mLPDA set up. I used my HP Signal Generator 8647A for a signal source. Here are my results. The first number is what I had the signal generator set to and the second number is the 6700 at max resolution.

    144.000000 MHz = -168 Hz

    145.000000 MHz = -166 Hz

    146.000000 MHz = -170 Hz

    147.000000 MHz = -171 Hz

    148.000000 = -172 Hz

    I haven't calculated the SGs accuracy nor the Flex 6700 at this frequency which will obviously play a role. 

    Also It will be interesting to see what Flex finds out

    Jim

    ka7gzr

  • Mike W8MMMike W8MM Member ✭✭
    edited July 2019
    The 144 MHz XIT/RIT issue has to do with using the frequency calibration feature.  The bug seems only to affect 2 meters and is perfectly fine on lower bands.   If it is not engaged, 2 meters transceives perfectly.  Until the bug gets fixed, the way around this is to use an external precision 10 MHz source or purchase the GPSDO.  Without engaging the frequency calibration feature, those two options give "perfect" frequency accuracy without being bothered by the 144 MHz RIT/XIT firmware bug.  My 6700's have the GPSDO installed and are immune from the issue.
  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited August 2017
    The issue, #3333 is still on the list to be addressed.  The comments from Mike, W8MM sums up the issue
  • ka7gzrka7gzr Member ✭✭
    edited August 2017

    Thanks Mike for the some details of the issue. Without access to the actual Problem Report I was guessing.
    Jim

    ka7gzr

  • Mike W8MMMike W8MM Member ✭✭
    edited August 2017
    You're very welcome.  A 50+ years close friend of mine (fellow Flexer) did a number of experiments on his 6700 after he experienced the problem.  He did not have the GPSDO nor a "precision" 10 MHz reference and experienced increasingly odd XIT/RIT divergence as his 6700's master oscillator aged (changed frequency) and he tried to calibrate against WWV to put the radio "back on frequency".  He was determined to get to the bottom of the odd behavior and has a whole ton of test equipment and the smarts to use it.  We would discuss various of his findings and mull over the possible causes.  Deductive reasoning produced his final analysis, which Flex confirmed.
  • Ken - NM9PKen - NM9P Member ✭✭
    edited August 2017
    Workaround Suggestion...You can create a DDUtil macro to set the RIT/XIT frequencies and status.  And another one to zero them out again.

    When you enter 2 Meters, hit the macro button and you are off and running.

    When you leave 2 Meters, hit the other one.

    I don't know if you can link a macro to a particular band or not.....

    Ken - NM9P

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.