Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

fldigi will not work with Flex 6700

Bill AB7AABill AB7AA Member ✭✭
edited March 2019 in SmartSDR for Windows
I am using SSDR 1.10.16.174 and trying to interface with Fldigi 3.23.07.  Audio works fine but no rig control.  I've tried using the sourceforge download but it is an html file and fldigi wants an xml file and does not recognize it.  How do I convert or somehow get it to work?

Comments

  • Jay SpauldingJay Spaulding Member
    edited May 2017
    Use Omni rig . and then use your cat program to pic the slice. That's what I do. Works very good. Something for WSJT-5. And I have them both reporting to Log4om. And the logger dents to QRZ hrdlog and wellLOTW and some others Good luck
  • Ken HansenKen Hansen Member ✭✭
    edited June 2018
    I setup wspr on my 6300, couldn't get radio control until I selected Kenwood TS-2000 as radio, selecting Flex was a no-go. The Flex radios are designed to support Kenwood-style rig commands, I'd give that a try. Also, I believe I had to 'enable' transmit on the SmartSDR screen, on DAX audio panel? Sorry, away from radio.
  • Jay SpauldingJay Spaulding Member
    edited May 2017
    Oh I forgot. There is a later version on FLDIgi btw it's over 4.0 now. Could be some of the problem.
  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited May 2017
    The problem is your browser needs to download the RigCAT xml file as a raw file and not as HTML.  Try a "save as"
  • edited May 2017
    On the Rig Setup menu open the Hamlib tab. Select the Kenwood 2000 radio. Select the comm port for the slice that you're dedicating to fldigi. Remember to click on "enable .hamlib". Remember to go to the audio tab and pick the correct slice under port audio for receive. FLDIGI defaults to the first comm port and the first audio slice. This can cause conflicts if you have other clients using the flex.
  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited May 2017
    Both Hamlib and OmniRig are very limited in functionality.  RigCat supports all radio modes properly including preset filter switching.
  • Bill AB7AABill AB7AA Member ✭✭
    edited May 2017
    Tim-W4TME,  Thanks for the reply.  I tried a Save As but raw was not one of the options.  My choices are Complete, Archive, or HTML Only.  What?   Bill AB7AA
  • Bill AB7AABill AB7AA Member ✭✭
    edited May 2017
    Tim, Thanks for the reply.  I tried a Save As but Raw was not one of the options.  My choices are Complete, Archive, or HTML Only.  What?  Bill AB7AA
  • Michael CosloMichael Coslo Member
    edited May 2017
    Bill, I have a howto on Youtube https://www.youtube.com/watch?v=IVOhj244e30&t=1s 

    It was based on a 6300, but will work for the 6700.  You should be able to simply click on the sourceforge link with a left click, and it will download the xml file with no questions asked about how to save it, getting you the xml file
  • Andrew VK5CVAndrew VK5CV Member ✭✭
    edited May 2017
    Bill,
    Try with another browser such as chrome.
    That works for me.
    Andrew de VK5CV
  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited May 2017
    You may need a different browser
  • Bob KC9RFBob KC9RF Member ✭✭
    edited March 2019
    Hi Bill 
    There is a XML file(s) that need to be loaded typically to C:Users(your user name)Documentsfldigi.files
    igs

    These files are  SMARTSDRsliceA.xml   and same name but slices b,c and d. etc

    Here is the link  for these files https://sourceforge.net/projects/fldigi/files/xmls/flex/

    The  setup should look similar to this depending on what slice you are using. Press initialize then check flex for correct freq controlled by fldigi.

    image

    Audio for fldigi should look similar to window below. Note don't forget to turn on dax channel in slice (x)
    I'm using slice B this is the config used.
    image
    Bob KC9RF



Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.