Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Deja Vu All Over Again - SSDR Crashes on my 6700

Roy LauferRoy Laufer Member ✭✭
edited January 30 in FLEX-6000 Signature Series
I'm really sorry to rain on anyone's parade...

I installed and every so often my 6700 goes crashing down. The window closes on my PC, but more importantly, the only way to get any version of SSDR to recognize that it is connected to a 6700 is to power down my 6700. This is NOT accomplished with a simple, quick press of the off/on button, unless I wish to wait 30 - 60 odd seconds (normally a quick press will shut it down MUCH more swiftly).

I have been here way too often, this is NOT a PC or a switch problem - the firmware is getting corrupted and crashing my 6700.

I have used builds that don't do this - this most recent build, unfortunately, does do this!

First, to those who want to yell out as loudly as possible, "I don't know what you're writing about, it's working fine for me!", I am happy for you (if you send me your address, I will mail you a cookie for your good fortune). As time goes on, if history repeats itself, people will slowly post these odd erratic crashes that they are becoming aware of.

Yes, I've "turned it off and on again". Yes, I reset it to factory default. Yes, I removed the power entirely. Yes, I imported my setting without the preferences setting (I gotta make a macro for this message - I post it so often).

This is NOT meant to disparage FRS in any way. I LOVE my 6700, and I fully appreciate the vagaries of software development and the almost infinite permutations that users twist their software around.

Maybe I should volunteer myself to the beta testing effort, since I seem to push my 6700 precipitously near the bleeding edge, and I seem, to be the first guy that mentions that the 'Emperor has no clothes'?



  • W0JDW0JD Member
    edited January 30

    You are a beta tester, the release you are running is a beta release.
  • Bill -VA3WTBBill -VA3WTB Member ✭✭✭
    edited February 2018
    What did the help desk have to say? the issue you are have could happen yes, but most do not notice this,,I have never crashed, it can happen. I'm sure they can help you find out what causes it.
  • Roy LauferRoy Laufer Member ✭✭
    edited May 2017
    By the way, after 10-15 minutes it crashed again!

    Here's some error info:


    And by the way, I timed the soft power down "quick press" after the crash - it took 60 seconds. It usually takes 5 seconds.
  • Roy LauferRoy Laufer Member ✭✭
    edited March 2017
    I beg to differ - this iteration of (I erroneously posted the.91 designation) has had the 'beta' designation removed (although previous versions of 1.10 were so designated).

    Unless you are suggesting that all of us SSDR users are beta testers <grin>????
  • DavidDavid Member ✭✭
    edited March 2017
    The current production release is As mentioned the .91 release was beta and issues are expected with beta. The fact that you have had this happen with previous releases I recommend you open a ticket with Flex so they can review your unique situation and help get it resolved.


  • Roy LauferRoy Laufer Member ✭✭
    edited March 2017
    I am absolutely sure that Tim will fix this for me, post haste.

    It just would just be nice if the beta testers would do a bit more beta testing...

    I think that this is the third time I have been the first to notice this type of a firmware bug.
  • George Molnar, KF2TGeorge Molnar, KF2T Member ✭✭✭
    edited February 2019
    A couple of things to test.

    Check the quality of the ethernet cables. Even a small problem with a cable can cause your symptoms. Are they rated for the length and speed you're using? Have you tried shielded vs unshielded? Ground loops with shielded can occasionally cause grief.

    Run the rig right off the LAN port of your computer. No switches, etc. If you have set up your 6700 with a fixed address, un-do that first (shouldn't need it in 99+ percent of cases, anyway). Ensure the PC port allows a link-local connection, too.

    If that does work, time to look at your LAN topography. Only one DHCP server on the whole LAN (should be)? No accidentally duplicated fixed addresses? Are your PC and 6700 plugged into the SAME switch (they should be)?

    Are you running long cables and trying to use Gigabit speeds? If so, try backing down to 100 Mbps connections.

    Is your NIC driver up to date and properly configured? Sometimes "updates" turn on sleep modes, jumbo packets, or other less-than-helpful things. Don't let the card power down. Sleep mode is generally not our friend.

    For what it's worth, my computer to 6500 connection has been pretty bulletproof for a long time. Computer, GigE switch, and rig are on the same desktop, with 1m CAT6 between them. 

    Hope this helps!

  • Roy LauferRoy Laufer Member ✭✭
    edited June 2017
    I am sorry for the confussion - I am writing about, NOT .91 (there most be a bug in my own personal firmware to have produced that erroneous firmware version.
  • George Molnar, KF2TGeorge Molnar, KF2T Member ✭✭✭
    edited February 2019
    One more question - what are your system specs? OS, Processor, installed RAM, video card? Is the NIC a "real" ethernet card, or a USB adapter?  Roy, I'm sure you've gone through most of this already, just trying to get a better view from here.

    73, Geo
  • Ross - K9COXRoss - K9COX Member ✭✭
    edited March 2017 is the hardware version shown for software version. It can deceive one when looking at the radio setup screen.
  • Roy LauferRoy Laufer Member ✭✭
    edited March 2017
    I appreciate the suggestions, but they amount to the same suggestions for the last two times, when it was a firmware problem.

    I am glad for those that have had no problem, but that is immaterial to those that DO have a problem. Some of us use our 6700's in a very narrow similar manner and some try to fashion it into a swiss army knife and see the flaws that are just not obvious.

    Stray RF is a very unlikely because, since I am not transmitting (not even my cell phone) during these crashes).

    I understand that I might sound like the guy that called "wolf" too much, but when I called "wolf" twice before and there actually was a gnarling wolf shown, I kinda wish people would entertain the idea that the firmware has a bug in it AGAIN...

  • Michael AustMichael Aust Member
    edited May 2017
    I have the same issue with my 6700 so I went back to stable
    knowing I would get the, it's working for me comments and no resolution
    73 mike
  • Roy LauferRoy Laufer Member ✭✭
    edited March 2017
    Thank you!

    Now I am reassured that my own firmware isn't corrupted<grin>!
  • Roy LauferRoy Laufer Member ✭✭
    edited May 2017
    My primary PC is a hefty desktop with nothing "virtual" - it has a discrete video card, a hardware network port. An up to date version of Windows 10 Professional and up to date non-beta video drivers.

    When this happened twice before I did all those "tricks" to disprove that it was PC related (it would happen on my maestro, my laptop, my iphone).

    I'm getting a bit tired of proving that a wheel is circular.

    Someone needs to fix the firmware.

  • Roy LauferRoy Laufer Member ✭✭
    edited March 2017
    As the saying goes, "the squeaky wheel gets the oil", and I am squeaking.

    Tim has come through with a fix for this before and I am sure that he will do so again.

    You just have to make people aware of the problem...
  • Paul MPaul M Member
    edited March 2017
    I put a trouble ticket in for a similar problem this weekend.  The radio quits and I cannot use the  on/off button to shut it down, I have to turn the power supply off.   I get similar messages on screen that someone else published.   

    Additionally I have one of the USB ports not sending information to the SteppIR.  It takes an disable/enable of the USB in the FlexRadio control panel to restart the SteppIR from working,  I have changed the adapters between the SPE and the SteppIR  and the port that stops working stays the same.  
  • Roy LauferRoy Laufer Member ✭✭
    edited March 2017
    And by the way, I just powered down my ethernet hub and SSDR just safely quit without my 6700 crashing, without requiring the 6700 to be powered down and back up. I just ran SSDR again on  my PC and worked fine.

    Not a PC issue... Not an ethernet issue.

  • EA4GLIEA4GLI Salvador Member ✭✭
    edited March 2017
    I just had the same problem a few minutes ago. I couldn't turn the 6700 off with the front button and a short push, however I was able to shut it down with a relay to the RemON RCA connector in the back of the radio. I didn't get the Screen error verbiage but even though the radio was on it would not show up on the SmartSDR radio selecting screen.

    Once I click the RemON to turn it off it shut off very quickly. And I was able to start again.

    Also, probably not related, my transverter band has no antenna persistance. ..sigh..
  • George Molnar, KF2TGeorge Molnar, KF2T Member ✭✭✭
    edited March 2017
    Thanks Roy, for the info. I'm just working the checklist; no doubt you have been thorough. Sometimes, though, running the procedure "one more time" finds the culprit where we least expect it. 

    You mentioned your ethernet "hub." Is your device really a hub, or is it a switch? Bandwidth issues can be quite different between these two similar products. If it's truly a hub, you might want to consider replacing it with a GigE switch. Not saying that's "the" problem, nor denying there may be a defect in the Flex firmware. Just covering bases and hopefully providing a resource for those who experience similar problems down the line.

  • Roy LauferRoy Laufer Member ✭✭
    edited March 2017
    I regret the inexact use of words.

    It is a gigabit switch, not actually a passive hub. My equipment tends to be relatively high end. I am aware of guys that prefer running Windows 95 on archaic Net Books that they bought in going out of business sales.

    In the past two episodes, by fixing the 6700 firmware, the problem was resolved. The 6700 is a great radio, but I do not believe it has magical powers regarding my computer network.
  • George Molnar, KF2TGeorge Molnar, KF2T Member ✭✭✭
    edited March 2017
    LOL, Roy - yes, we do have members of our hobby that are still griping that they can't use their 386 with math coprocessor that they "paid good money for!" Problem sounds frustrating, for sure. Wish I had some more advice to help you. I didn't catch if you had the crashes hooked directly to the PC (NIC to NIC). That's usually the "last best hope." Could very well be a firmware issue particular to the 6700 in some configurations. God knows there's a lot going on in that little black box.

    When it gets fixed, post about it here - I'm sure a lot of us are curious to see how it works out.
  • Roy LauferRoy Laufer Member ✭✭
    edited March 2017
    Thank you George.

    I will keep people informed.

    I do not think that this is a hardware flaw with the 6700 - it just has so much more capability, that it has so much more that can go wrong in firmware.

    Now, I am not quite sure what the explanation is for the unresolved issues with running 2 Meter panadapters. Update notices for each incremental update version keep listing those problems as not yet resolved...
  • N9VCN9VC Member ✭✭
    edited March 2017
    I am seeing the same problem that I have not experienced
    before. The screen will lock and I have to do a complete
    power down and restart. The latest version .91, which, by
    Tim's words is not a beta version and a 6700.
    Did not do this before and attribute it to some glitch that
    rear's its ugly head every now and then. I can not force the
    situation, it just happens.
    I used it for better than a week before I first encountered

    73, Jim N9VC

  • Paul MPaul M Member
    edited March 2017
    Good point, when the radio quits I cannot reconnect by restarting the software I have to reboot the radio.
  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited March 2017
    The error looks like something went wrong with the sorting in the memory form.  This likely happened when the client lost connection with the radio.  I suspect getting to the crux of the crashing issue will resolve this particular unhandled exception error. 

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.