Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

My Flex 6500 doesn't always connect to my correct network IP address

Rob Laws
Rob Laws Member
edited February 2020 in FLEX-6000 Signature Series
Having trouble getting my 6500 to connect to my network IP address.  Sometimes (like now) the radio network address is something different.  I restart the radio and reboot the router to no vail.  Is there anyway to set a static IP address for the radio?  How to fix this?  Sometimes it just resets on it's own and connects to the correct IP.  Any suggestions? Thanks, Rob 

Answers

  • David
    David Member ✭✭
    edited March 2017
    With the current release you can set a static IP. You have to be connected to the radio.
    Settings - Radio Setup - Network - Advanced
  • Rob Laws
    Rob Laws Member
    edited November 2016
    I can't connect to the radio. It shows up in the window and I can click on the network tab and see the network, which is wrong, but the advanced tab doesn't open anything because I guess I'm not connected to the radio
  • David
    David Member ✭✭
    edited March 2017
    so when you double click the radio or click the Green Connect button the radio does not connect? How is the radio and PC connect to the network, wired or wireless? Do you have just one router with DHCP or are there other devices that might also be configured to hand out addresses with DHCP? What type of network setup do you have?
  • Jim Gilliam
    Jim Gilliam Member ✭✭
    edited November 2016

    If your router will allow it, one can set a static address to the current DHCP of your Flex address. You might look at the router menu and see if this is allowed. On my Linksys 1900AC this is feature is located under the tab of local network settings.


    Jim, K6QE

  • Rob Laws
    Rob Laws Member
    edited November 2016
    No the radio won't connect because it has another IP address showing under network settings. This doesn't always happen. Most of the time it shows the correct network. I have only one router and the radio is connected directly to the router.
  • David
    David Member ✭✭
    edited December 2016
    And you did completely power off the Radio and the power supply to it along with powering off the PC and the router and restarting the router and then the radio? What are the IP's that show up when there are multiples? Are they the same network? Is the PC also also directly connected to the router? What type of router are you using. A Jim indicated you might be able to set the a 'static' address in the router for the flex. When you do set the radio with a static you will want to make sure to use an address outside the router's DHCP address pool to avoid conflicts.
  • Rob Laws
    Rob Laws Member
    edited November 2016
    I have completely powered off everything. And did as you said. I reset the router then powered on the PC then the radio. I use a Apple Extreme router. The router address is 192.168.1.1 The Flex is direct connect to router. The PC is direct connected. When the Smart SDR opens up, the radio is there, but every now and again I can't connect to radio. I check the network tab and it lists something completely different. Like 199.255.1 etc. Of course now that I have reset everything again for the 6th time.... it's working. So now I can't see the bad network address it was showing. So my question is how can I get into the advanced tab in the Smart SDR network setting to set a static address of say 192.168.1.22 etc. to keep this from happenening again? I'm running version 1.9.13.173 of Smart SDR. Rob
  • David
    David Member ✭✭
    edited December 2016
    With the SSDR screen connected the the radio (you have double clicked or clicked the connect and have the running panadapter screen)

    Select the following
    -Settings
    -- Radio Setup
    ---- Network
    ----- Advanced

    You should then see the options to switch from DHCP to Static and apply the address, Mask, and Gateway.

    Select Apply

    The radio should then cycle and you will need to reconnect. Once you have reconnected to the radio with the static IP you may want to power cycle all devices again to fully confirm everything has stuck and will work in the future.
  • Rob Laws
    Rob Laws Member
    edited November 2016
    Thanks David, I'll give that a whirl. I was trying to click on the advanced tab under network on the first screen where the radio was highlighted on the left and then under network tab. But that's not where you mean. Correct?
  • David
    David Member ✭✭
    edited December 2016
    That is where you will click but only after you have connected to the radio. The second time you bring that screen up after it is connected. Until you actually connect you cannot make updates to the Radio Setup settings. This is the case for any of the tabs on the right side of the Radio Setup screen. The radio needs be connected for you to be able to apply the settings on them.

    1. Start SSDR
    2. Connect to radio
    3. select Settings from the File, Settings Profile, Help menu at the top
    4. Select Radio Setup
    5. Select Network tab from the Startup, Radio, Network, GPS, ... tab listings
    6. Select Advanced
    7. Set the static IP, Mask, Gateway
    8. Select Apply (radio will reset with new IP configuration)
    9. Confirm you can connect to the radio and settings are working
    10. Fully confirm all will restart by power cycling all devices
    11. Reconfirm you can connect to the radio and settings are working
  • Ed_NZ1Q
    Ed_NZ1Q Member ✭✭
    edited March 2017

    Same problem with my 6500.  This problem of the rig coming up in link-local while on the wired network has been very annoying.  Since I've had the 6500 for a couple of years, I've had to take a different approach to using it successfully.  

    The FLEX should not exhibit this problem.  I've changed everything in the network - it still acts the same, i.e. coming up in link-local.  It does not happen all the time.  It used to come up with a bad IP address 9 out of 10 boots.  With newer software, it seems more like 1 link-local ip address in evert 10 boots.

    Dear FLEX - any solution to this?

    Ed  -  NZ1Q

    PS, my work-around was to connect the 6500 directly to my PC by Ethernet cable to the nic card in the PC (so it could come up with any ip address and still work).  Then I connect the PC to the router via WiFi (using a USB dongle).  The added benefit was to have the station equip electrically isolated form the cable system.


  • Rob Laws
    Rob Laws Member
    edited November 2016
    Ok got it. I know the IP, and mask but is the gateway the router address? Rob
  • David
    David Member ✭✭
    edited December 2016
    Yes gateway / default route is the router
  • Rob Laws
    Rob Laws Member
    edited November 2016
    Thanks David! I think before I change it, I will want to look for an address out of range like maybe .99 and I also worry if I change it and it doesn't work then it might be impossible to go back as I would not be able to connect to radio to go back to auto DHCP address. I guess I am not alone on the Flex 6500 connecting to local link some times. It's frustrating to have to reset and reboot all the time to connect. Rob
  • Michael Coslo
    Michael Coslo Member ✭✭
    edited November 2016
    Ed - can you borrow a different router and give it a try? Of a different brand of course. 
  • David
    David Member ✭✭
    edited December 2016
    You want to check the router DHCP range and probably adjust it so you have addresses outside the pool to use. If for some reason you can't connect you should be able to direct connect the radio to the pc (no router) and connect. Worse case you can factory reset. Make sure you have exported (backed up) saved all settings so you can restore any custom ones you do not want to lose.
  • Ed_NZ1Q
    Ed_NZ1Q Member ✭✭
    edited November 2016

    Hi Mike,

    Yes, when I said I've changed everything, I meant everything, router, wires, switch/no switch, direct connection to router.   I can't help but think it is in the 6500 hardware, i.e Ethernet port or software. 

    Thanks for asking.  Any other?

  • Mark Erbaugh
    Mark Erbaugh Member
    edited February 2020
    As for the automatic connection issue, I had a problem with that for a long time. I even opened a help ticket and had Tim review network logs from Wireshark. No one could figure any thing out. I replaced a network switch that was between the router and the Flex and the problem went away. The funny thing was that before and during the time I had the Flex, the computers, there were several, never had any network issues. The Flex's symptom is that most of the time when turned it on, it would come up with a bad IP address.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.