Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

SMARTSDR crashes when monitor 2 wakes up

Andrew O'BrienAndrew O'Brien Member ✭✭
edited June 2020 in SmartSDR for Windows
I run two monitors, monitor two is larger and gets to be the place I put SmartSDR most of the time.  That monitor (actually a TV) has a power saving feature that causes the monitor to go asleep after a period of time.  This is a useful feature if I am out of thshack for a while.  When I return o the shack and awaken monitor 2 I momentarily see SmartSDR is still running (live signals visible and audio briefly heard) but after a second or so SmartSDR appears to crash.  I lose any visible SSDR screens and audio goes away.  If I try to reboot , nothing happens .  Then I check the task bar and it says SSDR is already running.  I have to "end task" and reboot to get SSDR to function again.  Any suggestions aside from not use power management ?

Andy K3UK

Comments

  • Mike - ZL1MRCMike - ZL1MRC Member
    edited January 2019
    Hi,  I have also seen the same running under Parallels in the MAC.  Not too sure what is causing it.
  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited March 2017
    Try controlling the "sleep" behavior of the monitors using the features of Windows (video card) so that Windows knows about the sleeping monitor rather than having it power down, which makes it look like the monitor has "gone away"
  • Walt - KZ1FWalt - KZ1F Member ✭✭
    edited November 2016
    I reported this a week or two ago. I don't believe it was ever responded to. That was the first I've ever witnessed that behavior.
  • Andrew O'BrienAndrew O'Brien Member ✭✭
    edited June 2020
    I have another Windows update that pooped up today, I am postponing activating it.
  • Mike - ZL1MRCMike - ZL1MRC Member
    edited December 2016
    Hi, got another crash today.  I have instructed Windows to do nothing in the power save mode.  Leave monitors on etc.   My mac however does sleep the monitors after 15 minutes.  Following is a screen shot of what displayed today.
    image
  • Bob K8RCBob K8RC Old Guy Member ✭✭
    edited October 2016
    Another thing to look at is the sleep behavior of your network card. If your interface is powering down when the machine sleeps that would break the connection with the radio.
  • Ken - NM9PKen - NM9P Member ✭✭
    edited December 2016
    "Pooped up" is right! Ha ha!
  • Ken - NM9PKen - NM9P Member ✭✭
    edited June 2020
    I think Tim and Bob are giving good advice. If you let the tv power itself off rather than the computer operating system, then the computer completely will lose contact with the monitor. Also, I would check the network card in Windows Device Manager - properties. Make sure that power manager is turned off for the NIC card(s) and that they are all set to Always ON.
  • Andrew O'BrienAndrew O'Brien Member ✭✭
    edited June 2020
    my issue is not the actual sleep stage, it is the waking up part the the issue occurs.

  • Ken - NM9PKen - NM9P Member ✭✭
    edited December 2016
    So ssdr keeps running and you can use it monitor #1 while #2 is off? Then it quits when you turn monitor #2 back on? That IS strange........ What programs are running at the same time, and on which monitors are they running? Do you have SSDR in full screen? Or in a window? Are you stretching SSDR across two monitors? (That could possibly cause problems when one of them changes state and the other doesn't).... Hmmmmm....that is a stumper....
  • Andrew O'BrienAndrew O'Brien Member ✭✭
    edited October 2016
    I did not catch my typo !
  • Andrew O'BrienAndrew O'Brien Member ✭✭
    edited October 2016
    Correct Bob and it is strange.   I am NOT stretching across two monitors.  I usually am running SSDR in reduced size.  I do have audio from the Flex playing through the second monitor though.  Maybe that is part of the issue.  While the second monitor is asleep there is no sound. 
  • Walt - KZ1FWalt - KZ1F Member ✭✭
    edited January 2017
    I think the point is smartSDRfW shouldn't be crashing . In my case there was no TV involved. Further, nothing else on Windows 10 crashes.
  • KY6LA_HowardKY6LA_Howard La Jolla, CA. Paris and Sablet FranceMember ✭✭✭
    edited October 2016
    The evil Trolls from Redmond know you hate Windows and sent a Gremlin to bug you. hi hi
  • Steve K9ZWSteve K9ZW Member ✭✭✭
    edited March 2017
    What hardware/graphics card? Operating system (including build) and drivers? Windows 10 has had one fix issued for dual monitor sleep issues (I do not know the KB #) and many users report continued problems even with the fix. Letting parts of a system sleep can be challenging. Might be worth setting your power configuration at the PC to sleep BOTH monitors before the automatic sleep timer kicks in for just your second monitor. If you have SmartSDR displayed and it is sending data to the display why is your second TV monitor even sleeping in the first place? What triggers its stay-awake? 73 Steve K9ZW
  • Walt - KZ1FWalt - KZ1F Member ✭✭
    edited November 2016
    I no longer believe I am alone on that one, vocal perhaps, but not alone. The problem with making Microsoft Windows a requirement is it becomes part of the ecosystem, perhaps the weakest part.
  • Walt - KZ1FWalt - KZ1F Member ✭✭
    edited November 2016
    Steve, on that machine I have an AMD Radeon 520. It was on AMD Crimson 1511 and all was good. I don't think my situation has anything to do with sleeping, implying I don't think this problem has anything to do with sleeping, but I don't have visibility to that. Win10 had just gotten the update prior to the sp that broke my ability to boot Windows. There was a new AMD driver announcement which I installed. These all occurred roughly in the same time frame. SSDRfW doesn't immediately crash now but it is the only app that does. It may take 5 mins, may take longer or shorter. The common thread, as far as I can tell is two monitors of different geometries and SSDRfW is crashing.
  • Andrew O'BrienAndrew O'Brien Member ✭✭
    edited June 2020
    add this to the mix... the problem I describe does NOT happen if I turn off the REMOTE icon on SSDR.  When the "remote" is off, awakening monitor two causes no problem.

  • Ken - NM9PKen - NM9P Member ✭✭
    edited December 2016
    What happens if you put SSDR on monitor 1 and then let monitor 2 sleep and wake up? (With and without remote turned ON)
  • Walt - KZ1FWalt - KZ1F Member ✭✭
    edited November 2016
    I should have said supply chain. Ecosystem meant supply chain.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.