Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

DAX - 64bit driver installation issues (and workaround)

IW7DMH, Enzo
IW7DMH, Enzo Member ✭✭
edited June 2020 in SmartSDR for Windows

after having installed SmartSDR 1.3.8 I didn't found any DAX driver in my 64-bit Windows 7 Professional system.
After more attempts (uninstall-clean-setup) I had to install them executing the specific setup program "SmartSDR_IQ_DAX_install.bat" in "C:Program FilesFlexRadio SystemsSmartSDR v1.3.864-bit DriversIQ_DAX" directory.
On the contrary, on a 32 bit Windows 7 system all DAX drivers are correctly installed.

I don't know if it is the correct behaviour but, if so, I can't find any information nor in SSDR manual nor in Realease Notes documents.

I also have a question about setup process: is there an installation log that one can examine and/or submit to you support staff? It would be very helpful.
There are also some post-installation task that, I think, should be documented in SSDR manual like verifing/find "COM" drivers and verifying/finding DAX Drivers and probably more that now I don't know.
I became aware of DAX driver problem after having failed (more and more times) to configure SDR-Bridge e CWSkimmer. I had the same error reported in this post https://community.flexradio.com/flexradio/topics/error_dax_driver_installation?topic-reply-list[sett...

Best regards
73' Enzo


  • Sergey R5AU
    Sergey R5AU Sergey Member ✭✭
    edited April 2017
    Hi Enzo,
    you are not alone, and this is not a news as a solution, in Rus Flex6xxx community o got many reports regarding the same issue with DAX installation, may be we are talking abt localization issues with OS and drivers  (IMHO), ex. for some SW i should use "." as divider instead of the ",".
  • Tim - W4TME
    Tim - W4TME Administrator, FlexRadio Employee admin
    edited March 2017
    The DAX driver will install properly on 64-bit machines.  There are some local environments meaning how Windows is configured or third-party applications that have security suites that prevent some types of programs to run properly under the control of the SmartSDR installer.  This is not a systemic issue.

    In general the validator to determine if the DAX and CAT kernel mode drivers are installed properly is to run DAX and CAT.  If they do not work then some troubleshooting by FlexRadio Support is needed.  So if you are experiencing problems of this nature, please enter a HelpDesk support ticket (http://helpdesk.flexradio.com) so we can investigate your specific issue.  

    For details on how to submit a HelpDesk support ticket, please refer to the following URL: http://helpdesk.flexradio.com/hc/en-us/articles/202118688-How-to-Submit-a-Request-for-Technical-Supp...  
  • Ken - VE5KC
    Ken - VE5KC Member ✭✭
    edited December 2018
    Today I had this problem installing SmartSDR 1.4 - the DAX - 64bit drivers would not installing and I kept getting an error message. I installed and uninstalled several times, tried 1.38, still the same problem. (The computer is running win 7 Pro.)

    My solution:

    I cleaned out any SmartSDR & DAX files left on the computer after the last uninstall. Not sure if that made any difference.

    Then started a new install by right clicking on the installer file, then on "Run as administrator".

    The install worked perfectly, all drivers installed as they should.. 

    73..  Ken - VE5KC
  • DrTeeth
    DrTeeth Member ✭✭
    edited August 2016
    Windows security causes so many strange issues like this. I have configured my Win 7 installations to be completely open when I run as admin. Often, running an admin account is not good enough. I can therefore keep all my installs in the program files folders, where they should be <vbg>.
  • Ken - VE5KC
    Ken - VE5KC Member ✭✭
    edited April 2015
    Yesterday while trying to install SmardSDR on another computer I had the problem with the DAX drivers not installing. This time, "Run as administrator" did not solve the problem.

    I trying find a way to fix this, I found another solution:

    Look in the SmartSDR program folder (where SmartSDR is installed) for the folder called: 64-bit Drivers.,
    In 64-bit Drivers you will find three folders: IQ_DAX, RXAudio_DAX & TXAudio_DAX. Each of these folders has 2 .bat files, one for installing & one for uninstalling the drivers.


    To install the drivers you have to run each file - right clicking on the install.bat file, then click  "Run as administrator".

    Wait until the install is finished, then do the next one.

    Do this with all 3 and you should be good to go.

  • Jay
    Jay Member ✭✭
    edited January 2017
    I had to install software again to get dax to work. It works fine now.  Running  Win 8.1.
  • Mike
    Mike Member
    edited June 2020
    I have tried to get the 64 bit driver loaded to my windows 7 home premium system. When loading I got and window saying that windows will only do drivers that are digitally signed. It will not install the drivers. When I open the computer management and look at the driver I get this message in the general window.
    Windows cannot verify the digital signature for the drivers required for this device. A recent hardware or software change might have installed a file that is signed incorrectly or damaged, or that might be malicious software from an unknown source. (Code 52).
    I have tried running the install several times.

  • Tim - W4TME
    Tim - W4TME Administrator, FlexRadio Employee admin
    edited December 2016
    Your root certificate on your PC is out of date so it cannot verify the digital signing of our kernel mode drivers.  Run Windows update on your PC
  • Mike
    Mike Member
    edited June 2016
    I have update windows 7 with the windows update, uninstalled smartsdr and reinstalled it. I still get the same results. It will not let me install the drivers.
  • IW7DMH, Enzo
    IW7DMH, Enzo Member ✭✭
    edited December 2016

    I got the root certificate error two days ago. I turned off automatic updates before going on holiday, so my root certificate was out of date after three weeks.
    I followed Tim suggestions and now everything is right.
    Now I am wondering if there is a way to find out the root certificate and try to update it manually without having to run a full system update.

    Thank you very much
  • Peter K1PGV
    Peter K1PGV Member ✭✭
    edited December 2016
    This is odd. Root certificates should expire on something like five year intervals... Three weeks without updates shouldn't be a problem... Unless you just got slightly unlucky. I'm also not sure why having the root cert expire would impact your driver's ability to load either. When a driver is installed, the cert on the package is checked. The driver itself doesn't need to be signed (though often is) unless it starts at boot time. In addition, what matters about this signature is the cross-signature that chains-up to a MSFT CA. Anyhow.... The situation you describe is very confusing to me. In any case: You can review the certs using certutil., and manually add the new root cert.... Though I'm not sure how/where you'd find the new cert. Peter K1PGV

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.