Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

CW sidetone problem

John G3WGVJohn G3WGV Member ✭✭
edited November 2018 in FLEX-6000 Signature Series
6500 running V1.8.4.84, Windows SSDR

Now that I've mostly (ha!) finished writing code for my controller, I've started using my Flex 6500 on air. I notice that on the first dit/dah of each transmission period there is a quite noticeable rasping sound on the CW sidetone that lasts for perhaps 50-100ms. Investigation reveals that it is actually the "tail" of the receive audio continuing into the start of transmission. If I turn the active slice's AF gain down then the sidetone is pure.

The effect is more noticeable with short break-in delays, because the RX is recovering more often, i.e. in between individual letters or even each dit/dah. If the delay is set to, say, 500ms, then the effect mostly goes away because the RX is only coming back on in between words.

I'm using the powered LS audio output on the back of the 6000. I hear the same effect on the headphone output. The effect is rather unpleasant, especially at CW speeds around 30WPM and with fairly fast break in (20ms or so).

I'm surprised by this as all the reports I've seen suggest that the CW break-in (and, by inference sidetone) behaviour is excellent. Has anyone else come across it?

73, John, G3WGV

Open for Comments · Last Updated

Comments

  • Bill W2PKYBill W2PKY Member ✭✭
    edited November 2018
    Do you have the earphone/speaker volume controls on the upper right corner full on and the speaker volume control on the slice flag less than 50%? Those settings seem to be good for me. Hope this helps.
  • John G3WGVJohn G3WGV Member ✭✭
    edited December 2016
    Interesting. I didn't but I just set them as you suggest and it is noticeably better. The noise "tail" is still there but at a lower level relative to the sidetone and I probably wouldn't have noticed it had I not heard it more clearly with the other setting.

    Thanks for the suggestion Bill.
  • edited August 2016
    I kind of solved the problem by setting the audio controls the same way, but that is a bug that the FLEX folks should really address.
    73,
    Lou, i4AWX
  • John G3WGVJohn G3WGV Member ✭✭
    edited December 2016
    Thanks for the comments, Lou. I found that fiddling with the AGC threshold helps but in the end all these things are doing is masking the basic problem, which seems to be that RX audio carries on for a short period after key down. Obviously the lower you can make the RX audio level, e.g. by aggressively adjusting the AGC threshold, the less obvious the effect becomes.
  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited November 2018
    I have entered this problem report into our bug tracker (#3857) for additional investigation. Thank you for the defect report.
  • John G3WGVJohn G3WGV Member ✭✭
    edited December 2016
    Thanks Tim.
  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited November 2018
    We suspect that a different fix we are planning for SmartSDR v1.9 where we do not mix the RX audio with the sidetone audio will address this problem.
  • John G3WGVJohn G3WGV Member ✭✭
    edited December 2016
    That's an interesting comment, Tim! I'd like to understand how that would work, given that Rx audio and side tone will need to end up in the same analogue audio feed, to headphones/whatever.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.