Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

FlexControl issues

RickRick Member ✭✭
edited April 2020 in SmartSDR CAT
Ive had problems installing this device under 1.6.17. I've gone through all the processes of removing ghost com ports etc and when the computer first boots up or a plug in the FC the lights flash but then the controller is dead. I uninstalled the FC 64bit PwrSDR version thinking that might be the culprit since I never uninstalled my PwrSDR package used with. My 5KA. Any thoughts about this problem that has plagued me for about 2 weeks now. Rick, W2JAZ

Comments

  • George KF2TGeorge KF2T Member ✭✭✭
    edited February 2019
    Can you confirm the FlexControl option in Radio Settings is checked? Does the COM port (usually COM4) show up in Windows Device Manager?
  • RickRick Member ✭✭
    edited July 2017
    Will have to check when I get home. It showed up on com 3 initially and Flex tech support suggested I move it to a high number and that didn't work either. I'll have to check radio settings. To make sure it's checked which certainly would be an easy fix!
  • WW1SS - SteveWW1SS - Steve Member ✭✭
    edited April 2020
    I had the same issue. I did a manual uninstall per the flex writeup. I then shut down computer and restarted. Did the manual re-install. Then I connected the flex knob. I had to then go into device manager and select it and do a manual driver install and it updated driver and worked fine.
  • Bill-W9OLBill-W9OL Member
    edited October 2016

    I can't get mine to work either. I followed Tim's article and deleted all the old ghost com ports but no joy.

    When I click on FlexControl In Settings a graphic comes up saying it's not detected.

    Anybody have a clue?

  • Bill-W9OLBill-W9OL Member
    edited October 2016

    Mine says 'Not detected'

    Now mine is from back when K6tu made them and I have a small tag I put on mine that says com 13

    Device manager shows Eltima port 13<>port 23   (I remember that we made port pairs on a factor of 10 back then)

    My knob died when I upgraded to 1.6. And so far no joy finding the solution.

    It does light up though. LOL

    I generally fine tune freq with the mouse but would like to use this.

    My install of 1.6 went perfectly the first time except for the Knob.....

    oh one more thing DDuT shows the com 23 enabled and listint the Tuning knob.


    one more question, I'm pretty sure I'm correct in having ...the usb cable on the knob plugged into the computer, not the Flex6K

  • RickRick Member ✭✭
    edited July 2017
    Been having the same problems with FC and have been working with Dudley to try and find a solution. I'm out of town and away from the radio until this weekend when I can try a few solutions that have been suggested following my post. I can only assume that FC was checked in the SmartSDR radio setup pane but won't know until I get back to it. It worked fine under the previous version and before that worked fine under PowerSDR.
    Rick
  • WW1SS - SteveWW1SS - Steve Member ✭✭
    edited April 2020
    As I said earlier: I went into Windows . . . Program Files . . . Flex Radio Systems . . . SmartSDRv1.6.17 . . . 64-bit Drivers . . . Flex Control . . . ran  . . . FlexControlUninstall which is a batch file.
    Shut down computer and restarted it. Went into the same directory and ran FlexControlInstall which is another batch file.

    I then went into device manager and it showed up as USB device.
    I went into properties and driver then clicked "update driver"
    Clicked search automatically for updated driver. It found the Flexknob driver and installed it. It works beautifully after that.

    This is on a Windows 10 machine 64 bit.
  • Rob BlackieRob Blackie Member
    edited March 2017

    I got my flexcontrol today,  radio not arrived yet  :(

    so the VFO knob was not attached and I don't have an Allen wrench small enough to tighten it, also the brushed aluminium was scratch on the knob..  so far, im less than impressed with Flex ...

  • WW1SS - SteveWW1SS - Steve Member ✭✭
    edited April 2020
    I got my 6500 the other day and it had a couple scratch marks on the front black anodized bezel on top. I just colored them with a black marker.
  • Rob BlackieRob Blackie Member
    edited July 2016
    I would expect better at these prices
  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited December 2016
    If you have an issue with a product you purchased, you should contact us directly by submitting a HelpDesk (http://helpdesk.flexradio.com) support ticket rather than using the user Community where you comment my not be seen by us.  

    For details on how to submit a HelpDesk support ticket, please refer to the following URL: http://helpdesk.flexradio.com/hc/en-us/articles/202118688-How-to-Submit-a-Request-for-Technical-Supp...

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.