Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

SmartSDR.XML file

W4EY
W4EY Member
edited January 2020 in SmartSDR for Windows

Tim: 

This is a question about using 3rd Party Software with my FLEX 6500.  Everytime I start the Fldigi application, I have to open the Fldigi RIG configuration window, load and initialize the SmartSDR.xml file. If this file is not loaded and initiated, DAX will not work with Fldigi. I have saved the Fldigi configuration when shutting down the application. However, I  must repeat the SmartSDR.xml load and initialization process with each restart of Fldigi.

 Is there some way that this SmartSDR.xml file can be loaded and initialized with the initial start of Fldigi?  Everything works correctly after this .xml file is loaded and initialized. It is a number of initial steps that could possibly be eliminated.

Answers

  • Brian Morgan VK7RR
    Brian Morgan VK7RR Member ✭✭
    edited December 2018
    I have the same problem with FLDigi but my solution is to simply uncheck the top box, which means you have to "initialise" again, then re- check it, initialise, save and you are good to go. This way you don't have to reload the XML file.
  • Ned K1NJ
    Ned K1NJ Member ✭✭
    edited February 2017
        At the bottom of the page where you have been initializing the .XML file,
    there is a "save" button.  Initialize, then save.  See if that helps.

    Ned, K1NJ
  • Brian Morgan VK7RR
    Brian Morgan VK7RR Member ✭✭
    edited December 2018
    Ned, the Save button does not help. For some reason FLDigi loses handshaking to SmartCat and needs to be re-initialised.
  • W4EY
    W4EY Member
    edited June 2018


    Ned K1NJ

     I have used the Fldigi Configuration Save button after resetting the PTT and .xml file. Also, I use the configuration "save" process in the Fldigi configuration Menu. If I do not check the PTT or CAT boxes and restart Fldigi, it still does not work with the FLEX PTT Port or DAX.  I have tried both ways.. When I get everything set, FLEX CAT and PTT work correctly. It is just a hassle to have to reset these settings each time I run Fldigi.

    Bill W4EY

  • Tim - W4TME
    Tim - W4TME Administrator, FlexRadio Employee admin
    edited March 2017
    I have seen this behavior too.  I am trying to determine what is preventing Fldigi from initializing properly.  This looks to be Fldigi specific as other CAT enabled third-party apps are not showing this behavior.
  • DonS
    DonS Member ✭✭
    edited January 2020
    Make sure the SmartSDR.xml file is located in the Users<name>fldigi.files
    igs directory.  What I have found is when I startup fldigi the CAT doesn't usually work also indicated by the greyed out QSY button so I go into configure
    igRigCat and do an initialize.  Once I do this the QSY button down at the bottom right of the fldigi screen is no longer greyed out indicating CAT is working.  This assumes you are using RigCAT and not Hamlib.

    I have not had any DAX issues with fldigi.
  • Mike Sonn
    Mike Sonn Member ✭✭
    edited December 2016
    I know this thread is old, but I'm just starting the 6300 adventure after using PSDR for the last 5 years.

    In the "PHNE" block on the right side of SmartSDR, I needed to select "+ACC" and "DAX" to make FLDIGI work for all modes.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.