Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

SmartSDR 1.6.17 Installation Problems

Jerry GardnerJerry Gardner Member
edited October 2018 in SmartSDR for Windows
I'm having problems installing SmartSDR 1.6.17 on my system. I've had many previous versions installed without any issues, but when I try to install 1.6.17 on my Windows 7 64-bit system I get the following errors popping up:

Windows requires a digitally signed driver. Driver: Kernel-mode WDM driver Service: FlexRadio Systems Audio DAX (WDM).....

Ditto for the DAX IQ driver.

If I let the install continue, SmartSDR 1.6.17 runs, but DAX doesn't (presumably because it couldn't load its drivers). I tried uninstalling all pieces of SmartSDR/CAT/DAX going back to the very first version I installed and reinstalling 1.6.17, but get the same thing every time with the signed drivers issue.

Is there a fix or workaround for this?

Completed · Last Updated

Comments

  • Jim GilliamJim Gilliam Member
    edited January 2016

    I am sure you will get this reply from many: Completely uninstall SmartSDR using Tim's recommended method and try again.

    Jim, K6QE

  • Jerry GardnerJerry Gardner Member
    edited April 2016
    That's exactly what I did. I followed that method and removed everything, including all of the ports in the device manager, all SmartSDR files, etc. Same problem when I try to install 1.6.17.
  • Jim GilliamJim Gilliam Member
    edited January 2016
    Wow, I hope someone can help you.
  • edited January 2016
    My too, same problem here.   Glenn, VE6GC
  • Jim GilliamJim Gilliam Member
    edited January 2016

    I had problems like that once on 1.5 I could not get Flexvsp to load. I worked with Dudley and he couldn't help. I ended up reinstalling Windows and that did it. A grim remedy, I know.


    JIm, K6QE

  • K5CGK5CG Danny Member ✭✭
    edited October 2018
    Uninstall everything, reboot. Right click on the Installer and "Run As Administrator".
  • KY6LA_HowardKY6LA_Howard La Jolla, CA. Paris and Sablet FranceMember ✭✭✭
    edited January 2017
    You need to run Windows. Update first to load the most recent digital certificates Your version of digital signatures is out of. Date.
  • KY6LA_HowardKY6LA_Howard La Jolla, CA. Paris and Sablet FranceMember ✭✭✭
    edited January 2017
    There is a thread on this reflector on doing just. That.
  • KY6LA_HowardKY6LA_Howard La Jolla, CA. Paris and Sablet FranceMember ✭✭✭
    edited January 2017
    Ed.G, Software Engineer Official Response You probably need to run Windows Update to update the Windows root certificate. See similar thread here: https://community.flexradio.com/flexradio/topics/invalid-digital-signature-on-v1-6-dax-mic-audio-dri...
  • EA4GLIEA4GLI Salvador Member ✭✭
    edited November 2016
    So I recently went through this nightmare.

    I had a system that I upgraded to Windows 10, and I didn't like it.
    I went back to Windows 7. 
    My version of Windows 7 is "old" now so it needed in excess of 200+ updates just to get up to date.

    The Problem:
    If you don't get some of the latest updates Windows will not accept the signature on the Flex drivers.

    However, there is a big issue with Windows updates if you are trying to start almost from scratch (Windows 7 with SP1 was my Win7 install version). It just sits at 0% and never updates. So there is no way to get the necessary update to properly install Flex drivers.

    It took me quite a bit of online research until I found the solution. This is the forum where I found it. Read the whole thing if you want to get more info. http://www.sevenforums.com/windows-updates-activation/382249-windows-update-never-stops-checking-upd...

    The Fix:

    You basicly have to install this update 

    https://support.microsoft.com/en-us/kb/3112343

    And restart the computer so Windows Update will start working again.
    Even after that I had to let the Update run for a solid 10 hours until it was done with all the updates. It took a while to download 1GB of updates and over 8 hours to install them on a Intel i5 laptop with SSD drive.... be patient here.

    Important:
    If you are doing this on a laptop, or even in some PCs, make sure you disable the Sleep after X minutes Power Option of Windows so it stays on all the time. If the computer hibernates or goes to sleep the update process will halt.

    If you have messed around trying to delete update files and other things trying to fix the Windows Update Issue, you might need to Reset the Update Counter

    Instructions to do that here http://www.sevenforums.com/tutorials/91738-windows-update-reset.html

    Microsoft had a previous patch file to the one I linked above. It was the original solution on the thread until a newer version of the patch was made available by Microsoft. If KB3112343 doesn't work you can try this earlier one.

    https://support.microsoft.com/en-us/kb/3102810

    Patch KB 3112343, the first link, works much better, though.

    Good luck.


  • Jerry GardnerJerry Gardner Member
    edited April 2016
    Updating Windows fixed the issue. Thanks everyone.
  • km9r.mikekm9r.mike Member
    edited January 2016
    good deal

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.