Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

FLDIGI 3.23.05, SmartSDR 1.5.1 and Windows 10

KT0AM  - Mark
KT0AM - Mark Member ✭✭
edited May 2020 in SmartSDR for Windows
I've been working with these version of FLDIGI, SDRCat, SDR and Windows 10 in every conceivable combination of COM ports available but can't seem to find the right combination of parameters to make FLDIGI accept rig control from SDR.  I've included a screenshot that contains many of the pertinent parameters but I suspect the problem is between Windows 10 and FLDIGI. If any of you have had a similar issue, any tips, tricks or other suggestions will be welcome.

Thanks in advance and have a peaceful Thanksgiving!

Mark
KT0AM

image

Answers

  • Glenn
    Glenn Member
    edited December 2016
    I was fairly frustrated with fldigi myself, even with Windows 7.

    I use MMTTY now for all of my RTTY.   One can use several MMTTY's at once with different decode algorithms, as long as a different DAX channel is used.

    When working split, I make sure of a different DAX channel for receive and transmit, chosen in the SoundCard options, one for Slice A and one for Slice B.   In the TX options, I use COM 6, set up in SmartCAT, for PTT.

    So far, quick and easy to use and very effective.

    Glenn W0GJ





  • Michael Coslo
    Michael Coslo Member
    edited May 2019
    I can see from the screencap you are at 9600. you should be at 115200 baud



    fldigi and SmartSDR and W10 work great.
  • DH2ID
    DH2ID Dr.med. Member ✭✭
    edited March 2017
    Mark, it's all here, though I don't know about Windows 10, as I use 7 until
    MS is coming up with a bugfree version 12 ;-)

    https://community.flexradio.com/flexradio/topics/tutorial-setting-up-fldigi-with-smartsdr

    73, Alex DH2ID
  • k3Tim
    k3Tim Member ✭✭
    edited May 2020
    I have 3.23.05 under WIndows 10 running here.  

    Under CAT you will need to add a TTY port, use SerialPorts tab and ADD port of type Dedicated.  This will generate two ports, a low and high value, 6 and 16 for example.  In FLDIGI, set RigCat - Device - to use the new (low) TTY port. Six in the is example.  

    I am 99% certain the baud setting is irrelevant to a virtual TTY port. Initialize the setting from FLDIGI.  Sometimes I have to start FLDIGI twice to connect to CAT.  In CAT one can see the connection status in the Port Map tab after hitting refresh. 

    Hope this is helpful to you. 

    GL

    k3Tim

  • Sergey R5AU
    Sergey R5AU Sergey Member ✭✭
    edited April 2017
    Hi Mark, I am operate F6700 with iMAC27 with Parallels with Win10Pro technical preview
    I have no trouble at all with CAT, originally I am ran with DXlabs and FLdigi for digital + FLdigiDXlabsGateway as a bridge between FLdigi and DXlabs. In such setup DXlabs connect to the F6700 directly via API and FLdigi get CAT information from the DXlabs via FLdigiDXlabsGateway.
    However for the split operation I am starting the second instance of FLdigi with Slice B operation but connection to F6700 via SmartSDT CAT COM port, you can see different pics. below where the first is usual my setup for CW (as example just get on 12m VK9WA -  for fun). Pls be sure you have no shared ports between devices or shared ports with hidden ports(unused now but initialized previously -  pls follow with https://helpdesk.flexradio.com/hc/en-us/articles/200883925-Removing-Hidden-or-Ghosted-Com-ports ):

    CW VK9WA 12m:
    image

    FLdigi(left) vial FLdigi-DXlabs Gateway via DXlabs via API, right instance of FLdigi via CAT (com port 10)
    image
    more  with details
    image

    Just FLdigi as Slibe B via CAT (com port 7 as default, just for example)

    image
  • dlwarnberg
    dlwarnberg Member ✭✭
    edited November 2015
    Mike has it..... baud rate should be 115000 not 9600.... the virtual com ports are much faster.. I've had flgigi running for some time with great success and no issues.

    Good Luck
  • M0GVZ
    M0GVZ Member
    edited November 2015
    In FLDIGI set the radio to TS480 if you get really stuck. The Flex 6000 series are fully TS480 CAT command compatible so any program that does not support Power/SmartSDR or Flex Radios at all you can use the Kenwood TS480 as a fallback.
  • Tim - W4TME
    Tim - W4TME Administrator, FlexRadio Employee admin
    edited December 2016
    It really makes no difference what the baud rate is.  There is so little data going across the connection, there is no appreciable difference between 9.6k and 115k.  I run Fldigi at 9.6k all the time with no issues.

    And actually, virtual com ports have more latency (are slower) than hardware UARTs.  Dave, W1HKJ had to put a com port initialization delay in Fldigi to accommodate for the  virtual com port latency in order for them to connect reliably when Fldigi started up.
  • KT0AM  - Mark
    KT0AM - Mark Member ✭✭
    edited March 2017
    Thanks to all who responded with suggestions and information. I've tried some of the recommendations but to no avail, Windows 10 success continues to elude me. I've decided for now to drop back to a Windows 7 box and success was immediate. However, I'm determined to get digital modes up and running on Win10; once successful I will publish the process. Thanks again for all of your help and assistance... Cheers!

    Mark
    KT0AM
  • Michael Coslo
    Michael Coslo Member
    edited May 2016
    I'll be posting my Youtube video on that very thing soon, so if you get results and it's something I don't know about - I definitely want to hear what you did. If I get the video up first, maybe that will help. It's a race now! hihi


  • DH2ID
    DH2ID Dr.med. Member ✭✭
    edited December 2016
    Mark, the biggest problems with Windows 10 are the virtual sound and com
    port cables. Deleting and reinstalling them seems to help. I wish you good
    luck with your digital modes on 10. I keep to Windows 7 and try 10 out on a
    separate notebook. 73, Alex DH2ID
  • Jerry W2TXB
    Jerry W2TXB Member ✭✭
    edited February 2017
    Mark, as I look at the posted pics of your setup, my (Win-10/64) setup and config are the same as yours, except for my using COM4 rather than COM5. Can you swap what is on your COM4 and COM5 to see if anything changes? Is something else tying down your COM5? The reason I asked is that when I was using Windows 7, I tried adding the Internet Labs DVAP to the same PC my Flex was using, and it stopped the Flex from working. Once I removed the DVAP (it would only do COM4), all was well again. As Tim pointed out, 9600 baud is OK; my setup defaulted to that and I never changed it.
    image

    image

    The one thing that had me fooled for a moment was that my "DAX" button on SSDR was not initially selected... drove me nuts for a few minutes.
  • KT0AM  - Mark
    KT0AM - Mark Member ✭✭
    edited March 2017
    Thanks for the suggestion, Jerry. I've tried creating multiple virtual COM ports and using every one of them with no success. And, Michael, you win the race! I'm ready to shamelessly steal a solution from anyone who works through the Windows 10 issues.

    I did notice one thing during my experimentation that might be a clue... I noticed that as I created the virtual COM ports, and then looked at them in the Win10 Device Manager view, they were showing up as "Not correctly installed". I didn't have time to investigate further but it looked like something might have been incorrect with the creation of the virtual COM port. Maybe security protection? I did not run SDRCat as Administrator, maybe that's the next step. I'll try to get a screen shot up in the day or so.

    Cheers!
  • Tim - W4TME
    Tim - W4TME Administrator, FlexRadio Employee admin
    edited December 2016
    The virtual com port software and the SmartSDR control panel are separate software packages so running it as admin will not have any effect on the virtual com port.  I recommend you open a HelpDesk ticket if you don't have any luck soon.
  • Michael Coslo
    Michael Coslo Member
    edited May 2016
    Okay - I posted it. I have another topic here where I make note of some details, but might as well post the link in this thread as well

    https://youtu.be/IVOhj244e30

    - 73 Mike N3LI- 

  • KT0AM  - Mark
    KT0AM - Mark Member ✭✭
    edited February 2017
    Top notch video, Mike, tons of good information in a very clear presentation. Thanks for putting in the time!

    Cheers!
  • Jim Ricker
    Jim Ricker Member ✭✭
    edited November 2015
    Mike great how to video I am up and running with Windows 7. Took about 10 minutes. Just had to shutdown both programs after I made the changes Restarted SDR first then FLDIGI and bam there it was. Again thank you for your effort. Jim K6CEF

  • KF4HR
    KF4HR Member ✭✭
    edited February 2017
    Great video Mike.  Much appreciated!

    Butch - KF4HR

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.