Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

ThumbDV connected to a PC

Mark Erbaugh
Mark Erbaugh Member
edited February 2020 in Third-Party Software
Has anyone connected their ThumbDV directly to a PC and got it working? I downloaded the DutchDstar software which appears to be the recommended PC software, but I can't get it to work. The latest non beta version doesn't have an option for ThumbDV and the beta version keeps crashing for me, I've tried both Windows 7 and 10.

Answers

  • Bob N7ZO
    Bob N7ZO Member ✭✭
    edited February 2017
    Hi Mark,

    I have used my ThumbDV successfully with Dutch*Star "DV Node for Windows" version 1.5.8 Preview 3.

    Make sure you set the baud rate to 460800 if you have a recent ThumbDV.

    73, Bob, N7ZO
  • Cal  N3CAL
    Cal N3CAL Member ✭✭
    edited March 2017
    Mark I have my ThumbDV working on my Win10 system using the Beta version 1.5.8-3.  It crashed the first time because the baud rate was set to 230400.  Setting it to 460800 should do the trick.

    Cal/N3CAL
  • Mark Erbaugh
    Mark Erbaugh Member
    edited February 2020
    Thanks for the info. The problem was my Baud rate. I'm listening to the International D-Star net of REF 01 C right now.
  • N7BCP
    N7BCP Member ✭✭
    edited July 2017
    Baud rate change fixed my Dutchstar crashes also, thanks.
  • Andrew VK5CV
    Andrew VK5CV Member ✭✭
    edited February 2020
    Mark,
    I am having trouble with DStar on HF with the 6500 and am trying to test the dongle on WinDV.
    Can you please put up your settings for REF01c?
    I am not getting very far.
    Andrew de VK5CV.
  • Roy Laufer
    Roy Laufer Member ✭✭
    edited February 2020
    I have tried to get it to work on my boutique shop Windows 7 system (yes, the latest version of WinDV, and I checked that the ThumbDV is plugged into the PC). The window opens up and locks up. It uses about 6-7 % of my CPU cycles doing nothing visible until I close the window.

    Any thoughts?
  • Mark Erbaugh
    Mark Erbaugh Member
    edited October 2015
    I was getting lockups when I had the ThumbDV baud set to 230400. Setting it to 460800 fixed things for me. If you look on the NWDigitalRadio website it says that the Rev A version of the ThumbDV next 460800.
  • Mark Erbaugh
    Mark Erbaugh Member
    edited October 2015
    Under Options:
    Callsign: N8ME, cake sign suffix letter blank.
    Auth Call: blank
    Enable Slow Mode: not checked
    Enable Logging: not checked
    Call Lig Size 100

    Callsign Server AA4RC
    RF Device: ThumbDV, COM3 460800 baud
    Callsign N8ME / <blank> LOCL

    Under Settings: just the defaults
  • Roy Laufer
    Roy Laufer Member ✭✭
    edited October 2015
    I tried both 460800 AND 230400 using the device manager... No joy!
  • Mark Erbaugh
    Mark Erbaugh Member
    edited October 2015
    The baud rate needs to be set in WinDV.
  • Bob N7ZO
    Bob N7ZO Member ✭✭
    edited December 2016
    image
  • Roy Laufer
    Roy Laufer Member ✭✭
    edited May 2017
    Thank you, Mark and Bob.

    One of the problems was that I couldn't get to the Program Options window in the first place  - the program would lock up on the initial window!

    Removing WinDV and re-installing accomplished nothing. I had to uninstall it and then comb thru the registry, with regedit.exe for any entry of "MicroWalt" and delete them, then re-install WinDV!

    On my Windows 10 laptop, the driver did not default to VCP mode and it had to be enabled by me, then it chose to use a comm port already in use by Smart SDR CAT! After much "twiddling" I got all the settings straight and it seems to work on my Windows 10 laptop (no traffic on the Repeater when I tried it, so I am not 100% sure, but it looks good). I wasn't ready to reboot the big desktop and clear its comm port confusion (it so far doesn't recognize the ThumbDV's comm port, but that be fixed by a reboot...)

    I don't know how anyone would have figured this out if they hadn't monkeyed around with Windows system for the past 30 years....

    It goes to show, it's always something!

    73,
    Roy, AC2GS

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.