Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

FlexControl Not Responding after Windows 10 Upgrade

Joel Weder
Joel Weder Member
edited August 2020 in FlexControl
I got crazy a couple of days ago and let Windows 10 install.  (Had recently done a backup so no worries there) Only issue found so far was that my FlexControl was dead. (PowerSDR and other software are running perfectly) I could see it in Device Manager but it would not respond. Got it running eventually, but not exactly sure how...

Uninstalled it from Device Manager, disconnected it, waited a minute, reconnected. got a nice window telling me the driver was being installed, and then it reappeared in Device Manager as a serial port device. No improvement though...

FlexControl was assigned to Com3. Still not working even though Device Manager shows it as "working properly" and the three LED's all turned on when I booted up the computer. Just for the heck of it I tried changing the Com port used by the FlexControl from 3 to 5. Still no life however. Port settings are 9600 8N1 No Handshaking. In the FlexControl window in PowerSDR the Auto Detect box IS checked.

Last thing to try was to uninstall everything and start over. So I uninstalled PowerSDR, uninstalled the FlexControl driver, disconnected the FlexControl, rebooted, re-installed PowerSDR and verified it works, shut it down then re-connected the FlexControl. Its driver re-installed "apparently" normally, but STILL PowerSDR will not do anything when I spin the wheel or push a button.

After all that, over a period of a couple of days, I waited to see if anyone here or on the Yahoo group would have a suggestion. (nothing useful so far) But when I by reflex grabbed the FlexControl and gave it a spin just now, it WORKED!! Maybe just ONE more computer reboot was all it took. I really don't know at this point.

Joel, VE6EI

Answers

  • Villas - PY5VB
    edited August 2015
    No problem here. I finish upgrade from win8.1 to win10 and 100% except my RTL2838 dongle SDR drivers, but I reinstall it and OK. I use PowerSDR 2.7.2 and all OK.
  • John
    John Member
    edited June 2018
    No problems here either with flex 3000 and flex 1500. I also removed my win7 leftovers when I did a disc clean and defrag and got a warning that I would not be able to use win7 again unless I re-installed it. Just a thought remove the flex control then reboot and check if powersdr works without the flex control, then re-insert the flex control and see if that helps.
  • Tim - W4TME
    Tim - W4TME Administrator, FlexRadio Employee admin
    edited March 2017
    Joel - Manually reinstall your FLexCOntrol driver using this procedure located on the HelpDesk
    https://helpdesk.flexradio.com/hc/en-us/articles/205677445-How-to-Manually-Reinstall-a-PowerSDR-Flex...
  • Villas - PY5VB
    edited August 2015
    Sorry. We have a problem too. After upgrade from win8.1 to win10  my FlexControl sametimes work sametimes not.  I desisntall all FLEXRADIO software and reinstall again but same behavior. I create a litle software with visual studio to test FlexControl port and when windows 10 peek this port name sometimes is COM3 (correct and work), sometimes is COM3H, COM3y, COM3X, COM35, COM34, COM3 with a chinese caracter and FlexControl doesnt work. I do step by step manualluy reinstall procedure by Tim. Look COM3 in this box with test windows:
    image

  • John
    John Member
    edited June 2018
    I wonder if another driver is trying to take over as the chinese character is out of place. Very strange unless, windows 10 is downloading the nearest driver it can find. Perhaps the solution is to stop automatic downloads of the Flex Control driver. An unsigned driver could cause a problem. Tim, are all flex drivers approved and stamped by My Gates ?
  • Bob - WD8KND
    Bob - WD8KND Member ✭✭
    edited March 2017
    Ever since I upgraded to Win 10, I have had my FlexControl stop working off and on. I don't know why this is, but it never once did it before I upgraded. The fix is to close SSDR and reopen it. Have no idea why, but this works.
  • Tim - W4TME
    Tim - W4TME Administrator, FlexRadio Employee admin
    edited December 2016
    The intermittent initialization of the FlexControl is a previously reported issue with SmartSDR v1.4.16 and is not necessarily related to Win10.  We are working on this issue for the next release of SmartSDR.
  • Tim - W4TME
    Tim - W4TME Administrator, FlexRadio Employee admin
    edited December 2016
    Our drivers are digitally signed and work with Win10.  It is the upgrade process that is breaking the drivers.
  • Jon Schumacher
    edited June 2018
    I can't get the Flex Control to work either.  Using Flex 1500 and power SDR 2.7.2.  Tried uninstalling and reinstalling per the instructions several times with no luck.  Tried 32 bit and 64 bit both. 
  • Tim - W4TME
    Tim - W4TME Administrator, FlexRadio Employee admin
    edited December 2016
    Make sure that the com port the FlexControl uses is not conflicting with a virtual com port.  Setting it to a value of COM200 should move it far out of the way
    https://helpdesk.flexradio.com/hc/en-us/articles/202479329-How-to-Change-the-Com-Port-Assignment-for...
  • John
    John Member
    edited December 2016
    yes, windows devices will take any port available and not release them properly when they are not in use. This can cause many headaches. Sometimes a reboot is needed with the device hogging the port disconnected, this then free's up the port.
  • Tim - W4TME
    Tim - W4TME Administrator, FlexRadio Employee admin
    edited December 2016
    What I did was removed all of the "ghosted" com ports after I upgraded to Win10 and before I installed SmartSDR again.  Even the FlexCOntrol ports.
    https://helpdesk.flexradio.com/hc/en-us/articles/200883925-Removing-Hidden-or-Ghosted-Com-ports

    This cleans up some of that USB "mess".
  • Jeffrey Fritz
    Jeffrey Fritz Member
    edited March 2017
    After upgrading to Windows 10, I have the same issue as others have reported with FlexControl. Windows 10 Device Manager sees it the FlexControl lights up all three indicators when it is plugged it. Device Manager allows me to change Com Ports, but Power SDR v 2.7.2 doesn't know that it's there. (The control itself doesn't work and all the options to assign functions in the FlexControl Window in PowerSDR are grayed out.)

    I've tried all the solutions offered above but nothing has worked. I tried a complete uninstall and reinstall per Tim, W4TME. I've rebooted, changed the Com port, etc. all to no avail.

    Everything else related to PowerSDR is running just as expected under Windows 10. Any help or insight would be appreciated.

    Thanks!
  • Tim - W4TME
    Tim - W4TME Administrator, FlexRadio Employee admin
    edited December 2016
    I recommend you submit a support ticket via our HelpDesk (https://helpdesk.flexradio.com/hc/en-us) so one of our Support Engineers can assign you a case number and investigate the issue.

    Opening a HelpDesk support ticket will ensure our highest level of customer service we can provide.  For details on how to submit a HelpDesk support ticket, please refer to the following URL: http://helpdesk.flexradio.com/hc/en-us/articles/202118688-How-to-Submit-a-Request-for-Technical-Supp...

    Once the support ticket is submitted, a support engineer will be in contact so we can work on the issue.

  • Jeffrey Fritz
    Jeffrey Fritz Member
    edited August 2015
    Will do and thanks, Tim.
  • Jim K4JAF
    Jim K4JAF Member ✭✭
    edited January 2018
    Same problem here with Win 7 and now Win 10.  Usually going into settings on 6500 and disable and enable the flex control will toggle it back on after a reboot of the computer.  I know Flex is working on this problem so sure a solution will be out soon.  73s Jim K4JAF
  • Jeffrey Fritz
    Jeffrey Fritz Member
    edited August 2015
    Thanks, Jim. I heard from Dudley and I know that FlexRadio is working the issue.
  • Lars Pettersson
    edited August 2015
    Hi
    i did all above nothing helped. Then i did  as Tim said i changed comport to  255  reboted  and now it works.

  • Jeffrey Fritz
    Jeffrey Fritz Member
    edited August 2015
    Certainly worth trying. I do that later this morning. Thanks for passing that along.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.