Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Transmitting off frequency - again . . .

Ken - VE5KCKen - VE5KC Member
edited May 23 in SmartSDR for Windows
UPDATE - had the same problem again...

* I found the problem...  not a user problem either.. *

Further to my previous post -
https://community.flexradio.com/flexradio/topics/transmitting-off-frequency

Here is some more info, do we have a problem that could affect others?

All went fine after doing the factory reset. The next day I started up the 6500 then SmartSDR. I tuned up on forty and was receiving fine. I clicked [MOX] and to my surprise I was back to the same problem with my TX being low in frequency.

This time I didn't go straight to the factory reset and took a bit more time  checking things out. I played with RIT & XIT..  not the problem.

Then I found the problem.. an easy fix.. but why is this happening?

So here it is...  When I save a global profile, a transmit profile is saved as well with the same name. This profile is shown in the drop down list under [Tune Pwr]. For some reason when SmardSDR started up it switch to one of these profiles, instead *Default, for example.

When one of those TX profiles saved with a global profile backup name is selected, the 6500 transmit is of frequency from receive. Select Default or any of the original TX profiles and the problem is gone.

Restoring a previously saved global profile backup does not cause this problem. It is only when one of the backup files that show up in the TX profile list are selected. I have done nothing to cause this to happen.

So why is this file being put in the TX profile list?  Should they be created? If they are suppose to be created, what is making them cause this problem with the TX frequency? (there was no problem with the backed up settings)

Well at least now I know what to look for... I don't think this should happen..  It sure adds an element of confusion for this OM.. hi..


Comments

  • k3Timk3Tim Member ✭✭
    edited May 23
    Hi Ken,

    Good to hear you tracked this down....

    I have tried this and can't duplicate.  A global profile is saved but the name does not show up in the drop down list (transmit profile).  No duplication happens.  There is a "temp" name in both lists but not using those ones.

    Be that as it may, thanks for the heads up.


    Regards,

    k3Tim

  • Walt - KZ1FWalt - KZ1F Member
    edited May 23
    Independent of some errant profile being created, how does that cause a negative xit value?
  • k3Timk3Tim Member ✭✭
    edited December 2016
    Not sure.  I should have stated the XiT offset problem was NOT observed.  I tested several times in CW mode and Xmt always was zero-beat to the Rcv frq.
  • Ross - K9COXRoss - K9COX Member ✭✭
    edited June 2017
    I also see the names of my global profiles showing up in the transmit files list however no detrimental affect is noticed.
  • Dudley-WA5QPZDudley-WA5QPZ Inactive Employee
    edited March 2018

    Ken - VE5KC,

    I think what happened is that went you did the Factory Reset ,  you also reset the Frequency Calibration of the radio.   So after the Reset,  you should re-run the frequency calibrations of the radio..       Also remember if you Save a profile, or Save changes to a profile the XIT/RIT settings that you may have changed will also be remembered.. 



  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited March 2017
    Let me address your questions.

    "So here it is...  When I save a global profile, a transmit profile is saved as well with the same name. This profile is shown in the drop down list under [Tune Pwr]. For some reason when SmartSDR started up it switch to one of these profiles, instead *Default, for example."

    This is by design.  If you save a Global Profile and you do not have a Transmit profile selected at the time, SmartSDR creates a TX profile with the same name as the global profile.  This is because a TX profile is a child component of the global profile (subset).  The radio will restart in the last operational state it was in before your shut down.  This includes the TX profile.  Otherwise the radio would not be in the same state when it starts up as it was when it shut down.  This is a cornerstone of the radio persistence.

    Restoring a previously saved global profile backup does not cause this problem. It is only when one of the backup files that show up in the TX profile list are selected. I have done nothing to cause this to happen.

    When you select to manually load a global profile, it will load the TX profile that was associated with the global profile.

    "So why is this file being put in the TX profile list?"

    I explained this above.

    "Should they be created?" 

    Yes

    "If they are suppose to be created, what is making them cause this problem with the TX frequency? (there was no problem with the backed up settings)"

    I can't tell unless there was a parameter you saved that is causing this problem.  

    I recommend deleting both the TX and global profile that is causing the issue.

    Select a known working TX profile from the drop down list
    Create a new global profile.

    Then retry your test.  If it fails. then open a HelpDesk support ticket so we can investigate further.

  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited December 2016
    The frequency offset data is not reset with a factory reset.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.