Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

POWERSDR CAT -> LOSING CAT

Hello my friends.
Using powersdr 2.7.2 with flex-3000.
Each time i load powersdr i have to go to setup -> cat control -> and click on Enable CAT.
PowerSDR is not remembering this option for me.
What do you think?
am i doing something badly?
A lot of thank's.

Comments

  • DH2ID
    DH2ID Dr.med. Member ✭✭
    edited March 2017
    Ruben, that could be a Windows user rights/permissions problem. Which Windows version are you using? Are you using a virtual cable and what program are you working with to control PowerSDR?
    I never had problems with my Flex-3000, VSPE and Ham Radio Deluxe.
    I always log on as administrator and leave all filtering and the rights management to my trusty Linux firewall PC...
    Saludos,
    Alex DH2ID
  • Ruben Navarro Huedo
    edited April 2015
    Hello Alex. 
    I am using windows 7and yes...i am running like administrator.
    I am using vspmgr but this is not the problem.
    I don't understand why powersdr doesn't save "enable cat".


  • DH2ID
    DH2ID Dr.med. Member ✭✭
    edited March 2017
    Ruben, you could try to set CAT with the correct port and baud rate, then save the Flex database and reload it after restarting pc and the Flex-3000.
    Look up your port settings, Windows is still notorious for it's COM port management.
    Another thought would be to try a new setup on another PC. I use an old notebook
    fort these trials.
  • Tim - W4TME
    Tim - W4TME Administrator, FlexRadio Employee admin
    edited March 2017
    PowerSDR saves this configuration value in the XML based database that is specific for the version of PowerSDR you are using.  It is stored in the %APPDATA%FlexRadio SystemsPowerSDR v2.a.b folder.  There are several databases there, as some are backups for recovery purposes.  If it is only the COM port enable value that is not being saved and other parameters are, then the issue is not the database being saved incorrectly, but the issue is your virtual com ports.

    PowerSDR will try to open the virtual com port that is referenced in the database.  If it cannot enumerate it, then it will disable the CAT functionality, as you are observing. So you need to investigate why the virtual com port is not being enumerated by Windows. I can tell you this is not an easy thing to figure out, but if you are using VSPManager, you have to create the virtual com ports by manually running the VSPManager console as administrator and not assume it will inherit the elevated rights of the user.  I think this is in the VSPManager doc somewhere.  If this doesn't fix it, you can always try a different virtual com port software package.  VSPManager can be quirky. 


  • Ruben Navarro Huedo
    edited April 2015
    A lot of thank's for all your answer.
    Problem is powersdr is not saving this option in the database.
    I have opened the database with a text editor and this option is false.
    I changed it to True and now each time i load powersdr it is enable.
    I have the problem ONLY with this option becouse i have tried change cat serial port or other powersdr option and it is saved in the database.
    I don't know really what is the problem but editing by hand the database is solved !

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.