Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Flex 6300 locks out for a few seconds

2»

Comments

  • Dave KD5FXDave KD5FX Member ✭✭
    edited May 2018
    See my comment on this above. If you have another PC running SSDR on your network it could be causing the problem. Shutdown ALL but one PC and see if the problem clears up.
    73, Dave KD5FX
  • Duane_AC5AADuane_AC5AA Member ✭✭
    edited December 2016
    Thanks, but no other PC's in the house running SSDR.
  • Jim K4JAFJim K4JAF Member ✭✭
    edited January 2018
    No other PC either..  No stutters or stops until this evening.  Still continues every 15 minutes or so for 5-10 seconds..   Jim K4JAF
  • Steve W6SDMSteve W6SDM Member ✭✭
    edited April 2015
    I don't think the radio will get a bad reputation.  People have been bad-mouthing Flex for a long time but their numbers have been small compared to the advancement and successes that have been achieved over time. 

    I have a brand new Yaesu FT400DR that's at the factory for warranty repair.  It's a great radio - it just decided to stop putting out RF.  It would only be a bad radio if the factory didn't honor their warranty.

    Flex is cutting edge technology.  Much of what we're using today didn't exist a year ago.  Of course there are going to be glitches.  I've been a Flex customer for long enough to know that those will eventually get fixed.

    I have a feeling that we will see a problem for the freeze up problem pretty soon just like we have seen fixes for the other problems that have come and gone.
  • Mark GriffinMark Griffin Member ✭✭
    edited June 23
    This is an interesting development. If this was not happening with prior versions of SmartSDR then it is definitely a software issue versus a hardware issue. I do not have a flex as of yet. And I am considering a 6300 as the flex of choice. When it comes to SmartSDR, does flex have where people can download a beta version of the SmartSDR and try it out before it is finally released?

    I would certainly hope they do that. I have an Elecraft K3, and I know when they have a firmware upgrade, they have the beta software where you can download it and install it. But of course, there are the warnings that you may have issues. Once, all the bugs are worked out, then they release the final version. I am not a programmer but you would think that if 1.43 was beta tested, that the freezing problem would have been noticed and from that not releasing the upgrade with those issues until it was fixed. Mark KB3Z
  • Duane_AC5AADuane_AC5AA Member ✭✭
    edited December 2016
    Mark, while I'm experiencing this problem (hopefully the workaround may be working for me), I think you'll find that FLEX is very good at responding to problems, and, most likely, this will be history by the time you order one.  While they have a Beta test team, I think it might be a managed team and then the code is released once it gets through that gauntlet.  I can't address how this one slipped through, but it doesn't affect all users and may be configuration sensitive.  Guessing...

       73, Duane
  • Ken - NM9PKen - NM9P Member ✭✭
    edited December 2016
    The strange thing to me is that I didn't begin experiencing this until after I had been using the new update for about a week.  So I don't know if a Windows update changed something, or there is a cumulative memory leak, or if I finally got around to playing with DAX and opened multiple DAX channels "just in case" i needed them.  This bug does seem to be an odd little critter!
    A couple of nights ago I was running "latencymon" while talking with my 75 Meter ragchew bunch and noticed several times that about 5 seconds after a freeze, there was a spike in the latency meters.  I am also getting a high number of page faults.  In previous tests, the latency spike didn't show up as regularly.   Since I never ran "latencymon" before the update, I have nothing to compare it to.

    I will test it out more thoroughly on my day off, Friday Morning.

    Ken - NM9P
  • KY6LA_HowardKY6LA_Howard La Jolla, CA. Paris and Sablet FranceMember ✭✭✭
    edited April 2015
    Mark Yes there is a closed Alpha Test team which tests the software before it is released into the wild. Flex terminated the public Beta program some. Time ago The intermittent freeze issue does NOt affect most users which I suspect. Is why it slipped thru the cracks. It seems to be mostly with some few 6300 when Unused DAX channels are left open. It is on the bug tracker list
  • Mark GriffinMark Griffin Member ✭✭
    edited May 2016
    It's interesting to see that this bug effects both 6300 and an occasional 6500. I haven't seen anyone with a 6700 effected as of yet.

    Perhaps Flex should consider having two groups of testers on program releases. One would be the closed Alpha Test, and perhaps looking at those within the Flex Community who maybe are very active on the Flex Reflector.

    I'm glad to see that the tech staff is aware of the issue and is working on a fix as soon as possible! Mark KB3Z
  • ai6reai6re Member
    edited April 2015
    I took your advice and found DAX Control Panel had Channel 1 selected for Receive and TX. I clicked both off and have not had the problem with the radio freezing since. I ran it for a couple hours yesterday and again today with no problem. As long as I don'e need to run DAX this appears to have circumvented it for SSB. Thanks,
  • Duane_AC5AADuane_AC5AA Member ✭✭
    edited December 2016
    Likewise for me - but I only have about an hour to 90 minutes of operating time collected at the moment.  This may be a good workaround for non-digital modes.  One of the worst places I've seen it is on RTTY using FLdigi, and for that DAX is required.  This is a hopeful sign - at least root cause may be on the way to being  isolated.
  • Mark GriffinMark Griffin Member ✭✭
    edited May 2016
    So if I understand this correctly, one will use DAX when they are operating digital modes. But it doesn't necessarily need to be activated when operating SSB or CW modes. I have learned something new today! Mark, KB3Z
  • Duane_AC5AADuane_AC5AA Member ✭✭
    edited December 2016
    That is correct - DAX is the audio input (similar to feeding audio to your SSB signal through a digital interconnection device).  Apparently this bug is associated with running an active DAX input, whether it's actually in use or not. 
  • Ken - NM9PKen - NM9P Member ✭✭
    edited December 2016
    Yes, that is the point of the Digital Audio Exchange (DAC) -- it is a digital pipeline for sending audio to and from digital programs such as FLDigi, MMSSTV, FreeDV, et. al. 

    The only exception when running Phone modes would be if you wanted to use the Digital Voice Keyer functions in various contesting programs, or if you wanted to use outboard Broadcast Audio processing software such as Stereo Tool.  (http://www.stereotool.com)


  • Duane_AC5AADuane_AC5AA Member ✭✭
    edited December 2016
    OK, I've put a couple more hours on the 6500 running 1.43, and by disabling the DAX channel when in CW or SSB mode I have not had a single freeze.  I normally would have seen several freezes in that time. 
  • John LeonardJohn Leonard Member
    edited April 2015
    Sudden onset of the same problem... I have had the 6500 for 2 weeks now.... first week was fine but over the past few day has become MUCH worse.... The last time the radio took a full minute to shut down..... Help!
  • John LeonardJohn Leonard Member
    edited April 2015
    I also have been "freeze free" since disabling DAX while running 1.43. Fingers crossed.
  • ai6reai6re Member
    edited April 2015
    I decided to see if I could cause this problem to come back buy turning DAX back on but this does not bring the problem back. It appears that once you get rid of the problem you can use DAX normally without bringing the problem back. This could be pretty hard to find. My 6500 is running perfectly since the problem went away by disabling DAX.
  • Duane_AC5AADuane_AC5AA Member ✭✭
    edited December 2016
    I've had the exact same experience here with my 6500 - once disabled DAX for a bit, each time after using it, but now I've had it back on now for several days with no recurrence,  You're right - this one will be a tough one to chase down because it appears to be random or difficult to predict.
  • Roy - W5TKZRoy - W5TKZ Member
    edited December 2019
    I had been using 1.3 so I installed 1.4.3 and was unable to use it because of the screen freeze. I dropped back to 1.4.0 and had no problems with the freeze but was unable to use HRD. I replaced my computer in January with a Gigabyte Gamers Motherboard but I went cheap on the memory at 4 gig. 

    On April 23, after consulting HRD, I added an additional 4 gig memory and I am so far, pleased with the 1.4.3 and HRD.

    No more dropouts, stutters, or just plain no operating. I don't do remote yet.

    Lesson learned....

    Roy - W5TKZ  
  • EduardoCarvalhoEduardoCarvalho Member ✭✭
    edited July 2018
    Hello,

    I installed 1.4.11 and the issue is still present. I checked the release notes and it looks like the issue was not addressed in this release. The reproduction steps are still the same.

    I just wanted to provide an update. 

    Is Flex planning to address this issue prior to CQ WPX CW 2015? This issue is going to prevent us from running the contest with CW Skimmer.

    Thank you,

    Eduardo - KC8R
  • Duane_AC5AADuane_AC5AA Member ✭✭
    edited December 2016
    Agreed - in the first 5 minutes of operating on 1.4.11, my 6500 froze up for about 10 seconds while running FLdigi.  It has not done this on 1.4.3 for several weeks now after I disabled the DAX channel while not using it.  I'll try doing that again for a while and see if that "fixes" it.  I did a full uninstall of 1.4.3 before installing 1.4.11 just to be sure no driver issues.  (With Revo Uninstaller I got rid of all remnants of the old install.)  So, that's apparently not part of the problem.  The randomness of how it occurs is really what makes this one a ****!  (In case it helps, I should add that after a few days of disabling and re=entabling DAX 1, I elected to just leave it on, and never had a problem after that, until this evening after installing the new software.)  For whatever it's worth.
  • WimWim Member ✭✭
    edited May 2015
    I started seeing this lockup oif several seconds after installing 1.4.11, I never had this issue before. I'll try disabling DAX channel 1 for a while to see if it improves. I would say every 5 or 10 minutes it locks for a few seconds
  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited July 2018
    We are working on this issue for the next release of SmartSDR. 
  • EduardoCarvalhoEduardoCarvalho Member ✭✭
    edited May 2015
    Tim, thank you for the update. Eduardo - KC8R

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.