Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

External keyer on accessory port doesn't work

IW7DMH, Enzo
IW7DMH, Enzo Member ✭✭
Hello,

I built a db15-3 plug for my 6300 accessory port. I would like to wire my contest interface (the one you can see below) connecting positive wire to pin 4 and ground to pin 5. I am sure that all connections are correct as I checked them more times using a digital tester.
The problem is that my 6300 isn't keyed in any way: nor connecting the interface nor connecting a straight key.
I don't think I need some trick configuration somewhere in SSDR as in the manual is stated that pin 4 is always enabled.
Really I can't figure out where I am wrong.
Any suggestions?

Thank you and 73'
Enzo
iw7dmh

image

Comments

  • Ken - NM9P
    Ken - NM9P Member ✭✭
    edited June 2020
    Do I understand that if you short from the + pin and gnd that it still doesn't key the rig? Which ground pin are you using on the DE15 connector? Ken - NM9P
  • Ken - NM9P
    Ken - NM9P Member ✭✭
    edited June 2020
    You might want to consider using an opto-isolator instead of a simple transistor to keep the ground currents separate from computer to rig.
  • Al_NN4ZZ
    Al_NN4ZZ Loganville GAMember ✭✭✭
    edited March 2017
    Hi Enzo,
    I'm using the same circuit to key my 6700 from the PC.  I also have my straight key wired to the +  (pin 4) and GND point.     I used pin 10 on the DE15 accessory connector for ground but 5 should also be fine.  

    The only SSDR setting that affects the keying is the BREAKIN button.  
    OFF -- sidetone only
    ON - sidtone and RF

     Question -- what are you using to connect to the accessory connector?  Did you get make your own cable, reuse a DB15 cable, or use a breakout board?  You may want to double check to verify that your connections to pin 4 and GND are correct.    It's easy to get something reversed......


    Regards, Al / NN4ZZ  
    al (at) nn4zz (dot) com




  • Steve N4LQ
    Steve N4LQ Member ✭✭
    edited March 2017
    Take a paper clip or piece of wire and ground pin 4 of your radio's connector. It should key the rig. 
    Do not try to make a cable from an old VGA cable. 
    I use a cable and breakout from http://www.winfordeng.com/products/brksd15.php
    This will give you easy access to all the pins. He also sells straight through DB15 cables. 
    Steve N4LQ
  • Al_NN4ZZ
    Al_NN4ZZ Loganville GAMember ✭✭✭
    edited December 2016
    Steve,
    Agree on the warning about not using an old VGA cable.  I built an interface box using a cable from Winford.  

    I have a document with pictures, part numbers etc.  It's posted elsewhere -   if anyone is interested contact me at my email and I can send a link.  

    Regards, Al / NN4ZZ  
    al (at) nn4zz (dot) com

  • IW7DMH, Enzo
    IW7DMH, Enzo Member ✭✭
    edited March 2017
    Well, I finally solved :)

    I was using pin 5 for grounding my interface but it didn't worked on my 6300 unit.
    So, before desolder my connector, I made the clip test on pin 10 and it work as expected.
    This time I built my own connector because in my first attempt I tryed to use and old Vga cable, but at the end of my work I found that pin 4 was unused. It seems it happens to most of low quality (or very slim) commercial Vga cable.
    I will also consider to use an opto-isolator as suggested by Ken and to buy a db15 board as Steve suggested.
    Just a note for Flex hardware reference manual editor: on page 34 the connector is printed upside-down (or in my flex 6300 it is mounted upside-down). Also in paragraph 7.4.5 the pin 5 is reported as ground pin but it seems it is not right.

    I am very glad to be a member of this community. It is like a big family.
    Really thank  a lot for your help

    Best regards
    Enzo
    iw7dmh
  • Al_NN4ZZ
    Al_NN4ZZ Loganville GAMember ✭✭✭
    edited December 2016
    Enzo,
    Good deal,  using pin 10 for the ground worked for me too.   I didn't try the other documented grounds,  I just happened to use pin 10.   

     And I also noticed the connector was mounted upside down so that's one reason I suggested double checking the wiring.  

    Most of the VGA cables either have some pins missing or have some pins grounded that you don't want grounded.  They are not usually going to work unless you are willing to open the connector and make some changes.  

    Regards, Al / NN4ZZ  
    al (at) nn4zz (dot) com





Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.