Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

PowerSDR audio and panadapter freezes

I just purchased a used 3000 and am having problems with PowerSDR freezing after a few seconds. I can stop then restart and it will work for a few more seconds then freeze again. About 2 minutes is the longest it has worked

Changing any setting in the audio tab such as buffer size, sample rate or enabling or disabling the VAC will restart the audio for a few more seconds. Doesn't seem to matter if I'm using speakers connected to the radio or using the VAC to listen through the computer speakers.

I've tried 2 different versions of the software with the same results and also tried ending processes for every non essential service. Tried using safe modes and normal and it doesn't work at all in the "low latency" mode. Tried all bandwidth settings also.

I'm running a Toshiba laptop with a PCIExpress firewire card, Win7 home premium 64bit.
All windows updates and drivers are up to date

Can't find anything in the knowledge base or anywhere on the net. I'm new to Flex and PowerSDR and have simply run out of ideas. Any help you can provide would be much appreciated.

Thanks,
Danny AB4TI

Comments

  • Marc Hessel
    Marc Hessel Member
    edited September 2014
    Danny take a look at set-up display make sure you do not have the main FPS display maxed out at 50, that would tax your cpu to the max...just a thought.otherwise I'd contact Dudley..
  • Steven Hess
    Steven Hess Member
    edited September 2014
    Turn off your wifi. 
    Having that on can cause what you are seeing. 
  • Scott AC8DE
    Scott AC8DE Member
    edited September 2014
    If I had to take a stab at the first thing you should look at, it would be DPC latency.  Laptops are notorious for it.  Download this utility and make sure it isn't spiking into the red.

    http://www.thesycon.de/deu/latency_check.shtml

  • Richard G7EIX
    Richard G7EIX Richard - EnglishmaninNC Member ✭✭
    edited March 2015

    What is the model of the laptop? So we can pull the specs and see what processor etc.  And the make and model of the PCI Express card?   I'm going to assume this laptop did not come with the machine and this is the first time you have used it with a 3000.

    Scott is probably on the ball on this one - DPC latency is going to cause this - but so will an underpowered machine and incompatible FireWire chipset.


  • Ken - NM9P
    Ken - NM9P Member ✭✭
    edited June 2020
    Judicious adjustment of several parameters will help:
    1) Reduce the panadapter refresh FPS to 5-15 FPS
    2) Turn off "fill under pan trace" (or whatever it is called... i am away from my rig)
    3) Adjust USB and Receiver DSP Buffer sizes 

    These all reduced CPU loading and latency on my underpowered laptop to make it usable with my 1500 until I was able to upgrade to a better desktop.  

    These are a start.
    Good luck,
    Ken - NM9P
  • Tim - W4TME
    Tim - W4TME Administrator, FlexRadio Employee admin
    edited March 2017
    Danny - you have one or a combination of two issues; excessive system latency caused by DPCs and/or hard page faults or a Firewire adapter that does not have a chipset that can handle streaming Firewire data.

    Neither of these issues are easy to solve for the user who is not familiar with the nuisances of solving this type of system integration issue.  Therefore I have converted this topic to a support HelpDesk ticket (http://helpdesk.flexradio.com) for expedited issue resolution.  If anyone else is experiencing an issue similar to this one, please submit a HelpDesk support ticket for issue resolution.
  • Danny Mullins
    Danny Mullins Member
    edited June 2020
    First I want to thank everyone who responded. Really great to see this much help available.

    Everyone was correct that it was a latency problem. I downloaded the "latency checker" app and it was obvious right away. There were regular readings over 4000 with spikes over 15000. I loaded PowerSDR and watched the latency graph and ,sure enough, it froze just as a large spike appeared This allowed me to trouble shoot the problem by disabling drivers and immediately seeing the result.

    I finally found a process called HDMICtrlMan.exe that was causing the trouble. This is a Toshiba only process so it might not be much help in the future but at least it's here just in case someone has the same problem.

    Thanks again and best 73
    Danny AB4TI
  • Richard G7EIX
    Richard G7EIX Richard - EnglishmaninNC Member ✭✭
    edited August 2016

    Excellent news!  And way cheaper than buying new hardware!  Welcome to the Flex world!

  • Ken - NM9P
    Ken - NM9P Member ✭✭
    edited December 2016
    That is good news.  And thank you for sharing your solution.  It will be helpful to others.  In fact, perhaps to my own station, since I run my Toshiba Satellite when I run the 1500 portable!  

    So... you have been helped and have helped others too, with the same set of posts.  Welcome to the Flex Community!

    Ken - NM9P

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.