Joining the Community is Easy!

Our community is a great place to share and connect with other people that are passionate about the same things you are. Get your questions answered, share your ideas and feedback, get your problems solved, and give back by helping others! It only takes a minute to get started.

Get Started Today

  • Step 1: Sign Up
  • Step 2: Follow Categories

Conversations

Conversations 1 - 20 of 701
Photo of K7JV
HELP - No side tone o CW
HELP!!!   Flex-6400 w/Maestro - On CW I no longer have a side tone while keying the Bencher.  New Flex system as of about two weeks ago. ...
  • 1 me too
  • 7 replies
  • Problem
  • Solved
Photo of jim
FT8 problem on 60 meters
I'm running FT8 on all bands except 60 meters. Using a 6500 and latest version of wsft-x. I havelooked at a lot of post about problems.  ...
  • 1 me too
  • 7 replies
  • Problem
  • Solved
Photo of Ken AG2K
can not connect
This is a new problem that just started on only on of my laptops. I'm running a 6600 with a lenovo laptop with Win 10. This was working f...
  • 1 me too
  • 6 replies
  • Problem
  • Solved
Photo of K6ANP
Flex 6600m
Flashing red power button when I operate the push to talk on the mike or when I hit the dit or dah on the paddle. When I first turn on th...
  • 1 me too
  • 7 replies
  • Problem
  • Solved
Photo of Bob W8RMV
No Tx Menu
While operating my 6400M in rig mode, when I push in the Mic/Speed PWR knob to access the Tx Menu, nothing happens.  According to pg 145,...
  • 1 me too
  • 5 replies
  • Problem
  • Solved
Photo of Andrew John
MARS for v3.0
I HAD mars UPDATE ON MY flex 6500. sINCE UPDATE TO 3.0 mars UPDATE NO LONGER FUNCTIONAL. wHAT DO i NEED TO DO TO REESTABLISH mars OPER...
  • 1 me too
  • 4 replies
  • Problem
  • Solved