wsjtx will not receive

  • 1
  • Problem
  • Updated 3 weeks ago
I have used WSJTx for at least a year with success......but now it won't receive, DIGIU...DAX Channels in SmarSDR (2.6.1) are set up correctly......Channel 1.......WSJT X.....DAX RX1......levels are set correctly...DAX Channels are named correctly in the Computer Sound Control Panel.....and I see the level change within DAX RESERVED AUDIO RX 1 in the sound panel....no duplicate names.....transmits correctly.....running WSJT-X v2.1.0, FT8 mode, WSJT waterfall is scrolling, on 14.074....I have uninstalled WSJT and reinstalled.....rebooted computer...I am at a loss....
Photo of WA5YOM

WA5YOM

  • 70 Posts
  • 2 Reply Likes

Posted 2 months ago

  • 1
Photo of John - AI4FR

John - AI4FR

  • 276 Posts
  • 80 Reply Likes
Change DAX RESERVED AUDIO RX 1 to DAX AUDIO RX 1 in wsjt.


Photo of WX7Y

WX7Y

  • 853 Posts
  • 183 Reply Likes
I don't think "DAX RESERVED AUDIO RX 1" is the correct sound Device, Here are the correct settings for Slice 1  "DAX AUDIO RX 1".
 I think the "RESERVED" device's are used internal to the computer.

73's
Bret
WX7Y


Photo of Mark - WS7M

Mark - WS7M

  • 1375 Posts
  • 516 Reply Likes
Also, be aware there is a known issue where after some period of time for some people DAX will become corrupted.   The only known solution is to restart DAX which means restarting WSJT-X as well.

Flex knows about the issue and is working on it.

I have the issue when using DAX 1.   If I switch to DAX 3 I do not get corruption.

Just FYI
Photo of Ken Wells

Ken Wells, Employee

  • 31 Posts
  • 12 Reply Likes
In many cases it also works to simply cycle the DAX RX Channel off and on in the DAX COntrol Panel.  This resets the DAX Buffer.  and It usually does not require restarting WSJT-X.  Other cases require a restart of DAX.

And Yes, NEVER use the RESERVED audio drivers.  Those are reserved as the "Radio End" of the virtual audio cable.
(Edited)
Photo of WA5YOM

WA5YOM

  • 70 Posts
  • 2 Reply Likes
Well it worked fine...stopped and I had to restart DAX....worked then stopped again......I tried RX3....but that didn't work either.....restarted...didn't work......went back to RX1 and nothing....I have tried every DAX Channel...nothing...then suddenly started working on DAX 4
(Edited)
Photo of WA5YOM

WA5YOM

  • 70 Posts
  • 2 Reply Likes
Constantly having to restart DAX......works a few minutes...then stops...useless this way....
Photo of Mark - WS7M

Mark - WS7M

  • 1375 Posts
  • 516 Reply Likes
Change to dax 3 and see if same result.  My dax 3 is good, dax 1 continuously corrupts.
Photo of WA5YOM

WA5YOM

  • 70 Posts
  • 2 Reply Likes
Thanks for all the quick responses.....while I was waiting...I uninstalled DAX and reinstalled and all is working now.....apparently there was an issue with DAX talking to WSJT....
Photo of Bill W2PKY

Bill W2PKY

  • 564 Posts
  • 104 Reply Likes


Locate sound panel and check "listen to this device" to hear the data stream from DAX. If it becomes scratchy sounding etc it's time to restart DAX. DAX can become corrupt if run for long periods of time or if the computer fails to provide prompt service time for the application.
Photo of John - AI4FR

John - AI4FR

  • 276 Posts
  • 80 Reply Likes
It drives me crazy as well. I have to play with DAX everytime I change profiles. Been thinking about going back to 2.4.9 as many others have. Other things to check would be the PC time and a reboot of everything including the router. Start fresh.
Photo of WA5YOM

WA5YOM

  • 70 Posts
  • 2 Reply Likes
Thanks.....I have rebooted a lot.....but not the router....
It quit again...then I selected a different channel....started working......about a  minute later it stopped....
Photo of Bill -VA3WTB

Bill -VA3WTB

  • 4060 Posts
  • 981 Reply Likes
Are you sure your time is exact? sounds like you may be off a few seconds
Photo of WA5YOM

WA5YOM

  • 70 Posts
  • 2 Reply Likes
Well..it doesn't run long enough to be able to use WSJTx.....
Photo of Bill -VA3WTB

Bill -VA3WTB

  • 4063 Posts
  • 981 Reply Likes
Try setting your computer time with your phone time as close as possible, and try that.
Photo of Dan Quigley N7HQ, 4O7HQ

Dan Quigley N7HQ, 4O7HQ, Service/Support Manager

  • 41 Posts
  • 53 Reply Likes
We have seen this procedure cure WSJTx issues.  Not sure if it will solve this one. 

1) Close WSJT-X, SmartSDR, DAX, CAT, etc.

2) In Windows, find your "C: > Users > username >Local > AppData >WSJT-X" file folder.

3) Rename the WSJT-X folder to "WSJT-X-Old"

4) Reboot the computer

5) Restart SmartSDR and CAT.

6) Restart WSJT-X and it will rebuild the AppData folder.

7) You will need to recreate your configuration settings.

8) Test it.

9) if it now works, go to the WSJT-X-Old and copy your wsjtx.logand wsjtx_log.adi files to the new WSJT-X folder. If it asks if you want tooverwrite the existing (new) ones, say OK.

This process may work to eliminate a corrupted configurationfile in the WSJT-X folder.
Photo of Jeff Eli

Jeff Eli

  • 11 Posts
  • 2 Reply Likes
What worked for me when I had similar problems was just to make a new wsjt-x configuration file. Somehow the configuration file I was using became corrupt. Might want to try this before trying the above.

Photo of Dave - WB5NHL

Dave - WB5NHL

  • 289 Posts
  • 67 Reply Likes
Here is a link to a discussion on the WSJT-X board regarding latency issues with WSJT-X, Windows and DAX. Bottomline.... Complex interaction between WSJT-X, Windows and DAX drivers and programs. Note in this posting Flex/ Tim Ellison was supportive but there was no magic.
https://groups.io/g/WSJTX/topic/another_case_of_decoding/32495572?p=Created,,,20,2,0,0::,,,0,0,0,324...


Photo of Dave KØKQ

Dave KØKQ

  • 13 Posts
  • 4 Reply Likes
I quit trying to get DAX and WSJT to play together.

Would finally get things sorted, then stopped working the next hour or the next day.

Secondly, my (very) remote site has such poor up-link bandwidth, DAX was just too bandwidth heavy.

The fix here has been VBAudio. It has worked flawlessly on the remote both 6300 and 6500 for two years. Little bandwidth (compared to DAX) and reliable once set up.

Must be set up in audio / recording and playback. WSJT settings / audio input / output.

Very reliable on low bandwidth connection remote. Comes up "everyday".

Dave