WSJT-X with PowerSDR and DXLab

  • 1
  • Question
  • Updated 1 year ago
I'm trying to get WSJT-X running with PowerSDR, My Flex 5000, and DXLab, under WIN10. I  had WSJT-X working at this location with my 6500 setup, but as I left the 6500 at my winter home as a remote. I'm now trying to get the 5000 running. Issue I'm having is a  Rig control error  'dxlab suite commander sent an unrecognized mode'. I left WSJT-X config in same setup as the 6500 that worked. Anyone have this setup working ?

73 Jeff kb2m
Photo of Jeff Griffin

Jeff Griffin

  • 13 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of Todd

Todd

  • 6 Posts
  • 4 Reply Likes
I don't have the same set up as you, but I just resolved a similar problem after fiddling with it for many hours. I hadn't used WSJT-X for a good while (it previously was working fine) and I had not changed any of the settings and when I tried to use it I kept losing CAT control and getting an error message regarding "Mode". I looked around on the web for my specific error message and the suggestion was to go to the WSJT-X settings and on the radio tab choose 'None" for the mode. (It had previously been set on USB.) so now I just make sure that DIGI U is selected on the PSDR display. you can also refer to the WSJT-X manual where it explains the settings (Mode) for the Radio tab. Hope this helps. Let me know if this worked and/or if you have questions about what I described. stolz55@att.net 73 Todd K1OD
Photo of Jeff Griffin

Jeff Griffin

  • 13 Posts
  • 0 Reply Likes
That worked! The mode errors went away. Setting DIGU on when I run WJST-X is no problem. Thanks Todd...
73 Jeff kb2m
Photo of Rick

Rick

  • 158 Posts
  • 21 Reply Likes
I use WSJT-X with my 5000A without a problem and have also used it with my 6300. I abandoned using DX Laps some time ago so can't help you there. I do know that a number of logging programs have not kept up with integrating all the digital modes. I guess they find it hard to keep up!
73
Rick
Photo of Todd

Todd

  • 6 Posts
  • 4 Reply Likes
Jeff - Very glad to hear that it's fixed!  What I find very strange is that it was working fine in the past when the mode was set on "USB" so I don't know what may have changed. Somewhere along the line I switched to the KE9NS version of PSDR (which is great) but I can't remember if I had tried WSJT-X since I had made the switch. Perhaps someone will offer an explanation, but if not put we can just put this in the "oh well" folder. 73, Todd
Photo of Peter Helfenstein

Peter Helfenstein

  • 2 Posts
  • 0 Reply Likes
Thanks. I suddenly had the same issue and was very happy to find the causing setting here. Looking at the mode signaled by Commander - I see correctly RTTY-R for DIG U in PowerSDR - I assume this is an issue between WSJT-X and Commander. Somehow commander does not seem to hand back the mode the way WSJT-X expects it. Does anyone have more details on this. 73, Peter