WSJT-X v1.9.1 not receiving?

  • 1
  • Question
  • Updated 5 days ago
I just upgraded to this new version and it is not receiving, It was working on the last version.
Photo of Bill -VA3WTB

Bill -VA3WTB

  • 2959 Posts
  • 642 Reply Likes

Posted 4 weeks ago

  • 1
Photo of Steven Linley

Steven Linley

  • 239 Posts
  • 27 Reply Likes
Ck DAX?, CK Settings? I recently had to cycle DAX on/off after a runaway Tx. Closing and opening WSJT-X didn't help but rebooting SmartSDR or DAX Fixed things.
Photo of Bill -VA3WTB

Bill -VA3WTB

  • 2959 Posts
  • 642 Reply Likes
Still not receiving,,don't know what is different from last version
Photo of Jay / NO5J

Jay / NO5J

  • 1572 Posts
  • 227 Reply Likes
Bill
I don't see the question mark anywhere in your post, did you leave it out? Were you going to ask for help? WSJT-X v1.9.1 working FB here, maybe if we compare our configurations we can get it receiving again for you. I'll keep an eye on the #Flexradio IRC channel.

    #FlexRadio IRC chat

For real-time discussions

        SDRgadgets

User created documentation.
           Volunteer!!

         73, Jay - NO5J

Photo of rjguidrysr

rjguidrysr

  • 77 Posts
  • 10 Reply Likes
Can you turn off 77 bit in Rc3 notes think say no and dontbwNt to mess up with VP6D due anytime now!
Thanks
Photo of Bill -VA3WTB

Bill -VA3WTB

  • 2959 Posts
  • 642 Reply Likes
Here are my settings.

Photo of Jay / NO5J

Jay / NO5J

  • 1572 Posts
  • 227 Reply Likes
Bill 
Except for the Cat port your using, your setup matches mine, which would move the blame to either DAX, or your windows DAX devices. Have you tried reverting back to your previous WSJT-X version to see if that one works?

    #FlexRadio IRC chat

For real-time discussions

        SDRgadgets

User created documentation.
           Volunteer!!

         73, Jay - NO5J

Photo of Bill -VA3WTB

Bill -VA3WTB

  • 2959 Posts
  • 642 Reply Likes
Yes Jay reverting back to the last Version works fine
Photo of Jay / NO5J

Jay / NO5J

  • 1572 Posts
  • 227 Reply Likes
Bill
Which band are you trying to work? 40m FT8 is dead/flatlined here locally this morning but 20m is really hopping. 

    #FlexRadio IRC chat

For real-time discussions

        SDRgadgets

User created documentation.
           Volunteer!!

         73, Jay - NO5J

Photo of Bill -VA3WTB

Bill -VA3WTB

  • 2959 Posts
  • 642 Reply Likes
Interesting, I do not have any band sellections in WSJT
Conditions on 40m is not to bad here.
(Edited)
Photo of Jay / NO5J

Jay / NO5J

  • 1572 Posts
  • 227 Reply Likes
Bill 
OK now I see 2-3 users working 40m, It was probably just a fluke.
I'm using WSJT-X v2.0.0-rc3, but I still have v1.9.1 installed and working.
I'll assume you tried the reboot/restart everything routine.
I doubt it's SmartSDR or your radio.
I don't see anything that would cause a problem though, in what you've posted about the problem. I'm willing to Teamviewer in, and poke around.

    #FlexRadio IRC chat

For real-time discussions

        SDRgadgets

User created documentation.
           Volunteer!!

         73, Jay - NO5J

(Edited)
Photo of Bill -VA3WTB

Bill -VA3WTB

  • 2959 Posts
  • 642 Reply Likes
Something not right about this version,,I still don't have any band sellections in the pull down.
Photo of Jay / NO5J

Jay / NO5J

  • 1572 Posts
  • 227 Reply Likes
Ok, so your having problems I'm not. maybe a re-download and reinstall of WSJT-X?
The frequency drop down should be populated. BTW which version was your previous working version?

    #FlexRadio IRC chat

For real-time discussions

        SDRgadgets

User created documentation.
           Volunteer!!

         73, Jay - NO5J

Photo of rjguidrysr

rjguidrysr

  • 77 Posts
  • 10 Reply Likes
Using same works great
Photo of KP2L

KP2L

  • 23 Posts
  • 2 Reply Likes
Try this:
If you upgrade from v1.8.0-rc1 it may be necessary to do a one-time
reset of the default list of suggested operating frequencies.  Go to
*File->Settings->Frequencies*, right click on the table and select 
*Reset*.
Photo of Bill -VA3WTB

Bill -VA3WTB

  • 2959 Posts
  • 642 Reply Likes
This is happening when it trys to Decode 
The bands are back thanks  in the pulldown.

(Edited)
Photo of Jay / NO5J

Jay / NO5J

  • 1572 Posts
  • 227 Reply Likes
Bill
The bug that causes that error message was discussed at the end of last month, on the WSJT-X-devel mailing list. It was claimed to have been fixed in the next release. It wasn't affecting everyone, I guess your just lucky. See if you can try the release after the one that's not working for you.  

    #FlexRadio IRC chat

For real-time discussions

        SDRgadgets

User created documentation.
           Volunteer!!

         73, Jay - NO5J

Photo of George Molnar, KF2T

George Molnar, KF2T, Elmer

  • 1578 Posts
  • 554 Reply Likes
This is a kmown defect in 2.0 rc3. While there are workarounds, you may want to stick with the latest release version (1.9.1) until 2.0 is out of beta.
Photo of Bill -VA3WTB

Bill -VA3WTB

  • 2959 Posts
  • 642 Reply Likes
I am on version 1.9.1 as stated in my discription. I am still not getting a signal into the program.
Photo of Bill -VA3WTB

Bill -VA3WTB

  • 2959 Posts
  • 642 Reply Likes


On Win 7 64bit
(Edited)
Photo of Arvind Mallya

Arvind Mallya

  • 39 Posts
  • 1 Reply Like
Bill,

What is your filter setting on SmartSDR I usually keep that to 6K try that.
Photo of Jay / NO5J

Jay / NO5J

  • 1572 Posts
  • 227 Reply Likes
The WSJTX-devel thread can be read here.

https://sourceforge.net/p/wsjt/mailman/search/?q=subprocess 

I agree skip the beta releases, but this bug has been a known defect as far, or further back than WSJT-X v1.7.1 the thread suggests fix info worth trying.

    #FlexRadio IRC chat

For real-time discussions

        SDRgadgets

User created documentation.
           Volunteer!!

         73, Jay - NO5J

Photo of KP2L

KP2L

  • 23 Posts
  • 2 Reply Likes
What does the dax program look like?  Getting audio on channel one? Slider turned up? Dax has to be enabled  in four places, left flag, slice flag, right audio "pop out" pane, and in the dax program itself. If any of those are turned off,  you will not see dax rx audio to wsjt-x.
73
Carl KP2L

Photo of Paul F6EXV

Paul F6EXV

  • 37 Posts
  • 1 Reply Like
Hi all
I have just installed SmartSDR v 2.4.9 and all of its componensts (DAX and CAT).
I do follow the step by step indications by the youtube presentation mentionned elsewhere.
The PTT and CAT test on the WSJT-X settings radio page both give positive answer. So everything should work... but it does not.
The Smart SDR settings are OK as well (Dax 1, DAX button blue...)
What puzzles me is on the DAX control panel, the TX stream is read, saying "not connected". The RX stream 1 is red too, indicating "not connected". At the bottom of this screen, the IQ stream 1 and 2 are red, sample rate 48000 and "driver error".

I have reinstalled SmartSDR twice, to no avail.
Anyone has any idea where I should look into so I can get on FT8 ?
Thanks + 73
Paul F6EXV


Photo of rjguidrysr

rjguidrysr

  • 76 Posts
  • 9 Reply Likes
With the "RED" DRIVER ERRORS you likly will need to uninstall SMART SDR 2.4.9 and be sure to say "NO" so it uninstalls the drivers, then reinstall. 
Photo of Paul F6EXV

Paul F6EXV

  • 37 Posts
  • 1 Reply Like
I just did that, some changes... Now TX stream, and RX Stream slice A are blue in he DAX control panel. But the IQ sttreams are still red with the "driver error" note.
Sample rate is indicated at 48000. Could this create the issue ?
And WSJT still not receiving. The bar graph on the lower left end of the screen shows no reading.
Photo of rjguidrysr

rjguidrysr

  • 77 Posts
  • 10 Reply Likes

f you are requested by support to reinstall your DAX drivers, please use the procedure below.

This procedure assumes you are running on a 64-bit operating system.  If you are using a 32-bit version of Windows, you will need to change the directory path to replace 64-bit Drivers with 32-bit Drivers.

In the example below SmartSDR is version 1.6.21 is used to re-install 64-bit DAX drivers.  

Make certain you are running this procedure from the latest SmartSDR for Windows application folder installed on your PC.

If your latest version of SmartSDR is, for example, 2.3.9, then replace v1.6.21 with v2.3.9 in the examples below.

  1. Shut down SmartSDR
  2. Close the DAX Control Panel
  3. Close any sound card applications that may be using a DAX sound device
  4. Using the Windows Search, type in CMD.
  5. Right click on cmd.exe and Run as Administrator
  6. Change directory to where the DAX_IQ driver is located: cd \Program Files\FlexRadio Systems\SmartSDR v1.6.21\64-bit Drivers\IQ_DAX 
  7. Run the DAXIQ driver uninstall batch file: SmartSDR_IQ_DAX_uninstall.bat
  8. Run the DAXIQ driver install batch file: SmartSDR_IQ_DAX_install.bat
  9. Change directory to where the RXAudio_DAX driver is located: cd \Program Files\FlexRadio Systems\SmartSDR v1.6.21\64-bit Drivers\RXAudio_DAX 
  10. Run the RXAudio_DAX driver uninstall batch file: SmartSDR_RX_DAX_uninstall.bat
  11. Run the RXAudio_DAX driver install batch file: SmartSDR_RX_DAX_install.bat
  12. Change directory to where the TXAudio_DAX driver is located: cd \Program Files\FlexRadio Systems\SmartSDR v1.6.21\64-bit Drivers\TXAudio_DAX 
  13. Run the TXAudio_DAX driver uninstall batch file: SmartSDR_TX_DAX_uninstall.bat
  14. Run the TXAudio_DAX driver install batch file: SmartSDR_TX_DAX_install.bat
  15. Change directory to where the MICAudio_DAX driver is located: cd \Program Files\FlexRadio Systems\SmartSDR v1.6.21\64-bit Drivers\MICAudio_DAX
  16. Run the MICAudio_DAX driver uninstall batch file: SmartSDR_MICAUDIO_DAX_uninstall.bat
  17. Run the MICAudio_DAX driver install batch file: SmartSDR_MICAUDIO_DAX_install.bat
  18. Close the command window
  19. Reboot the PC

Paul, This is then a good way to just take one set at a time and delete and reinstall
I would do just DAQ IQ since that is what is now RED!.  
Photo of rjguidrysr

rjguidrysr

  • 77 Posts
  • 10 Reply Likes
OK, one more thing and that is to make sure Windows has not hijacked the audio so open Sound and be sure it does not have your DAX RX 1 as its default.  Got me a number of times.

Photo of Paul F6EXV

Paul F6EXV

  • 37 Posts
  • 1 Reply Like
Just did all that... still no change... WSJT not receiving (nor decoding) anything. Meter at bottom left of WSJT screen still not moving ( I think it is supposed to !)
Photo of Bill -VA3WTB

Bill -VA3WTB

  • 2949 Posts
  • 637 Reply Likes
I never did get 1.9.1 working here either, I just went back to 1.8.0 and all is fine. I had someone offer to team view my computer to see what is going on but have not come up with a good time.

The settings in 1.8.1 do not seem to work on 1.9.1
Photo of Paul F6EXV

Paul F6EXV

  • 37 Posts
  • 1 Reply Like
Speakers are the audio by default, so this is not the issue either...
Photo of rjguidrysr

rjguidrysr

  • 77 Posts
  • 10 Reply Likes
Paul, then I would say use another program like FLdigi if know working to be sure the DAX drives are all ok.  The vertical bar graph on the bottom left yes should show actually received audio levels at least 30 to 50 is needed to decode I would think. I use the RX slider to keep it at about 50. If the waterfall display does not show anything you still have a DAX issue for sure.

Photo of rjguidrysr

rjguidrysr

  • 77 Posts
  • 10 Reply Likes
I have run all versions of WSJT-X  even v2.0 rc3 with SmartSDR 2.4.9 as long as I keep the DAX drivers current and they are named in Windows 10 Pro correctly.   Safe to stay with 1.9.1 until end of year to not inject the new 77 bit option.

Photo of Paul F6EXV

Paul F6EXV

  • 37 Posts
  • 1 Reply Like
I tried everything back again, and now all seams to be OK in the DAX panel.
As for CAT, I have set Com 12 in the PTT method CAT selected corner. What mode should be selected, on both WSJT and the Flex ? Data/Pkt and DigiU, or anything else ?
Which should be the split operation choice ? On Smart CAT, com 12 shows "process : None". Tha is not normal, I think (of course, WSJT is running)

I still don't get any reading on the vertical bar graph, even if RX gain is set to maximum in the DAX control panel.

So, it looks like the rig and the computer are talking to each other, (CAT and PTT tests work fine), but there is no input signal into the WSJT program.

By the way, you are advising me to use FLDigi, but I do not think it will do FT8...

We are progressing, but still some issues...
Photo of rjguidrysr

rjguidrysr

  • 77 Posts
  • 10 Reply Likes
I use DigiU as this kills the mic input and use 3khz or 6khz  filter.

Photo of rjguidrysr

rjguidrysr

  • 77 Posts
  • 10 Reply Likes
I use split "none" but keep my TX set to hold at say 1234 or 1500 or maybe move to a hole in the displayed waterfall. Paul, no the use of FLdigi was just to prove that the DAX is working or maybe MMTTY or some other digital program "just to test".  I would look now at Audio tab in WSJT-X to be sure you are set to Input Dax RX 1 as well output DAX TX.

Photo of Dudley - WA5QPZ

Dudley - WA5QPZ, Elmer

  • 68 Posts
  • 9 Reply Likes
Paul - If DAX TX in the DAX Control panel says no connected, make sure the “ DAX “ button in the SmartSDR Transmit stack is “Enabled”. Very easy to over look enaging DAX in SSDR.

Dudley
WA5QPZ
Photo of Paul F6EXV

Paul F6EXV

  • 37 Posts
  • 1 Reply Like
Now, in the DAX control panel, Slice A RX is streaming (bargraph moving), 1st IQ is blue. WSJT is supposedly well configured according to all indications given here above, and on the youtube presentation. If I change freq on the Flex (DAX is blue there), WSJT will follow. If I change frequency on WSJT, the Flex will follow.
At this point, it looks like the audio is OK on the Flex, but is not making it through to the WSJT program, even though all settings seam OK.
Not sure what to investiage now...
Photo of Paul F6EXV

Paul F6EXV

  • 37 Posts
  • 1 Reply Like
Alleluyah... I uninstalled WSJT-x (3 versions installed, uninstalled them all), only reinstalled latest version (1.9.1) and now decoding fine !
Thanks guiys for the time spent trying to help me out !
73
Paul F6EXV
Photo of rjguidrysr

rjguidrysr

  • 77 Posts
  • 10 Reply Likes
GREAT News Paul, Fun to try to help always!  And that is what is Great about this community, they help each other.  73, Russ K5OA