WSJT-X v1.7.0 will not allow any selection for audio input

  • 2
  • Question
  • Updated 2 years ago
Hi, This may be caused by something I have done or not done.  I have watched videos and read manuals but may have missed something.

So, while I have used other software to successfully decode JT65 digital transmissions I cannot get the WSJT-X software to work.  The main problem is that I cannot enter the sound input in settings under the soundcard tab.  Nothing I do opens that field to allow input or selection.

I get error messages when I restart.  I have removed and downloaded (an it is the current version).

Any ideas or thoughts would be greatly appreciated!

Kevin N9JKP



Photo of Kevin N9JKP

Kevin N9JKP

  • 39 Posts
  • 14 Reply Likes

Posted 2 years ago

  • 2
Photo of Kevin K4VD, Elroy

Kevin K4VD, Elroy

  • 775 Posts
  • 171 Reply Likes
This is odd Kevin. I happen to be using WSJT-X 1.7.0 r7405 at the moment and don't see this issue. My Audio Input dropdown shows all the DAX devices.

I'm set up slightly different than you on the radio tab but I don't think that would affect the audio tab.

Curious what SmartDAX looks like.



Kevin K4VD
Photo of Ernest - W4EG

Ernest - W4EG

  • 206 Posts
  • 38 Reply Likes
Kevin I will email you a one page fro instructions of what your problem maybe!  I had the same issues and I worked with Dudley at FRS and wrote the procedures of what to do in this case.  I got your email at QRZ.COM. If that is not correct, please let me know.  I call it my "How to correct DAX errors in Audio Input & Outputs" for dummies like me. 
73
Photo of Ernest - W4EG

Ernest - W4EG

  • 206 Posts
  • 38 Reply Likes
Check your email... it should be there by now!
Photo of Kevin K4VD, Elroy

Kevin K4VD, Elroy

  • 775 Posts
  • 171 Reply Likes
Any chance you could post the document here? Or maybe Flex could add it to their helpdesk page?
Photo of Kevin N9JKP

Kevin N9JKP

  • 39 Posts
  • 14 Reply Likes
Ernest,
I did get the email, I will try it after supper.
73,
Kevin
Photo of Kevin N9JKP

Kevin N9JKP

  • 39 Posts
  • 14 Reply Likes
Kevin Schafer,
I am using the TS2000 for the rig and the CAT function does test good, so that part works.
Photo of Ernest - W4EG

Ernest - W4EG

  • 206 Posts
  • 38 Reply Likes
I forwarded it to Tim; he was going to look it over and posted: However, As of today I have not seeing it anywhere.  I have many request for it and the only thing I can say the problems were resolved on the first try. 
The issue seems to be, that DAX errors occurred in the computer sound I/O; and those errors need to be deleted by removing all the DAX drivers and then reinstalled. However, I tried to using the one that Tim wrote and for me was rather wordy and confusing. I wrote mine so anyone can follow. In other word I kept it simple and with a KISS!
Photo of KY6LA - Howard

KY6LA - Howard, Elmer

  • 3593 Posts
  • 1446 Reply Likes
WithV1.7 you should no longer need to iluse Kenwood as Flex works now
Photo of Kevin N9JKP

Kevin N9JKP

  • 39 Posts
  • 14 Reply Likes
Nope, still a no go.  I can change frequency and band from the WSJT-X but it will not open up the input box. (I am now using the Flex as my rig selection.)  I can and have selected the output.
Photo of KY6LA - Howard

KY6LA - Howard, Elmer

  • 3593 Posts
  • 1446 Reply Likes
Photo of KY6LA - Howard

KY6LA - Howard, Elmer

  • 3593 Posts
  • 1446 Reply Likes
Photo of KY6LA - Howard

KY6LA - Howard, Elmer

  • 3593 Posts
  • 1446 Reply Likes
Not sure what ur issue is but setup is simple and takes 30 seconds.

The IP address I use is the up of my Flex radio and the TCP port
Photo of Ken - NM9P

Ken - NM9P, Elmer

  • 4025 Posts
  • 1248 Reply Likes
Or, I think, you can use "local host:5004" (or whatever port you wish to assign) if all the numbers get in your way. I think that is the way I am doing it.
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1208 Posts
  • 249 Reply Likes

Are you trying to set the transmit audio source on the radio tab? That is greyed out. You need to use the audio tab and you should then see the DAX selections. We are assuming you selected to install DAX and CAT when installing SmartSDR.

Dave wo2x


Photo of Ken - NM9P

Ken - NM9P, Elmer

  • 4025 Posts
  • 1248 Reply Likes
Yes, the select buttons in the radio tab for "rear data" and "front mic" are to tell legacy rigs which connector to use. We just define our connection as the virtual audio DAX ports in the audio tab. Slick!
(Edited)
Photo of EA4GLI - 8P9EH - Salvador

EA4GLI - 8P9EH - Salvador

  • 1758 Posts
  • 536 Reply Likes
My WSJT is transmitting on DAX RX6 !!! (WTF) even though I selected DAX_TX on WSJT. I can't get CAT to work with WSPR. All of these used to work. I've been using SmartSDR for over 2 years and know my way around. FLDIGI works ok when I select DAX TX for Transmit.
Still, tons of issues with every software update. I understand this is Beta, but in order to use the DEMI gear I need to use it. ..... I am not having a great time with a constant fight with the radio to do even simple things.
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1208 Posts
  • 249 Reply Likes
Salvador,

Check device manager under audio devices. My DAX was all wrong after a Microsoft Windows 10 update. I completely removed all traces of DAX, rebooted and reinstalled SmartSDR.

I will post a picture of my Device Manager audio section in a few minutes. You will see it was messed up.

Dave wo2x
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1208 Posts
  • 249 Reply Likes

Here is what my Device Manager looked like before I completely removed DAX and reinstalled. (Thanks Microsoft!)

Dave wo2x


Photo of EA4GLI - 8P9EH - Salvador

EA4GLI - 8P9EH - Salvador

  • 1758 Posts
  • 536 Reply Likes
Thanks for the help!
A restart of WSJT solved the issue. No idea what happened.
WSPR still having trouble with CAT... maybe a couple of restarts, some dancing around, some voodoo... lol
Photo of Chris DL5NAM

Chris DL5NAM

  • 597 Posts
  • 130 Reply Likes
Have same issue with Audio Input. Can select only one entree "Default Input Device"
Output - no problem; full range exist and selectable

CAT is working well
Have removed and install SSDR again, no changes. Every time i have done a reboot.

Flex amd SSDR working well, all DAX "channels" are visible in Device manager
WSJT must be OK, run well with 2. TRX

Where is the operator fault ?
Photo of Chris DL5NAM

Chris DL5NAM

  • 597 Posts
  • 130 Reply Likes
I had a long conversation with Igor. We try many things but with no success. All my other soft like RTTY, CW or any other digital soft runs well.
At last i do a reinstall (there is a function in W10 with option "not loosing data") and now all run without problems.  Was it W10 or JTDX or ...

73 Chris
Photo of Kevin N9JKP

Kevin N9JKP

  • 39 Posts
  • 14 Reply Likes
All,
Thanks for the ideas and comments.  Nothing has worked.  I have uninstalled almost everything, rebooted and reloaded dozens of times and still it doesn't work.  I suspect that there is a problem with the way the program interfaces with my computer (Realtec Sound).  

I may try it (Flex and WSJT-X) on my work laptop since it has no ham software on it and is a Window 10 Pro machine.  (I did load WSJT-X on it this afternoon and it showed both input and output).
73,
Kevin
Photo of Kevin N9JKP

Kevin N9JKP

  • 39 Posts
  • 14 Reply Likes
Still no luck.  I got everything working FB on my laptop so I know all the software and the radio is working, this leaves the Realtek sound devices.  I have uninstalled and re-installed the latest version still a no go.  I am posting this question in the WSJT Yahoo group hoping someone has run into this same problem
Photo of Kevin N9JKP

Kevin N9JKP

  • 39 Posts
  • 14 Reply Likes
Finally, got it working BUT only after I installed the newest version of Windows 10 Creators. (Windows 10 Pro Version 1703)

So there was something about my configuration/hardware that nothing but this new release resolved.

Needless to say, SmartSDR works well with Windows Creators.
Photo of Michael Coslo

Michael Coslo

  • 853 Posts
  • 210 Reply Likes
W10 is the worst thing to happen to Flex.
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1207 Posts
  • 247 Reply Likes
One of the things I do now is to uninstall SmartSDR and uninstall DAX drivers when prompted before doing the OS upgrade. I then reboot and reinstall SmartSDR. I haven't had corrupted DAX doing it that way.