WSJT-X Transmit Audio is Chopped. Local Remote operation

  • 1
  • Problem
  • Updated 5 months ago
I am having a problem with transmit audio sounding chopped when monitored. I have been having trouble making contacts and seems to be the TX audio.When I look at SCU 2 the signal is about 16 kHz wide.

I am using the Local Remote from my laptop over the WiFi. I have a Flex-6600 and did not have an issue when operated from my computer in the shack. The receive works fine on decode and the channel is DAX RX1. On the TX side, the audio is in WSJT-X settings is DAX TX audio and the problem is seen. I am using wsjt-x 1.9.0 -rc3 R8576. 

I think the problem is on the Flex side but not sure. Have used 1.8.0 for some time.

CPU is running about 55% and does stays well below 100%. I have set up FRstack and loaded SliceMaster 6000 but have not used it. I have HRD Logbook running.

I just shut all the apps down and restarted only SmartSRD and WSJT-X and the problem went away and worked fine. A surprise but should not have been. 

I am not sure what is happening but with all the 3rd party software it becomes very confusing evaluation the implementation of multiple applications and what is really going.  Apparently some of the data packets are being corrupted but don't know of tools to monitor this behavior. Documentation is lacking as is education on the fundamentals of the interfacing of applications.

The transmission of 16 kHz of chopped audio is ugly. Any ideas what the cause would be would be appreciated. It was not apparent that I had a problem based on PO or audio levels, only the monitor button identified an issue.

73
Bill
W9JJB
Photo of bahillen

bahillen

  • 46 Posts
  • 12 Reply Likes

Posted 5 months ago

  • 1
Photo of Michael Walker

Michael Walker, Employee

  • 268 Posts
  • 75 Reply Likes
Hi Bill

I think you are finding out what many have already notices and that is that WiFi is very unreliable.  While it is good enough for video and NetFlix, it fails when it comes to real time communication like Ham Radio when we need to get every byte of data, especially on Digital modes.

You did some good testing and eliminated the part of the problem when you said it all runs locally to the radio very well, but once you introduced WiFi it fails.  

While you WiFi speeds make look ok, if you could test it, you will find that your WiFi latency and packet loss isn't as good as a wired LAN connection.

If you have neigbhours with WiFi, they all have to play nice together like a party line and have to wait for each other to finish transmitting and time slicing.  Short story is that intense streaming on WiFi is questionable at best.  

I've done a lot of testing of WiFi performance over the past years and have reported on a lot of it here.  Too bad there isn't a good alternative.

Mike
Photo of Ted  VE3TRQ

Ted VE3TRQ

  • 103 Posts
  • 33 Reply Likes
I found that my issues with WiFi were solved (or at least improved greatly) by switching from 2.4G to 5.8G. I used a WiFI monitoring tool to figure out there was way too much crud on 2.4G. 5 was much more open. Of course it's all dependent on your neighborhood.

Ted VE3TRQ
Photo of Bob Craig, K8RC

Bob Craig, K8RC

  • 210 Posts
  • 81 Reply Likes
^^^What Ted said!^^^

My laptop can "see" many 2.4Ghz Wifi networks with no clear channels but none except my own on 5Ghz.

Maistro and SmartSDR work much better on 5Ghz!
(Edited)
Photo of Robert Lonn

Robert Lonn

  • 252 Posts
  • 64 Reply Likes
Yes, 5GHz is a great alternative with crowded conditions,,, but it does come with some distance limitations.. So working with your router antennas sometimes is required along with other options to get the biggest bang for the buck..

I use 5GHz exclusively except for a few items that do not have dual band capabilities, older iPad for one.. You would think that in 2018 every consumer device is dual band, but buyer beware, does not happen..

When I got my Sony 70" 4K HDR TV set a few years back, it was Dual Band, but many Samsung, LG and Visio were not!! Sometimes paying even $6K for a TV set does not guarantee you get dual band!

As most of us know, you just need to do your homework!! That is why the other conversation going on related to getting a External TV set monitor for the 6400-6600M version is a good one, 4:4:4 and all of that..

That is why this Flex community is fun to be part of.. Just when you think you have something figured out, along comes someone who is a bit smarter, more knowledgeable and shares it with the community!! Then you run off to the closes mirror, look in it, and say those magic words "Why the XXXX did I not think of that"  :-)

Robert
Photo of Russ GUIDRY SR

Russ GUIDRY SR

  • 12 Posts
  • 4 Reply Likes
Hi Bill. I have noted the same problem and am not on WiFi link.  I am using SmartLink with 50 Mb/20MB cable service at both ends. Latency is about 100 ms and I do see a few dropped packets but the concern is the TX 4-16KC wide TX signal.  Using WSJT-X rc3 as well.  
Russ K5OA
Photo of Michael Walker

Michael Walker, Employee

  • 268 Posts
  • 75 Reply Likes
Hi Russ

100ms on a LAN cable seems pretty long.  It should be 1-2ms, or did I read that wrong?

Mike
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9148 Posts
  • 3467 Reply Likes
Over a high latency connection (like SmartLink and wifi) the control channel data (small packets) that CAT sends to the radio to key and unkey the radio can arrive before the end of the audio data (really large packets).  In this type of scenario, you will experience exactly the behavior described above; the radio unkeys before the audio data has been fully processed. 

We had this same problem in the early days of operating digital modes with PowerSDR and the SDR-1000 because there was inherent latency processing audio data (sending it to the PC for processing and sending it to the radio for digitization).  Fldigi added a com port parameter where you can add a wait period after the audio has been sent to the radio before unkeying to prevent clipped digital mode communications.  Check with the digital mode program to see if a feature like this is available.

On the other hand, if the process is creeping latency, then you need to find out what process is causing the problem.  Shut down one thing at a time to find out what is responsible for the issue.
(Edited)