WSJT-X SETUP SETTINGS

  • 2
  • Question
  • Updated 4 months ago
When setting up WSJT-X 2.0, I Can only get it to do FT8 with the radio set to HRD and a slice A ip of 127.0.0.1.7831. Setting the radio to Flex 6xxx does not work. Any ideas?
Photo of W5AP

W5AP

  • 108 Posts
  • 8 Reply Likes

Posted 5 months ago

  • 2
Photo of Tom Worthington

Tom Worthington

  • 39 Posts
  • 5 Reply Likes
I run with the Rig set to FlexRadio 6xxx, and the Cat Control to Network Server 127.0.0.1:5002
I use a serial port on SmartCAT for PTT.
Seems to work that way.
GL de NH6Y
Photo of K1DBO

K1DBO

  • 535 Posts
  • 111 Reply Likes
Hi W5AP,

With those settings, it sounds like you are using Slice Master.  You can make other settings work, but if you want to continue using Slice Master, you shouldnt.  Part of Slice Master's job is to configure WSJT-X so you dont have to.

--Don

Photo of Michael Walker

Michael Walker, Official Rep

  • 825 Posts
  • 232 Reply Likes
Wow... that was a good video before.  Let me see what happened.
Photo of Michael Walker

Michael Walker, Official Rep

  • 825 Posts
  • 232 Reply Likes
see if this is better
Photo of Kevin

Kevin

  • 931 Posts
  • 271 Reply Likes
Thanks Mike. That definitely helped me.

Kev
Photo of Robert Lonn

Robert Lonn

  • 364 Posts
  • 119 Reply Likes
Good question! I have the same issue!!
Photo of Michael Walker

Michael Walker, Official Rep

  • 827 Posts
  • 233 Reply Likes
Just a question to both of you (not Don).

I'm curious (seriously, curious) if when you started to create this conversation did any other conversations pop up about the same question.

It is not uncommon to have the same question/conversation to be created many times and I am wondering if the search isn't working as it should.

Thanks and I hope it answered your questions.

Mike

Photo of N9VC

N9VC

  • 181 Posts
  • 55 Reply Likes
I have another question for W5AP. When you say it doesn't work, just what does
that mean? It doesn't receive? Transmit? Question, too vague.
I have WSJT version 2 and it has Flex 6XXX for the rig and it works here. I can
post my settings. What is your CAT set for for the Flex?
Photo of W5AP

W5AP

  • 108 Posts
  • 8 Reply Likes
On startup of WSJT-X ver2, I get a hamlib error and a pop up window with 4 options - restart, cancel, config, settings.   So the cat is set to 172.0.0.1.7831 with the PTT set to a flex PTT DAX channel 12. If I choose the radio as HRD, I get a green connect button in WSJT-X  and all works fine when starting from Slicemaster or from the WSJT-X directly. If I choose the radio 6xxx, then I get the errors on startup.   I've tried other DAX channels for 172.0.0.1. xxxx and set that in the WSJT-X settings, but that makes no difference.   So its working with the radio set to HRD, but I don't know why. One of those deals where you just don't mess with it and all is OK.
Photo of Ted  VE3TRQ

Ted VE3TRQ

  • 424 Posts
  • 147 Reply Likes
I believe you either may have made a typo, or you have used an incorrect IP address. You should be using a local Loopback address (the local computer) to talk to CAT i.e. "127.0.0.1:port"
(Edited)
Photo of W5AP

W5AP

  • 108 Posts
  • 8 Reply Likes
Thanks
It was a typo and that is what I'm using
Photo of N9VC

N9VC

  • 181 Posts
  • 55 Reply Likes
Here is a snapshot of my screen which works.

Make sure your DAX channels are correct and enabled also.
Photo of Jim K4JAF

Jim K4JAF

  • 361 Posts
  • 105 Reply Likes
Did you create the TCP port in PowerSDR CAT?
Photo of W5AP

W5AP

  • 108 Posts
  • 8 Reply Likes
Yes for each network server I tried ie: 127.0.0.1.xxxx
Photo of Tom Worthington

Tom Worthington

  • 39 Posts
  • 5 Reply Likes
make sure there is a : not a . before the port number...
127.0.0.1:xxxx
Photo of Geoff - AB6BT

Geoff - AB6BT

  • 125 Posts
  • 29 Reply Likes
Good catch...  I saw that as well in the original post but failed to comment...
Photo of W5AP

W5AP

  • 108 Posts
  • 8 Reply Likes
That was it. You solved my question
Now I can set the radio to flex 6xxx and the port to 5004 with the 
Smart SDR CAT TCP port set to 5004 an it works. 
I should have noticed that Slicemaster was setting 127.0.0.1:7841 with the radio set to HRD and I didn't see the :
Wow. And I even had my glasses on
Thanks and 73, Jim

Woops, that didn't fix it. As slicemaster continues to set WSJT-X up as before ie:rig-HRD and network server 127.0.0.1:7831
However WSJT-X does work ok with these settings.
I'll keep playing with it

I believe the problem is with SliceMaster. Same with all previous versions, but I have 
6000-v0.10.6a installed and it is very slow to initialize if at all. WSJT-X v2.0.0 works fine by itself with the settings rig=flex 6xxx and port 5xxx set in Cat control - network server. 

comments?
(Edited)
Photo of Dudley - WA5QPZ

Dudley - WA5QPZ, Elmer

  • 191 Posts
  • 29 Reply Likes
Jim,

Hope you have it working,  but just in case,  maybe I will confuse you more  ;-)  ,

Make sure that you have created or at least have a  TCP port created in SmartCAT.  The default is created with port 5002 as the directed port.  You can use another port number there if you like, but that port number needs to be entered when you direct WSJT to get the CAT commands from the TCP port.   So if you do use the PC server IP number,  127.0.0.1    your port number from the SmartCAT TCP port needs to follow with the  " : " by default,  " 5002 "   but can be any other unused port number that you have assigned in SmartCAT  . 

73,
Dudley
WA5QPZ
Photo of roger na4rr

roger na4rr

  • 124 Posts
  • 17 Reply Likes
OK so what dont I have set correct?  I get this error when trying to connect felx via js8call.  If I set


If I set radio to the gold standard "Kenwood TS-2000" it works.



Photo of roger na4rr

roger na4rr

  • 124 Posts
  • 17 Reply Likes
yes
Photo of roger na4rr

roger na4rr

  • 124 Posts
  • 17 Reply Likes
its there by default