WSJT-X problem

  • 1
  • Problem
  • Updated 2 years ago

The latest version of WSJT-X has added a "feature" I would like to disable. When I first start it, the slice is part way off screen. I move it over so the entire slice is visible, but at the end of each transmission, WSJT-X resets it back. Is there a way to disable this "feature"?

73, Bill W6WRT


Photo of Bill Turner

Bill Turner

  • 73 Posts
  • 6 Reply Likes

Posted 2 years ago

  • 1
Photo of Kevin K4VD, Elroy

Kevin K4VD, Elroy

  • 775 Posts
  • 171 Reply Likes
Are you using ""Fake It" in the wsjt-x config? If so, I think that's what is moving your pan display around. I use it but don't mind the movement. Reading the wsjt-x doc, fake it is recommended but many here say that the Flex doesn't need that and you can disable that option.

Not so sure the people here are right that it is best, but it does work good and should take care of the issue you see.

Kev K4VD
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9149 Posts
  • 3467 Reply Likes
I am sure that is the issue.
Photo of Bill Turner

Bill Turner

  • 73 Posts
  • 6 Reply Likes
Sorry but "fake it" was already disabled, i.e. "none" was selected. I tried going to "rig" and back, but no change. Other suggestions?
Photo of Kevin K4VD, Elroy

Kevin K4VD, Elroy

  • 775 Posts
  • 171 Reply Likes
Sorry Bill, I am also running the latest version of wjst-x. When I bring it up later I'll recheck how it works here but what you are seeing is something I posted about a long time ago. Fake-it was the issue (which I still use). If I notice anything different with the latest versions I'll post back my results.

Kev
Photo of Ken - NM9P

Ken - NM9P, Elmer

  • 3971 Posts
  • 1226 Reply Likes
Isn't the "Fake it" option designed to help "squeeze" 5KHz of combined JT65 and JT9 spectrum into a standard 2.5 or 2.7 KHz receive/transmit bandwidth on legacy radios?

When I run WSJT-X on my 6500, I just use DigiU with 5KHz RX and a WSJT-X Mic Profile that is 5KHz wide.  I can then copy both JT65 & JT9 at the same time with no jumping around.  (on 160 Meters, I need to bump the low end of the RX filter up to 200Hz to knock off the WSPR signals)

Or am I confusing this with a different feature?

Ken - NM9P
Photo of Kevin K4VD, Elroy

Kevin K4VD, Elroy

  • 775 Posts
  • 171 Reply Likes
No. You have the right feature but not sure you have all the info on why fake-it or split might come in handy.

I know the Flex is near-perfect and flat because the community told me so. An audio tone at 1 KHz is probably at the same level as one at 5 KHz and therefore generates similar RF out. But I've noticed a difference when dropping down a bit and approaching 0. If someone is calling CQ right at the edge of the jt-65 sub-band then, without shifting your VFO a bit you may have a hard time generating that 50 or 100 Hz audio. With fake-it, everything gets shifted so the audio is always between 1500 and 2000 Hz.

Split Operation: Significant advantages result from using Split mode (separate VFOs for Rx and Tx) if your radio supports it. If it does not, WSJT-X can emulate such behavior. Either method will result in a cleaner transmitted signal, by keeping the Tx audio always in the range 1500 to 2000 Hz so that audio harmonics cannot pass through the Tx sideband filter. Select Rig to use the radio’s Split mode, or Fake It to have WSJT-X adjust the VFO frequency as needed, when T/R switching occurs. Choose None if you do not wish to use split operation.
Some will reply the Flex doesn't need this and everything will work great. Maybe. But I used it and everything still works great. :)

Kev
Photo of Kevin K4VD, Elroy

Kevin K4VD, Elroy

  • 775 Posts
  • 171 Reply Likes
OK Bill - I just tried it out. I'm using WSJT-X v1.7.0 r7405 with SSDR 1.10.15 Beta.

When split operation is set to none the panadapter doesn't move between transmit and receive.

When split operation is set to fake it, the panadapter may move if you are responding to someone outside 1500-2000 Hz. When it is done, the yellow frequency marker gets centered in the panadapter display. If the filter is wide or the display is narrow it may cause part of the passband highlight to be partially off the screen.

SmartSDR seems to like to put the yellow bar in the middle of the screen when it feels like it. OK for AM and maybe CW but kind of odd for SSB (including DIGI) I guess. Personally, I'd like to see the display stay right where it is until I move it. :)

The odd thing is you say you are not using fake it (or split too?). You are set to None for Split Operation? I can't explain this. It isn't happening to me.

Kev
Photo of Bill Turner

Bill Turner

  • 73 Posts
  • 6 Reply Likes

I can't explain it either. I will have to play with some settings some more.

Many thanks to all who replied, your help is much appreciated!

73, Bill W6WRT