WSJT-X Hamlib Error

  • 1
  • Question
  • Updated 7 months ago

Hi,

I have SSDR 2.1.33 and WSJT-X 1.8 installed in the Win10 VM using Parallels 13; however, I am getting a Hamlib error when opening the connection to the Flex 6600.  I configured WSJT-X with the following setting:

Rig: Kenwood TS-2000

Serial Port: COM4

PTT Method: CAT

Mode: None

Data Bits: 81N  I also tried 82N

Split Operations: None

 

How do I correct this issue?

Thanks,

Reggie

Photo of Reggie

Reggie

  • 74 Posts
  • 2 Reply Likes

Posted 7 months ago

  • 1
Photo of David Salomon

David Salomon

  • 108 Posts
  • 26 Reply Likes
Reggie -

Not sure if this matters in your environment, but Kenwood serial interfaces are usually 4800 baud, 8N2.  You didn't mention the baud rate.

73 - David, AG4F
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9152 Posts
  • 3476 Reply Likes
That really doesn't make a lot of difference.  The FlexVSP driver will dynamically configure the baud, parity and stop bits of the endpoint device (which is why you never set it in CAT)
Photo of Reggie

Reggie

  • 74 Posts
  • 2 Reply Likes
David,

I set those parameters, but I still get the error.

73,

Reggie
(Edited)
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9152 Posts
  • 3476 Reply Likes
It could be a configuration issue with running it in your VM
Photo of Michael Walker

Michael Walker, Employee

  • 313 Posts
  • 82 Reply Likes
Try a speed of 19200. That worked for me.
Photo of David Salomon

David Salomon

  • 108 Posts
  • 26 Reply Likes
OK, one more thought.  Look at this post: https://community.flexradio.com/flexradio/topics/time-to-update-the-recommended-wsjt-x-config.  It talks about using TCP instead of COM for communications, and gives some examples.  A few people mentioned that TCP worked for them where COM did not.
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9152 Posts
  • 3476 Reply Likes
I endorse this option.  It eliminates the virtual serial port layer form the configuration.
Photo of David Salomon

David Salomon

  • 108 Posts
  • 26 Reply Likes
And, you wrote the book on it. :)
Photo of Reggie

Reggie

  • 74 Posts
  • 2 Reply Likes

Using TCP nor setting the baud rate to 19200 did not resolve the issue. 


Reggie

Photo of Ria - N2RJ

Ria - N2RJ, Elmer

  • 2263 Posts
  • 894 Reply Likes
I don’t use TCP. It crashes and causes WSJT-X to hang in memory after exit requiring you to kill the process to restart. I have no problems using the serial port option. Likely a WSJT/Hamlib issue and not Flex.
(Edited)
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9152 Posts
  • 3476 Reply Likes
That's interesting.  I do not have those issues.  
Photo of Jay  K8CJY

Jay K8CJY

  • 7 Posts
  • 1 Reply Like
Use the FlexRadio  6xxx rig profile and enter  localhost:5002  into the Network Server box.  Set PTT to CAT.  It works very well and does not tie up a com port.

73 Jay K8CJY
Photo of Ria - N2RJ

Ria - N2RJ, Elmer

  • 2264 Posts
  • 897 Reply Likes
If you’re using a 6600 you need the new WSJT-X. It should work with 1.9-rc3, or the special build from WO2X. But I would really recommend 1.9 as it has the new DXpedition mode and you can take part in the tests.
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1201 Posts
  • 247 Reply Likes
As Ria said, download the latest version of WSJT-x, currently 1.9 rc3.
https://physics.princeton.edu/pulsar/...
Scroll down newr the bottom for the link to latest 1.9 release candidate for Windows.

The 1.9 or higher versions support the 6400 and 6600 models. I suggest following the insteuctions on this thread, https://community.flexradio.com/flexr...

I suggest creating a TCP port 5004 and in WSJT-X for radio IP use 127.0.0.1:5004

Reason is 5002 is reserved for DDUtil and if you use or plan to use DDUtil in the futurw you will have a conflict.

Dave wo2x
Photo of Reggie

Reggie

  • 74 Posts
  • 2 Reply Likes

All,

Thanks for the assistance. WSJT-X 1.9 rc3 is working. I was reluctant to use this version since it was Beta, but it resolves the Hamlib error.

Reggie