WSJT-X connectivity issue

  • 1
  • Problem
  • Updated 2 years ago

Running a 6500 ( software) with WSJT-X (v1.8.0 r8193).  Intermittently WSJT-X loses connectivity, so clicking Settings/TestCAT or TestPTT no longer work, and neither does the main menu’s Tune button and I cannot of course transmit.  The button to the right of the band select bar generally (but not always) turns amber or red.

I’ve tried using the Kenwood TS-2000 and Flex 6xxx settings but the problem occurs equally with both.  It can work properly for several hours, and at other times for just a matter of minutes.  When choosing Flex 6xxx as the rig, under Network Server I’ve tried changing the default localhost:5002 setting to something like 5050 (and of course similarly in SmartCAT) so there cannot be a conflict there. 

An error message generated by WSJT-X can appear:  Rig failure.  Hamlib error: IO error while opening connection to rig.  Presumably this implies a problem with Hamlib itself?

It seems the easiest way to remedy the situation is to close WSJT-X then Task Manager/End Task.  Simply closing then reopening WSJT-X doesn’t work.  After reopening it, WSJT-X works normally...until it next decides to lose connectivity.  Thanks to Ria for these tips!

I’d be interested in hearing the experiences of other users.  It’s a very standard setup and I’m sure I’m not the only one to experience this.  Naturally it happens just when some rare DX shows up!

Jeff – G4IUA

Photo of Jeff - G4IUA

Jeff - G4IUA

  • 139 Posts
  • 16 Reply Likes

Posted 2 years ago

  • 1
Photo of Alex - DH2ID

Alex - DH2ID, Elmer

  • 983 Posts
  • 181 Reply Likes
Jeff, I use the Ham Radio Deluxe setting and MiniDeluxe as my server. I usually try to keep away from Hamlib as I find it not very stable. With my settings I never have had a problem with my Flex-6500 and my TS-2000X.
My interface for the TS-2000X is the microHAM DigiKeyerII, which I can recommend.

You can also look at my tutorial:

Alex - DH2ID
Photo of Bernie


  • 30 Posts
  • 2 Reply Likes
I am experiencing the same thing running a 6700 (SmartSDR 2.1.30 and WSJT-X v1.8.0 r8193) and Windows 10 Pro.

Bernie - W4BGH
Photo of Mark - WS7M

Mark - WS7M

  • 1374 Posts
  • 514 Reply Likes
My cat using network has been flawless. Dax is the problem for me.  It will start fine, run fine then sometimes in the middle of an exchange suddenly no transmit power and Dax is looking alive but dead.

Requires a shutdown of WSJT-X, restart of Dax, then restart of WSJT-X
Photo of Mike Stevenson

Mike Stevenson

  • 1 Post
  • 1 Reply Like
Also having this problem and using the same restart procedure,

Mike G8ALS
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9199 Posts
  • 3560 Reply Likes
We are aware of this behavior with DAX and have open issues to address them.
Photo of Roger,  W6VZV

Roger, W6VZV

  • 264 Posts
  • 122 Reply Likes
I had this problem.  The 5050 solution solved it.  Thank you fellows!
Photo of Jeff Eli

Jeff Eli

  • 11 Posts
  • 2 Reply Likes
   As someone on the Flex forum suggested, I can exit and restart DAX and most of the time I can transmit again. I am running the latest WSJT-X. I have not upgraded to 2.00+ version of SmartSDR so this may not help you at all. I am using a 6500.
Photo of Roger,  W6VZV

Roger, W6VZV

  • 264 Posts
  • 122 Reply Likes
I probably should have tried that.  Didn't think to do it.