WSJT

  • 1
  • Question
  • Updated 1 year ago
I just upgraded to WSJT 1.7 after installing an Intel NUC as my PC. I transferred the same config from the original PC. Each time the radio attempts to go into transmit, the manually set DIGU mode reverts to USB. Was there a change in the latest version of WSJT? The other strange thing is that the CAT commands pass the check, but PTT isn't working and the PTT logo turns RED when I try to check it. Reconnected the old PC, using the same settings and PTT works fine.
Photo of WA2SQQ

WA2SQQ

  • 394 Posts
  • 84 Reply Likes

Posted 1 year ago

  • 1
Photo of Alex - DH2ID

Alex - DH2ID, Elmer

  • 878 Posts
  • 157 Reply Likes
Bob, please post your PTT keying method here and a screenshot of your settings, perhaps.
What is your SmartSDR CAT panel showing? 
Here are my SmartSDR CAT settings:



With the new NUC I believe the OS to be Windows 10/64bit? 
Did you check all your permissions for the WSJT folders?
Try to run WSJT-X as an administrator.

Here are my WSJT-X settings:



Notice that I use the HRD setting with MiniDeluxe and a dedicated PTT port (COM7) for the PTT.

73, Alex - DH2ID
(Edited)
Photo of George Molnar, KF2T

George Molnar, KF2T, Elmer

  • 1529 Posts
  • 542 Reply Likes
Are you using a alpha of 1.7.1? Some issues with rig control exist in some builds. Recommend using the release 1.7.0 (7405). Alex's suggestion is also very helpful. Try with "Mode" set to "None," and see if that helps.
Photo of WA2SQQ

WA2SQQ

  • 394 Posts
  • 84 Reply Likes
OK so PTT method was fixed by changing to CAT option. Still one problem.

1 When I begin I set mode to DIGU. Each time radio goes into XMIT, WSJT software sends CAT command to change mode to USB.
(Edited)
Photo of WA2SQQ

WA2SQQ

  • 394 Posts
  • 84 Reply Likes
I'll check and try both later this afternoon thanks
Photo of Phil m0vse

Phil m0vse

  • 204 Posts
  • 38 Reply Likes
I found that using DDUtil or MiniDeluxe seemed to set the mode incorrectly for me so I set mode to None in WSJT-X and that worked. However, I am now using a TCP CAT port and the FlexRadio 6xxx rig type in WXJT-X and that switches mode to DIGU correctly.

It is easy to configure, just add a TCP CAT port in SmartSDR CAT (I used port 60001) and select Rig: FlexRadio 6xxx and enter 127.0.0.1:60001 in the network server section in WSJT-X.
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1061 Posts
  • 214 Reply Likes

Phil,


I called Bob on the phone earlier and that is exactly what I told him to do. Using the TCP connection works fine and mode switching uses DIGI-U when selecting the band from WSJT-X

Dave wo2x

Photo of WA2SQQ

WA2SQQ

  • 394 Posts
  • 84 Reply Likes
Dave's suggestion to use the TCP connection got everything up and running in about 5 minutes. Saturday night I picked up 4 new countries on 160m!  Now, need to finish packing and it's off to Orlando Hamcation and to see the kids in FL! WO2X will be joining me also.

Thanks to all!