Windows 10 update broke DAX

  • 4
  • Problem
  • Updated 3 years ago
  • Solved
  • (Edited)
I had a working Win10 with SSDR 151 and dax and cat. This afternoon I allowed the 1511 update to run.
Now I can run ssdr BUT dax does not work, I believe cat does as HRD knows what the radio is doing. Also the DAX control applet fails to start.

I saw one prior problem that sounds like the November win10 upgrade and dax but talks about upgrading to win 10 over an existing win7 w/ssdr.  apparently not relevant.

I did see what looked like a problem thread Peter entered but now can't find it.

I do have a boatload of the following:

The machine-default permission settings do not grant Local Activation permission for the COM Server application with CLSID
{C2F03A33-21F5-47FA-B4BB-156362A2F239}
 and APPID
{316CDED5-E4AE-4B15-9113-7055D84DCC97}
 to the user COR8357\walte SID (S-1-5-21-3812435307-1928038946-566690288-1001) from address LocalHost (Using LRPC) running in the application container Microsoft.Windows.Cortana_1.6.1.52_neutral_neutral_cw5n1h2txyewy SID (S-1-15-2-1861897761-1695161497-2927542615-642690995-327840285-2659745135-2630312742). This security permission can be modified using the Component Services administrative tool.
Photo of Walt - KZ1F

Walt - KZ1F

  • 3040 Posts
  • 643 Reply Likes

Posted 3 years ago

  • 4
Photo of Jay / NO5J

Jay / NO5J

  • 1514 Posts
  • 222 Reply Likes
Official Response
Walt 
The relevant fix thread and fix might be the Official response found here,
https://community.flexradio.com/flexradio/topics/windows-10-november-update-1511-broke-dax
There were several threads though.
You're right though Windows file/device permissions make it worse.

73, Jay - NO5J
(Edited)
Photo of Rick Hadley - W0FG

Rick Hadley - W0FG

  • 579 Posts
  • 120 Reply Likes
Official Response
I solved my problem by doing a system restore back to a point before the upgrade to 1511.  After doing a full uninstall and reinstall of SSDR 1.5.1, I've gone two weeks without a crash under Win10, build 10240, which is better than I ever did with Win7.  Now just watch the jinx hit....