Windows 10 Update 1803 No Problem

  • 2
  • Praise
  • Updated 3 weeks ago
My PC with Windows 10 Home edition did the Windows 10 Update 1803 installation, SmartSDR 2.1.33 and FlexRadio 6600 running without a problem, all OK. Including FT8 with WSJT-X and JTDX.
Photo of Juan TG9AJR

Juan TG9AJR

  • 31 Posts
  • 2 Reply Likes

Posted 3 weeks ago

  • 2
Photo of Ted  VE3TRQ

Ted VE3TRQ

  • 54 Posts
  • 20 Reply Likes
I had the same experience - update to 1803 without issues. I used the "metered WiFi" trick to hold off updates, and when ready, stopped Dax and Cat and forced the update. After waiting about an hour for Windows to do its thing, I started up Dax/Cat and SSDR and everything worked, including Fldigi and wsjt-x. No reconfiguration required,
Photo of N5LB - Lionel B

N5LB - Lionel B

  • 94 Posts
  • 16 Reply Likes
Is it true that the Home edition is different than Pro insofar as security? 

Anyway, Using the Tips and Tricks still no joy on 1803 Pro.  The drivers will not install, or at least not properly. It is only DAX having a problem, all else is fine with .33, SmartCAT, N1MM, and FLdigi, except of course no audio.

I'll roll back to 1709 and reinstall SSDR .33 or keep 1803 and forget about any digi modes until a fix is found.
Photo of Juan TG9AJR

Juan TG9AJR

  • 31 Posts
  • 2 Reply Likes
I forgot to mentioned I did not did anything, just plain download and installed and nothing else and it is working OK. Did not back up anything or re-install anything.
Photo of Steven Linley

Steven Linley

  • 115 Posts
  • 18 Reply Likes
I have home addition and I was not so lucky but he's okay now
Photo of Michael Coslo

Michael Coslo

  • 744 Posts
  • 167 Reply Likes
New note: the previous patch applied to Win10 addressing Spectre/Meltdown was useless, and could be easily bypassed. Supposedly the April build is protected, but who knows? As well, the new fix is only for the latest build - has not been backported yet. Be careful out there folks. AdBlock od some sort and Ghostery or NoScript are recommended. 
Photo of VE7ATJ

VE7ATJ

  • 102 Posts
  • 20 Reply Likes
I took Tim's advice and de-installed SSDR, then ran the Windows Update Assistant to 'force' the upgrade to 1803.  Everything went smoothly, then after the update, I simply re-installed SSDR.  All is working well.
Photo of Dave - WB5NHL

Dave - WB5NHL

  • 266 Posts
  • 60 Reply Likes
Same here  3 different machines (vintages, laptops, desktop, including dual boot Ubuntu Linux) uninstalled SmartSDR including VSP. Also uninstalled VBcable used on 2 machines. Forced install with Update Assistant. Reinstalled SmartSDR and VBcable all is good!!
(Edited)