Windows 10 creators update April 11 2017

  • 2
  • Idea
  • Updated 2 years ago
  • (Edited)

This update is big think Gigabytes and took over an hour with high speed internet and good computer with ssd.
Only problem i had was smartsdr CAT shown an issue so i re-booted and all is well.
I looked into device manager for hidden comms and everthing is ok there also.

Downloaded (windows 10 upgrade assistant) for getting ahead of the line.

True windows 10 creator comes out April 11th and there after for those that want to wait.
Windows 10 add lots of new features to the windows settings.

If interested lots of information on the web for this new creators update.

73 Jeff

Photo of AA0KM

AA0KM

  • 356 Posts
  • 65 Reply Likes

Posted 2 years ago

  • 2
Photo of AA0KM

AA0KM

  • 356 Posts
  • 65 Reply Likes
Photo of Alex - DH2ID

Alex - DH2ID, Elmer

  • 974 Posts
  • 180 Reply Likes
Hi Jeff, thank you very much for reminding us about the upcoming update and
posting the link. The update works well, although it took a lot of time.
I'm running my main computers on Win7 64bit Prof. still, but my newest aquisitions,
the ASUS Zenbook and my trusty PiPo, are running 10.
73, Alex - DH2ID
(Edited)
Photo of Alex - DH2ID

Alex - DH2ID, Elmer

  • 974 Posts
  • 180 Reply Likes
I had a nice evening with the "creators update":

That the update went well is not entirely true, as the new update "created"
a nice shootdown of my graphics driver and the startup screen went black. Nothing
worked until I started up in protected mode and deinstalled the intel graphics card driver!
Now everything works again. SmartSDR, CAT, DAX - all work. Hope the rest does so, too :-)
This on a 64bit ASUS Zenbook, which I also use as my testing platform for my own programs.
(I hope that Zen helps https://en.wikipedia.org/wiki/Zen :-))
Photo of Larry: KE2YC

Larry: KE2YC

  • 76 Posts
  • 8 Reply Likes
Hi Alex

I had the same problem and deleted the drivers and windows kept reinstalling the drivers.  I tried several times and still lose my graphics and can not install new update.  Will check a few thing tomorrow and try again.  I am running Nvidia for a graphics driver.  I don't know where the intel driver came from but it is giving me all kinds of trouble trying to delete it.  Will let you know what happens.  If any suggestions will help.

Larry
ke2yc
Photo of Roger W9YU

Roger W9YU

  • 19 Posts
  • 2 Reply Likes
Just started the download.  Fingers crossed.
Photo of k3Tim

k3Tim

  • 914 Posts
  • 189 Reply Likes
Thanks for the heads up Jeff; took the bait.

Download went fairly fast and the update went fairly fast though there were about 3 reboots. 
One problem was Dax would pop-up an error box on startup although it appeared to work. Uninstalled / reinstalled is several times to no avail. Took the simply way out un-installed (latest) SSDR and all. After a reinstall and reboot all was back to working. 

k3Tim
Photo of NX6D Dave

NX6D Dave

  • 308 Posts
  • 95 Reply Likes
Upgrade elapsed time depends on a lot of factors, particularly disk speed.  I've seen it take over an hour on a relatively slow spinning disk, and only about 20 minutes on a fast SSD.

I've upgraded many systems to the 1703 version, including one on which I set up all of the SmartSDR software then forced the update to see what would happen.

In all cases the only "damage" that was done was to the assignment of the default playback and record devices.  This has been a consistent effect (I've never seen it not happen) and an easily corrected one.  Don't wait until you trip over some sort of problem with DAX, go look for this "damage" right after the upgrade completes and deal with it before you attempt to use any of the radio software.

Assuming you have the audio devices control in the system tray:

* Right click the speaker icon to open the menu, select and left click the "Playback devices"

* Scroll down the list.  You'll see the DAX devices and you will probably see one of them, marked with the green check, as the default device.

* Select the correct default device (whatever you prefer) and right click it.  Set it as the default device and probably the default communication device.  The objective is to get all defaults off of DAX channels.

* Select the "Recording" tab and do the similar thing.  Again, get the default back onto an appropriate conventional sound device and off of DAX.

Once I did these steps, my SmartSDR installation ran correctly after the system upgrade.  I have a simple COM port layout and didn't have any problems with COM ports.

If this doesn't solve any problems you may have after the OS upgrade, it is relatively simple to uninstall and reinstall the SmartSDR software.  I'm an alpha tester (and a Windows Insider tester) and I do it all the time.  There is a procedure you can follow to reinstall the DAX drivers,

https://helpdesk.flexradio.com/hc/en-us/articles/204017069-How-to-Manually-Re-Install-DAX-Drivers


but so far I haven't found a circumstance in which I needed to go that far.  In my view the SmartSDR install/uninstall process has been polished quite a bit in the last few years and works very well now.

Finally, if you get stuck on problem, don't spend a lot of time struggling with it.  File a helpdesk ticket and you'll get help, right away, from people who have seen and fixed it all.
(Edited)