Why can't I use SMARTSDR away from my home?

  • 1
  • Question
  • Updated 2 years ago

Hi

Sorry if I am rehashing an old topic but I need to make sure that I am not missing something. I have a 6300 connected to my Gigabit network with a sonicwall (firewall) at my home and at my office that provides a nailed up VPN. I can ping the 6300 but SmartSDR cannot find the radio. Is this because either the radio or the software does not know the default gateway? With that in mind I setup a vpn from my laptop to my home so now I actually have a local IP address and I can ping the 6300 but again the SmartSDR software does not find the radio? What gives? Even if the bandwidth is low (mine is not) I should at least find the radio on the network. Why is there no way to add a static IP and network configuration to both the radio and the software. Sorry for the rant but I don't get it.

Thanks

Randy

KB4CTS

  

Photo of Randy Giffin

Randy Giffin

  • 6 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of Mark - WS7M

Mark - WS7M

  • 959 Posts
  • 337 Reply Likes
Randy,

Your VPN/Sonicwall as well as networking pieces at your office need to allow UDP packets across the VPN.  If they do not then the radio will not be found.

UDP packets are how SmartSDR finds the radio.
Photo of Walt - KZ1F

Walt - KZ1F

  • 3040 Posts
  • 641 Reply Likes
You actually can, in a fashion, give the radio a perm IP address. Some routers more accurately refer to that as a reservation. You reserve the IP via the radio's MAC address. Is your remote laptop on precisely the same subnet, I.e. 192.168.0.n?

Also be sure to opn both TCP an UDP in your router.
(Edited)
Photo of Mark - WS7M

Mark - WS7M

  • 959 Posts
  • 337 Reply Likes
This is what I do Walt but from what I can see there is no way to tell SmartSDR without the UDP packet to connect to the radio at IP XX.YY.ZZ.AA.

I wish there was a mode in SmartSDR to say, "Don't try to find the radio... it is at XX.YY.ZZ.AA and list that in the list box.  Like a command line parm even:

SmartSDR -radio:XX.YY.ZZ.AA
Photo of Walt - KZ1F

Walt - KZ1F

  • 3040 Posts
  • 641 Reply Likes
Yes Mark, I was referring to Randy on that suggestion. Keep in mind too, FRS does not support WAN until sometime in 2.x. If I recall correctly the entire discovery logic changes to support true WAN.
(Edited)
Photo of Kevin LaFata / K0KEV

Kevin LaFata / K0KEV

  • 39 Posts
  • 12 Reply Likes
I've been using SoftEther VPN with some success (expect for speed issues).  You need to use the Bridging option as that assigns a local IP address to your remote machine that can receive UDP broadcast packets (which are necessary for things to work)

Here's some info:  https://www.softether.org/4-docs/1-manual/A._Examples_of_Building_VPN_Networks/10.4_Build_a_PC-to-LA...
Photo of Randy Giffin

Randy Giffin

  • 6 Posts
  • 0 Reply Likes

Thanks for al the great replies, I do have the ability in my router to assign a permanent reservations so I can lock the radio in that way but no way to tell the software where to look. Thanks for the UDP comment I will configure that and give it a shot shortly. As for the soft VPN client yes I do have the same subnet laptop 10.1.1.41 and 6300 is at 10.1.1.249

Thanks guys

Photo of Dan -- KC4GO

Dan -- KC4GO

  • 337 Posts
  • 68 Reply Likes
I have been using OpenVPN with my Night Hawk r7000 router for about 1.5 months.  Using a Dell XPS-13 i7 with 16 GB memory and 512 GB SSHD.
The issues are mostly the remote location network ability.  On a very good (4 to 5 bars) 4G phone signal it works reasonably well. 
Mostly happy with this but still thinking  about headset. Think I would like Bluetooth but still not sure.
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9013 Posts
  • 3413 Reply Likes
First, SmartSDR v1 is not WAN enabled.  SmartSDR is designed to operate on a single IP subnet.  We use a broadcast mechanism for radio discovery.  So your VPN must act like a bridged network connection where broadcast packets are forwarded to both ends of the VPN. 

Second, the radio does have a default gateway if your DHCP server allocates one, which I suspect it does.  The radio queries Internet NTP servers to set it's RTC and this would not be possible without a default GW.

Third, the radio does not need a reserved IP address.  If it is setup properly, a DHCP IP address allocation will work just fine.  

And Kevin K0KEV has offered a great link for setting up your VPN to allow you to use your FLEX-6000 at a remote location.
Photo of Randy Giffin

Randy Giffin

  • 6 Posts
  • 0 Reply Likes

Thanks for your reply Tim, my responses follow your order;

1.) WHY is it NOT WAN enabled? It should be in my opinion because many of us can not have antennas at our homes but can install something at our offices.

2.) Yes I do allocate a default gateway and I also have a GPS NTP server it would be great is I could enter that IP address directly into the radio.

3.) This refers to comment 1 since I ideally want to use my rig in different subnets have a static IP is a great help.

4.) Thanks to you and K0KEV

Best Regards

Randy

Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9013 Posts
  • 3413 Reply Likes
#1 - because it is not a support feature.  It will be included in SmartSDR v2.0

#2 - We use an NTP pool address for redundancy.  If the radio does not get it time, it does not adversely effect the operation of the radio. 

#3 - That is not currently possible because the radio has to be in the same IP subnet as the SmartSDR client.

#4 - the pleasure is all mine.
Photo of KY6LA - Howard

KY6LA - Howard, Elmer

  • 3467 Posts
  • 1328 Reply Likes
WAN will be part of V2.0 SSDR
Photo of Randy Giffin

Randy Giffin

  • 6 Posts
  • 0 Reply Likes

Thant would be GREAT!

Thanks

P.S. any idea when?

Photo of KY6LA - Howard

KY6LA - Howard, Elmer

  • 3467 Posts
  • 1328 Reply Likes
Your guess is as good as mine. They have to finish Maestro before getting to V2.p WAN
Photo of Rob N4GA

Rob N4GA

  • 145 Posts
  • 25 Reply Likes
Replying to track this thread. Tnx.
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9013 Posts
  • 3413 Reply Likes
Tentatively slated for later this year.  After the release of Maestro.
(Edited)
Photo of Rob N4GA

Rob N4GA

  • 145 Posts
  • 25 Reply Likes
This capability will likely sell you a LOT of radios... Probably should of done it first. 
Photo of Randy Giffin

Randy Giffin

  • 6 Posts
  • 0 Reply Likes

Thank You everyone

Randy

KB4CTS

Photo of Randy Giffin

Randy Giffin

  • 6 Posts
  • 0 Reply Likes
With every ones help I have it working over my VPN tunnel now I am on one subnet and the radio is on the other. Thanks again
Photo of Ken - NM9P

Ken - NM9P, Elmer

  • 3866 Posts
  • 1176 Reply Likes
I have successfully done remote via VPN with both SoftEther and my ASUS VPN enabled router. Both worked well, except that my shack-side internet service is limited in its upload speed to about 750 Kbps, which is just barely enough to function. With the ASUS router I am using PP2P format to run it with my iPad and my laptop. I have also used the ASUS router in openVPN mode with the laptop, which is a bit more secure.
(Edited)