Who has used C# with Multi Client/MultiFlex

  • 1
  • Question
  • Updated 1 month ago
I finally figured out how to disconnect the front panel of my M model radio (6600M) from my test program. But, I no longer get panadpater, waterfall or slice data from the radio.
I tried setting perimeters in the panadapter added event, but, still nothing.
I was really hoping to find a way to run my GUI app at the same time as the front panel is connected, using an unused panadapter & waterfall.
So, this is the reason for the question posted in the title.
I can run my nonGUI apps, just fine while the front panel is running. Just not at the same time with the GUI app that has a panadapter/spectrum display (and hopefully a soon to be working correctly waterfall).
  I am sure it's going to turn out to be something simple that's causing these issues. But, being simple minded, I cannot figure it out!!!
A little help and guidance would be greatly appreciated.
James
WD5GWY
Photo of James Whiteway

James Whiteway

  • 1059 Posts
  • 302 Reply Likes

Posted 1 month ago

  • 1
Photo of James Whiteway

James Whiteway

  • 1059 Posts
  • 302 Reply Likes
Well, it would appear that Mark and I are the only ones outside of FRS doing any sort of GUI programming with C# for Windows.
James
WD5GWY
Photo of Mark - W3II

Mark - W3II

  • 230 Posts
  • 49 Reply Likes
I did some checking. The VITA information you are looking for is only sent to GUI clients.
If you are a Non-GUI client regardless of your Client Binding the VITA packets for FFT and WATERFALL are not sent to you.  Now if you are a GUI client and you are using V2.5 there is only 1 client allowed. That would be the FRS GUI app. If you are running V3 then two GUI clients are allowed. I hope this helps.
Photo of James Whiteway

James Whiteway

  • 1059 Posts
  • 302 Reply Likes
Thank you Mark. I am slowly making progress.
I wish this stuff came to me easier like it did when I was younger. At 68, it seems my thinking cap is a bit loose!
James
Photo of James Whiteway

James Whiteway

  • 1059 Posts
  • 302 Reply Likes
Another quick reply Mark,
  I have been setting isGUI = true in my code. And prior to V2.x of SSDR and the API, things worked just like you say. And I was able to get spectrum data (and waterfall data as well) my app at the time, while not looking like much, worked.
After V2.x it quite working. Until, I found that the Size property that the API had been using was depreciated. ( commented out in the FlexLib source code) Instead, they added the  Height and Width properties. Once I set that, it started working in v.3.027 and when I downgraded to v2.49 to test the main issue I was having of the M model radio's front panel Spectrum/Panadapter display freezing in V3.x, the issue was the same. The  spectrum Display freezes on both versions of the API, on the M Model radios front panel. It almost makes me wish I had kept my 6500 and Maestro. At least with that, I could revert to a version prior to V2.x and know my app would work.
But, I wanted to play around with learning more about Mult Client/ Multi Flex. But, as it stands, it appears that either there is an issue within the M model's front panel tablet's software, and how the radio sends data to a 3rd party GUI app that is NOT SSDR.
I did notice that when I connect SSDR to the radio from my pc that the radio's front panel displayed the MAC address of my client as well as when SSDR connected,a popup box with the info. BUT, also it causes the screen to flash orange on the M model's front display and the external monitor that I have.
I'm not sure why that is, but, it's all giving this old guy a real headache and making me thing i should just give up on this.
James
WD5GWY

Photo of Mark - W3II

Mark - W3II

  • 229 Posts
  • 49 Reply Likes
Are you able to record a video with your phone then post it for me to see?
Photo of James Whiteway

James Whiteway

  • 1059 Posts
  • 302 Reply Likes
Well, I tried recording a video. And guess what? It wouldn't do it again. Just a normal connection from SSDR to the radio. Maybe it was just a fluke. Or a residual from my app connecting from the same IP address.
  This gets more fun and frustrating(mostly frustrating) as I go along. I do wish there was someone that is using C# (FRS devs are you listening?) and the FlexLib api (v3.0.27) and making Multi Client (aka Multi Flex) actually work.
There is a section of FlexLib api that's called GUIClient.cs that has some parameters
in it that I have not set in the past. Plus, there are only a few that are Public. I've tried setting those from my app and either get errors, or nothing changes.
Getting tired of running around in circles.
James
WD5GWY


Photo of James Whiteway

James Whiteway

  • 1059 Posts
  • 302 Reply Likes
Issues fixed and now my test app works.
Thank you Eric for your guidance.
James
WD5GWY