When I run and install CAT, what ever version, the ports are NOT showing up?

  • 1
  • Question
  • Updated 4 years ago
I hope that someone can help. I am very confused...I have tried everything, I believe. When I first downloaded and installed PowerSDR with its early CAT-64 COM Port Program, the COM Ports that were created would show up for use in every RCP (Radio Control Prpgram) including HRD, TRX Manager, etc.. PowerSDR would respond well to CAT Commands sent to that port via any RCP such as HRD, all versions...I would be able to run or control SmartSDR using HRD with no problem using t he "Main" COM Port created by this program. The COM Ports would show up in my Device Manager, if I remember correctly as well. The COM Ports created by CAT-64 and SmartCAT would show up in the lists of viable COM Ports available in the various RCPs.

Now, the COM Ports that are created by SmartCAT don't seem to show up ANYWHERE! What is strange is that within the SmartCAT program itself, using the Command Tester, the radio responds just fine to commands sent to SmartSDR just fine through that "Main" COM Port...assuming that is whrere the data is coming from? Yet, the Main COM Port generated by the SmartCAT program as welll as all of the other COM Ports it creates, do not show up anywherre and they don't seem to do anything except work in the Command Tester routine of the SmartCAT software.

When using DDUtil Version-3, I can get a slave radio to follow SmartSDR just fine. Additionally, the SPE Linear follows. I don't know where that data is coming from...Port 7809? Can someone please help me with this? How can I get SmartSDR to hook up with RCPs again? Using DDUtil does NOT help. The COM Ports generated by SmartCAT don't show up in DDUtil either. Yet, DDutil is getting data from somewhere for the slave radio function, etc.

I can get Digital Master 780 to follow just fine using DDUtil Version-3. However, again, No COM Port for Radio Control is recognized by any RCP.

Thanks in advance!
Daniel Baral

Can someone email me with some help?
Photo of W3DCB


  • 86 Posts
  • 14 Reply Likes
  • confused

Posted 4 years ago

  • 1
Photo of Steve - K5FR

Steve - K5FR

  • 62 Posts
  • 8 Reply Likes
Daniel - DDUtil v3 talks directly to the F6K to get basic radio state information it uses to send freq/band data to hardware (amps, slave radio, HRD, SteppIR, others) and DOES NOT use SmartSDR Cat. DDUtil's RCP clients DO USE SmartSDR Cat as it was developed specifically for servicing these types of clients.

If the SmartSDR Cat ports are not showing up in the RCP's or in Device Manager then I would guess you either have a bad load of SmartSDR Cat or, you're running another virtual serial port program that has also created ports. Under some conditions SmartSDR Cat may not create ports if there are already a bunch of com0com or VSPM ports present.

Deleting all other virtual ports and using only SmartSDR Cat to create your ports is the proper way to create the virtual serial ports you need.
Photo of Al K0VM

Al K0VM, Elmer

  • 555 Posts
  • 91 Reply Likes
With the current state of the software, It is necessary to that have the harware powered (Flex 6x00) up and connected ( able to run SmartCAT) .. If not SmartCAT will not show newly created virtual Ports ( or any)... After turning on the hardware they should become visalbe the next time you start SmartSDR CAT...
To clean things up suggest that you use SmartSDR CAT to 'Delete all Virtual Ports', close and reopen SmartSDR CAT, and then recreate your ports...

Photo of W3DCB


  • 86 Posts
  • 14 Reply Likes
I did the following several times already. Figured I would give it one more try...I uninstalled everything. Then, I rebooted. Then, I re-installed Smart-SDR and Smart-CAT. Then, I rebooted again. When I re-started Smart-SDR and Smart-CAT, it worked! It worked! Yeah boy, it worked! Thanks!