what's up with the 'nag screen' ?

  • 2
  • Question
  • Updated 7 months ago
  • Answered
  • (Edited)
updated to v1.11.12..

boot / power up sequence here is

1. wireless extender
2. pc
3. flex 6500 ( sometimes.... ok, usually )
4. DxLab launcher, start..
5. CMDMicro...
6 wsjt-x  (sometimes.)
7 wsjt-x jtAlertX  (works GREAT with wsjt x)
8 OpenHPSDR PowerSDR mRX ps, 3.4.2 (sometimes.) for my Red Pitaya
9 old n1mm greyline ( hey, i like it..)

produces consistently good results, for quite a while...

but, the SmartSDR Cat nag screen, if the 6500 isn't booted in advance??
 the software loads, why do i need this?

like, whas up wi dat?

w5xz, dan
Photo of W5XZ - dan

W5XZ - dan

  • 562 Posts
  • 82 Reply Likes
  • annoyed

Posted 7 months ago

  • 2
Photo of W5XZ - dan

W5XZ - dan

  • 562 Posts
  • 82 Reply Likes
same thing, if i boot my 6500 before my pc...i don't need this nag screen...

does 2.xx does this too??

just sayin...w5xz, dan
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 8670 Posts
  • 3253 Reply Likes
I have no idea what you are referring to.  There are no "nag screens" in SmartSDR.  Care to share an image?
Photo of Eric - KE5DTO

Eric - KE5DTO, Official Rep

  • 653 Posts
  • 198 Reply Likes
If you're talking about the radio selection screen, it sounds like you may have turned of the option to Auto Connect to the last radio used.  If this is the case, to turn this back on right click on the Radio Connected (or Radio Not Connected) text in the upper right of the SmartSDR CAT main window to bring up the option and the left click to toggle it on or off.
Photo of Greg - KØGDI

Greg - KØGDI

  • 57 Posts
  • 3 Reply Likes
How can I accomplish this?
Photo of Kevin K4VD, Elroy

Kevin K4VD, Elroy

  • 775 Posts
  • 170 Reply Likes
I think this is what you're looking for...
https://community.flexradio.com/flexradio/topics/simplified-startup

I haven't tried it with the new versions but used to use it in the icon I used to start up SSDR.


You can actually do this with a parameter added to the shortcut that starts SmartSDR.  Just add "--serial=nnnn-nnnn-nnnn-nnnn" to the end of the Target line of your shortcut (right click -> Properties) and fill in your serial number for the nnnn's.
Photo of Jay / NO5J

Jay / NO5J

  • 1364 Posts
  • 196 Reply Likes
Greg
This has been documented before, here in the Community.
You do it by editing the Shortcut that you use to start SmartSDR.

Add a commandline option to the end of that shortcuts Target value.

My shortcut's default Target value is ...
"C:\Program Files\FlexRadio Systems\SmartSDR v2.0.19\SmartSDR.exe"
Yours should be similar.

The Serial to use is the Serial number/value displayed in SmartSDR's Radio Setup / Radio / Radio SN: .

The syntax for the CommandLine string is ...

--serial=####-####-####-#### 


"C:\Program Files\FlexRadio Systems\SmartSDR v2.0.19\SmartSDR.exe" --serial=####-####-####-####

Put the above into the Target Box.
Just substitute your Radios Serial Number for the #'s.
Make sure to insert a single space, between the final " and the --serial=.

The Shortcut should now autostart SmartSDR, allowing you to skip choosing which radio you want it to connect to.

73 Jay - NO5J 
(Edited)
Photo of Greg - KØGDI

Greg - KØGDI

  • 57 Posts
  • 3 Reply Likes
That worked wonderfully!  One less step in the boot up process for the APRS DIGI / IGATE.
Photo of W5XZ - dan

W5XZ - dan

  • 562 Posts
  • 82 Reply Likes
thanks eric, that fixes it...

73, w5xz
Photo of Kevin - KS0CW

Kevin - KS0CW

  • 80 Posts
  • 11 Reply Likes
I was wondering about this too... It started for me with 1.11 install, I suspect that "of" is the default as I don't recall changing it during or post installation... :)
Photo of Eric - KE5DTO

Eric - KE5DTO, Official Rep

  • 653 Posts
  • 198 Reply Likes
Hmm.  Strange.  It is setup to be on by default as best as I can tell.
Photo of W5XZ - dan

W5XZ - dan

  • 562 Posts
  • 82 Reply Likes
when i now boot my shack pc, i get this:
Photo of W5XZ - dan

W5XZ - dan

  • 562 Posts
  • 82 Reply Likes
before i upgraded i got this:
Photo of W5XZ - dan

W5XZ - dan

  • 562 Posts
  • 82 Reply Likes
i may, or may not choose to boot the 6500 on the shack pc...but i don't need this 'nag screen'..

just sayin...

w5xz, dan
Photo of Phill Beistel

Phill Beistel

  • 22 Posts
  • 3 Reply Likes
Did you try to minimize the 'Nag Screen'? I had this happen in an earlier version And once I minimized the cat screen and rebooted minimized it stayed! Just sayin!
Photo of W5XZ - dan

W5XZ - dan

  • 562 Posts
  • 82 Reply Likes
thanks Phill....eric's tip, above, solved my problem..
Photo of Duane  N9DG

Duane N9DG

  • 71 Posts
  • 24 Reply Likes
I saw this too. Note that it was the SmartCAT radio chooser, not the GUI client radio chooser dialog. It only occurred once after the initial install and before the SmartCAT client re-established a relationship with the radio box. Simply selected the radio in the dialog, minimized it, and haven't seen it come up since.

Given the remove and reinstall changes done by the SmartSDR installer to the VSP code as part of the 1.11 upgrade, it makes sense why this could occur.

Additionally I should note that I'm running Win7 Home x64. I log into the computer with a non admin level account. Then launch SmartSDR client with right click "Run as administrator".
(Edited)