What type of Amp are you using??

  • 3
  • Question
  • Updated 2 weeks ago
I'm doing a poll on HF Amps 

I would like to know which HF amp you are using and if it is CAT controlled.

Let me know!  

73, Mike va3mw
Photo of Michael Walker

Michael Walker, Employee

  • 1102 Posts
  • 328 Reply Likes

Posted 9 months ago

  • 3
Photo of Robby Robertson

Robby Robertson

  • 15 Posts
  • 3 Reply Likes
I am using an Ameritron AL - 1200 that runs about 1200W max. I normally use it at 800W when I use it. My KPA500 is back in the US and will be for sale along with the rest of the K-Line.


Photo of Craig Williams

Craig Williams

  • 240 Posts
  • 73 Reply Likes
Just built  an Elecraft KPA-500. Still building the tuner. Amp replaces an AL811 so I can go power remote. Hopefully I can figure out how to get the 2 USB cables working for full computer control remote.
Photo of Pat - WH6HI

Pat - WH6HI

  • 455 Posts
  • 91 Reply Likes
Software for remote control available from Elecraft.

link

 https://elecraft.com/pages/firmware-software

 Logging and Control Software —->  KPA1500, KPA500, KAT500 Remote Software 
(Edited)
Photo of SQ8N_Pawel

SQ8N_Pawel

  • 2 Posts
  • 0 Reply Likes
I am using  Flex-6500 + OMPower OM2000A+, CAT / Ethernet controlled.  https://www.om-power.com/products/om2000aplus
Sensational amplifier, full automatic

SQ8N Pawel

Photo of Bob  KN4HH

Bob KN4HH

  • 112 Posts
  • 21 Reply Likes
Flex 6500 driving a SPE Expert 1.3K-FA  CAT controlled

Bob, KN4HH
Photo of Tom K3TF

Tom K3TF

  • 73 Posts
  • 4 Reply Likes
I am using the Elecraft KPA1500 with my Flex 6700. I use the USB CAT cable from Flex and it works great!

Tom...
K3TF
Photo of Richard Zalewski

Richard Zalewski

  • 103 Posts
  • 9 Reply Likes
I am an extremely satisfied user of the Elecraft KPA1500 amplifier with my 6600M.
Photo of Gary W9GD

Gary W9GD

  • 19 Posts
  • 1 Reply Like
I am using a SPE 1.3K . on a 6400M  Using the Dan SPE cable set interface and Cat

Photo of KF4HR

KF4HR

  • 858 Posts
  • 281 Reply Likes
I had been using an Alpha 87A for the last year or so and it worked beautifully.  In fact, my only minor gripe was its 3-minute warm up delay.  A couple of months ago I received my PG-XL which has performed well.  My only gripe with the PG-XL is the output wattage meters indicate Average, not Peak power readings in the SSB mode.   Hopefully 4o3A will eventually provide a software option for this.
Photo of N1DZ

N1DZ

  • 3 Posts
  • 0 Reply Likes
Using a Ten Tec Centurion and a Ten Tec Centaur. Old school. Instant on. No issues with overdrive. No cat control. Only hand control.
I had a PW1 a while back and ever since I am hesitant to go for solid state amp.
The SPE looks promising.
73 N1DZ
Photo of Brian - W9HLQ

Brian - W9HLQ

  • 58 Posts
  • 15 Reply Likes
ALS-1306 with automatic band switching.  Also have remote power on/off. Smooth operating combination.