Weird SmartSDR login issues

  • 1
  • Question
  • Updated 2 months ago

Having some weird issues with smart link which really doesn’t make any sense to me. My friend and I both have Flex 6400’s radios and live pretty much across the country from each other.

I’m able to log into his radio 6400 (and mine) using my desktop computer here in California. He’s also able to log into my radio also from Tennessee on any network or device. But he’s not able to log into his own radio unless he’s on his own network. Also I’m not able to log into his radio with my ipad or iphone even from the same network my desktop computer is on.

However I’m able to see his radio but unable to log into it, stays in discovery mode. I did notice one thing, on the discovery page my radio stated UPnP and his stated HP.

He did the router forwarding but that didn’t help or may any changes.

Just weird he’s able to get to my radio but not his own outside of his own network, but I’m able to get to his radio but only from my desktop computer.

Thanks.
Photo of Mike Steiner, K7QDX

Mike Steiner, K7QDX

  • 34 Posts
  • 7 Reply Likes

Posted 3 months ago

  • 1
Photo of Mack McCormick

Mack McCormick, Elmer

  • 440 Posts
  • 151 Reply Likes
Mike,

These are unusual symptoms and are definitely related to a port being blocked or an Internet routing problem. My best guess is the Windows Firewall or anti-virus program are at the root of the issue.

73,

Mack
W4AX
Alpha Team
Photo of Mike Steiner, K7QDX

Mike Steiner, K7QDX

  • 34 Posts
  • 7 Reply Likes
My friend did the manual routing of ports with no change. Doesnt explain that I can log in on my computer but he cant. 
(Edited)
Photo of Carmine Iannace, W1EQX

Carmine Iannace, W1EQX

  • 49 Posts
  • 19 Reply Likes
Mike, in regards to your computer - is it hardwired via a Ethernet cable? The other devices you can’t connect with are obviously wireless. If this so, what brand of wireless are you using to connect these devices?. Describe your set up in a bit more detail. Is your in-house wireless on the same ip subnet range as your rig and desktop computer?


W1EQX Carmine
(Edited)
Photo of Mike Steiner, K7QDX

Mike Steiner, K7QDX

  • 34 Posts
  • 7 Reply Likes
The radio is hard wired (Cat6) into the router. No wireless except the Ipad and iPhone. 

This wouldn't answer the question that I can log into his radio from my desktop from my house in California but he cant log in from his radio from his laptop from work but can log into my radio from his work to my radio.

Hope that makes sense?
Photo of Doug K0DV

Doug K0DV

  • 142 Posts
  • 17 Reply Likes
I've had this problem before.  For remote make sure you are signing into to an I.P. that has a different subnet (the 3rd number in the I.P.) There may be an I.P. conflict. 
Photo of Mike Steiner, K7QDX

Mike Steiner, K7QDX

  • 34 Posts
  • 7 Reply Likes
I don't understand...
Photo of Eric - KE5DTO

Eric - KE5DTO, Official Rep

  • 854 Posts
  • 314 Reply Likes
What happens when he runs the SmartLink Settings -> Network Test?
Photo of Mike Steiner, K7QDX

Mike Steiner, K7QDX

  • 34 Posts
  • 7 Reply Likes
Green light, UPNP passed but port fowarding failed.
Photo of Eric - KE5DTO

Eric - KE5DTO, Official Rep

  • 854 Posts
  • 314 Reply Likes
So long as the result is green, this tests the connection between the SmartLink server and the radio.  If the connection won't work, it may be a routing issue on the client side.  This makes sense given that you can connect successfully.
Photo of Mike Steiner, K7QDX

Mike Steiner, K7QDX

  • 34 Posts
  • 7 Reply Likes
Upon going back and re-registering smartlink found out that the ports were backwards on the router for port forwarding. I dont know... any case its working now. Thanks...
Photo of Eric - KE5DTO

Eric - KE5DTO, Official Rep

  • 854 Posts
  • 314 Reply Likes
Glad to hear that.  Thanks for keeping us updated.