V3 and Slicemaster 6000

  • 1
  • Problem
  • Updated 4 months ago
Is anyone else having a problem with V3 and Slicemaster 6000?  Slicemaster 6000 is reporting that DAX is not enabled, yet it is enabled in the DAX panel.  Neither WSJT-X or CW Skimmer is launching.  I tried this initially with two clients running, but then retried with one client after rebooting the client PC and cold rebooting the Flex 6600.  No change.

Chuck
Photo of W9WLX-Chuck

W9WLX-Chuck

  • 62 Posts
  • 16 Reply Likes

Posted 5 months ago

  • 1
Photo of Rick Hadley - W0FG

Rick Hadley - W0FG

  • 601 Posts
  • 130 Reply Likes
Slice Master does not yet support V3.  Ed has indicated he's working on a version that will.
Photo of K1DBO

K1DBO

  • 542 Posts
  • 112 Reply Likes
Rick is correct.  Slice Master needs a bit of work to support the new API.  It's in the plan but is still weeks away at best.

--Don

Photo of Rich McCabe

Rich McCabe

  • 1120 Posts
  • 239 Reply Likes
Don, if you need any help alpha testing, let me know.

Rich
Photo of W9WLX-Chuck

W9WLX-Chuck

  • 62 Posts
  • 16 Reply Likes
Thanks.  I knew there were issues with forward compatibility with the APIs.  I thought I saw a post where SM 6000 was ok, but I must have mis-read.  Launching the individual app still works well.
(Edited)
Photo of Ed - W2RF

Ed - W2RF

  • 257 Posts
  • 77 Reply Likes
By choosing not to make the V3 API compatible with previous versions, Flex has made quite a bit of work for us developers. Fortunately SDR-Bridge is based on the C# .NET FlexAPI, which although requiring work, eased the conversion effort somewhat.

So SDR-Bridge V3, which is compatible with SSDR V3, is currently in alpha test and appears to be working well. If good results continue I hope to release a public beta soon, perhaps in the next few days.

If you are a CW Skimmer user it may tide you over while Don K1DBO is finishing his conversion. (Good luck Don, I'm looking forward to your new version.)

73 Ed W2RF
(Edited)
Photo of W9WLX-Chuck

W9WLX-Chuck

  • 62 Posts
  • 16 Reply Likes
Thanks, the third party work is appreciated!  I will look at SDR-Bridge as well, given it may be available earlier.  I seem to have CW Skimmer working with version 1.5.1.124, but I do need to enter the LO frequency manually.  

I noticed that K3II will need to work on FRStack too, if he chooses to keep it alive.  Some functions still work, but my main use was the pseudo-squelch/S-level mute function for SSB, which does not.
Photo of Ed - W2RF

Ed - W2RF

  • 257 Posts
  • 77 Reply Likes
There is a newer version that 1.5.1 that may solve the LO problem. But only for V2. http://www.qrv.com/sdrbridge.html

Photo of Zack Schindler - N8FNR

Zack Schindler - N8FNR

  • 152 Posts
  • 27 Reply Likes
I was going to get V3 but will hold off now until I know that SDR-Bridge, DXLab, FRlogger and Slicemaster are all working OK with it.
Photo of Ed - W2RF

Ed - W2RF

  • 257 Posts
  • 77 Reply Likes
Jump in, join the fun :-)
Photo of Erik SM0JCA

Erik SM0JCA

  • 16 Posts
  • 4 Reply Likes
I just upgraded my 6400M and SmartSDR to v 3 and it seems to be OK. Also found out that SliceMaster is not working but WSJT-X in FT8 mode works fine when I set the radio CAT port to Kenwood TS-2000, 19200 baud. Worked a few stations and everything seems normal. 
As a side note I needed to check the DAX as the DAX channel 2 indicated Driver error after I made a complete removal of the previous version before upgrading. It turned out to be a wrong name on "DAX RESERVED IQ RX2" audio unit. Now all is well.
73 de Erik SM0JCA
Photo of W9WLX-Chuck

W9WLX-Chuck

  • 61 Posts
  • 16 Reply Likes
Setting the radio to Flexradio 6xxx works well too.  I used it today with V3 and it performed flawlessly.

Photo of terry

terry

  • 28 Posts
  • 1 Reply Like
reverting back to 2.4.9.  most of my activity is FT8 these days.  not looking to have to modify my current methods to use new software version.  will wait to 3rd party updates and then go back to 3.0.
Photo of Pat N6PAT

Pat N6PAT

  • 786 Posts
  • 254 Reply Likes
Terry,

What features of V3 did you upgrade for? I'm just curious because you so quickly decided to revert back to 2.4.9
Photo of Rich McCabe

Rich McCabe

  • 1120 Posts
  • 239 Reply Likes
Its likely I will jump back and forth. I upgraded to get a bug fixed that drives me crazy which they did fix. But as soon as 2.5.x comes out I will probably stay with that until Don gets SM working.
(Edited)
Photo of terry

terry

  • 28 Posts
  • 1 Reply Like
I reverted back because slicemaster does not support 3.0 and my current primary operating mode is FT8. I don't feel inclined to have to do work arounds within setup to accomodate the 3.0 upgrade.
Photo of Neil D Friedman N3DF

Neil D Friedman N3DF

  • 238 Posts
  • 75 Reply Likes
I found setting up my 600M for FT8 without Slicemaster or any other third-party intermediate program was reasonably quick and easy and has been 100 percent reliable. 
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1421 Posts
  • 308 Reply Likes
I use WSJT-X and JTAlert-X with 3.0 fine. JTAlert-X allows me to log my contacts directly to DX Labs Keeper or HRD Logbook directly.

Dave wo2x
Photo of Rich McCabe

Rich McCabe

  • 1120 Posts
  • 239 Reply Likes
Yea that should be easy as I have always did that. CW Skimmer is more of a challenge :)
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1421 Posts
  • 308 Reply Likes
We will need to wait until either SliceMaster or SDR Bridge are upgraded.

Dave wo2x
Photo of Cal Spreitzer

Cal Spreitzer

  • 449 Posts
  • 113 Reply Likes
You can add DDuti to the list of non-working 3rd party apps.  I'm back to V2 as well. 

Cal/N3CAL
Photo of terry

terry

  • 28 Posts
  • 1 Reply Like
Neil -  current version of slicemaster does not support 3.0.  

David - I may try JTAlert-X.
Photo of W7OMM

W7OMM

  • 5 Posts
  • 0 Reply Likes
I am looking forward to the updated version of Slice Master - thank you, Don!  I just received my 6400 a few days ago, and installed SSDR V3.  When Slice Master didn't work properly, I looked for answers and found them here - thanks again!

Claudia

(Edited)
Photo of W0JM

W0JM

  • 2 Posts
  • 0 Reply Likes
Is there a timeframe when Slicemaster 6000 will support SmartSDR v3
Photo of W7OMM

W7OMM

  • 5 Posts
  • 0 Reply Likes
The latest release works great with SmartSDR v3!
Photo of W0JM

W0JM

  • 2 Posts
  • 0 Reply Likes
Thanks Claudia for that information. I'm getting my new Flex 6600 tomorrow and am checking into what software will and will not work with SmartSDR v3.
Photo of W7OMM

W7OMM

  • 5 Posts
  • 0 Reply Likes
Wonderful - enjoy!