V2 Panels not closing when disconnected?

  • 1
  • Question
  • Updated 1 year ago
I am seeing what I think is a strange behavior with SmartSDR V2.  I operate with multiple monitors and I have the Flex Settings panel opened in a seperate and undocked location on a different screen than the Panafall.  The issue comes up when I start SmartSDR on another device.

Here is what I see happening.  I log in to SmartSDR from another device which shows the Flex is in use and I disconnect the "in use" session.  I can then launch SmartSDR on the new device normally.  On the old device the Panafall shuts down and I get a window indicating that another device has shut it down.  However, the undocked settings window does not shut down and instead looks as you see in the screen capture below. 

I would have thought that normal behavior would have all windows docked or undocked shutdown and not just the Panafall.  I have not tested if this happens to other undocked windows.

John K3MA


Photo of John - K3MA

John - K3MA

  • 286 Posts
  • 82 Reply Likes

Posted 1 year ago

  • 1
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9153 Posts
  • 3492 Reply Likes
This is not the intended behavior.  I have entered this problem report into our bug tracker as issue #5215 for additional investigation. Thank you for the defect report.
Photo of John - K3MA

John - K3MA

  • 286 Posts
  • 82 Reply Likes
Your welcome.  I thought the second SWR, Temp meter and the FWD Power going to 2K was interesting.

Am I correct in assuming that is part of the software to be utilized once the amplifier is released?  Maybe a stupid question since there is a OPR button and AMP indicator highlighted.
(Edited)
Photo of Bill -VA3WTB

Bill -VA3WTB

  • 3071 Posts
  • 674 Reply Likes
My V2 panel does not have the amp button?
Photo of John - K3MA

John - K3MA

  • 286 Posts
  • 82 Reply Likes
Mine does not either Bill.  That only appears when I go thru the disconnect/log in on another device process as outlined in the first post.  It seems the bug is exposing additional GUI options already baked into the software but not released for prime time.  Not as big a deal as the recent Apple leak but maybe a preview none the less.
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9153 Posts
  • 3492 Reply Likes
John - the answer is yes.  The amp controls only show up if the amp is connected to the radio and SmartSDR-Win shows the modified display.  In your case, the radio is disconnected and the orphaned window does not have accurate state information, so it defaulted to that screen.  It is a consequence of the bug.