v1.6.17 not connecting to my DX4WIN logging program?

  • 1
  • Problem
  • Updated 4 years ago
  • Solved
  • (Edited)
I followed release notes for installing V1.16 and now cannot connect DX4WIN logging program to 6500.  I'm running W10 with all latest updates.  DX4WIN has worked flawlessly with my 6500 for the last 2 years.  This is the first time I have had issues....  Running "Kenwood 2000" interface in DX4WIN as before.  I have attached the log for CAT for com5:

I'm using COM5 as to 3rd party programs.  All my real and virtual ports are correct after upgrade but I noticed the new CAT didn't create two shared ports, com10-20 and 11-21, is this normal?

Also, when I try to ADD a port in the CAT for OTRSP, PTT or Winkeyer I do not get the "Client COM and CAT COM" displays.  I get Client COM and Radio 1& 2 slice boxes??

I just tried V1.16.17 with N1MM+ and logger and radio seem to be talking to each other just fine.   So radio is working but something broke trying to communicate with DX4WIN....

All help appreciated as I'm dead in the water....
Photo of k0eoo

k0eoo

  • 621 Posts
  • 87 Reply Likes

Posted 4 years ago

  • 1
Photo of Neal - K3NC

Neal - K3NC, Elmer

  • 531 Posts
  • 183 Reply Likes
Send me an email at nealk3nc@gmail.com and I will give you a hand!
Photo of Doug Hall

Doug Hall

  • 214 Posts
  • 60 Reply Likes
Were you able to get this working? A friend of mine here in town is having the same problem.
73,
Doug K4DSP
Photo of Neal - K3NC

Neal - K3NC, Elmer

  • 531 Posts
  • 183 Reply Likes
Dennis and Doug,

I have been able to investigate this on my own computers. I buy licenses to all Ham logging programs, even though I own DXBase, primarily to support other software suppliers as well as provide a test bed when working on Flex customer problems.

Anyway, DX4WIN is querying on the comm port the status of "VFOa" and "VFOb", and, as you know, the new CAT system only deals with 1 slice at a time. If you enter a FT1; command that puts the radio in 'split' mode, the FB command does provide a proper response but normally it will only return a ?.

DX4WIN is obviously awaiting a proper reply to the second vfo query and timing out the whole connection when it doesn't receive it.  In comparison, DXBase awaits the second vfo info and after timing out just accepts that only 1 vfo is reporting.

I have written Paul about what I have seen (and heard back from Flex) so we will see where it goes.

73
Photo of Doug Hall

Doug Hall

  • 214 Posts
  • 60 Reply Likes
Thanks, Neal. I've never used DX4WIN, but my friend has been using it for years and was disappointed that it stopped working with v1.6. It appears that DX4WIN hasn't been updated in 5 years, so it seems unlikely that any updates are forthcoming.
Photo of Javi LU5FF

Javi LU5FF

  • 27 Posts
  • 0 Reply Likes
I have the same problem, I have not been able to solve

73s
Javi LU5FF
(Edited)
Photo of Neal - K3NC

Neal - K3NC, Elmer

  • 531 Posts
  • 183 Reply Likes
I have heard from the author and apparently we can change the behavior without programmatic changes.  I will take a look later tonight.
Photo of Neal - K3NC

Neal - K3NC, Elmer

  • 531 Posts
  • 183 Reply Likes
I think this radio definition will work for you, download it, unzip it and put the flexradioSSDR.rig file into the radios folder of your DX4WIN installation.
http://abrohamnealsoftware.com/flexradioSSDR.zip

73
Photo of Doug Hall

Doug Hall

  • 214 Posts
  • 60 Reply Likes
Thanks, Neal, but I get a 404 when I try to download the file.
Photo of k0eoo

k0eoo

  • 621 Posts
  • 87 Reply Likes
Hello Neal and et al,

I clean forgot about the VFO A&B issue with DX4WIN.  Hope your fix does the trick.  Neal, the link you give for the fix gives a 404 error....

Thank you for the help!
Photo of Neal - K3NC

Neal - K3NC, Elmer

  • 531 Posts
  • 183 Reply Likes
Official Response
Photo of k0eoo

k0eoo

  • 621 Posts
  • 87 Reply Likes
Hello Neal,  the patch seems to be working.  Thank you! I will do some more testing and let you know if I find any issues.  So far I can click on a spot and radio jumps to correct frequency.  Thank you!
Photo of Neal - K3NC

Neal - K3NC, Elmer

  • 531 Posts
  • 183 Reply Likes
I have  uploaded a newfile that makes spots work correctly I believe. 

73

This conversation is no longer open for comments or replies.