Using FT8 with Maestro

  • 1
  • Question
  • Updated 1 month ago
I have the 6700 and the Maestro.  I have no problem running FT8 with SmartSDR, but I'm having no luck using the Maestro for FT8. With WSJT-X and the DAX app running on my computer and DAX turned on at the Maestro, I see the received FT8 data from the Maestro going in to the DAX RX, but I cannot get WSJT-X to transmit. The TX channel shows no audio. When the Maestro is being used, I also get a configuration error.  Is there a way to make the pair of WSJT-X and Maestro work using DAX, or do I always have to use WSJT-X when SmartSDR is running?
Photo of Doug K0DV

Doug K0DV

  • 134 Posts
  • 16 Reply Likes

Posted 1 month ago

  • 1
Photo of Jay / NO5J

Jay / NO5J

  • 1577 Posts
  • 227 Reply Likes
Doug 
Can you post a screenshot of the Radio tab of the WSJT-X configuration dialog?

When configured correctly WSJT-X works FB  with both SmartSDR, and Maestro.

    #FlexRadio IRC chat

For real-time discussions

        SDRgadgets

User created documentation.
           Volunteer!!

         73, Jay - NO5J

Photo of Doug K0DV

Doug K0DV

  • 134 Posts
  • 16 Reply Likes
Sure..


This works fine when used with SmartSDR, but only RX works when I turn on the Maestro.  The Radio setting under "Rig" is necessary to prevent the program from occasionally losing TX when SmartSDR is in use..

Photo of Jay / NO5J

Jay / NO5J

  • 1577 Posts
  • 227 Reply Likes
Doug

Can you explain how you ended up using port 93, which might be just fine, but I wonder if you might be having problems with Ghosted Comports, that are preventing you from assigning lower port numbers or if you are having issues with com ports being marked as "Busy", or "In Use".

Other than that your Radio tab settings don't appear to be the issue.

    #FlexRadio IRC chat

For real-time discussions

        SDRgadgets

User created documentation.
           Volunteer!!

         73, Jay - NO5J

Photo of Doug K0DV

Doug K0DV

  • 134 Posts
  • 16 Reply Likes
Jay, it was one of the ports offered by WSJTX. (See below)

:
Photo of Jay / NO5J

Jay / NO5J

  • 1577 Posts
  • 227 Reply Likes
Doug
Normally windows will assign the next available, sequential numbered comport. So I'm curious how you ended up with port 93. Did you create port 93 intentionally? WSJT-X just displays the list of ports configured in the OS, How many ports in total are you using? Have you checked for Ghosted com ports?

    #FlexRadio IRC chat

For real-time discussions

        SDRgadgets

User created documentation.
           Volunteer!!

         73, Jay - NO5J

Photo of Doug K0DV

Doug K0DV

  • 134 Posts
  • 16 Reply Likes
I'm running the Control Knob on COM94, since it would not work on lower ports. There appear to be some ports in the list that are no longer in use. I don't think there is any conflicts with Port 93.
Photo of Jay / NO5J

Jay / NO5J

  • 1577 Posts
  • 227 Reply Likes
Doug
I could be wrong, I'd need to actually check your ports myself, but IMHO your screenshots indicate a MESS. Contact me thru the Flexradio IRC Chat Channel link in my post signature below, I can check for and also assist you in cleaning up any messes that might be. 

Ghosted/Hidden Com Ports are a problem, they serve no useful purpose at all, and should be removed whenever they exist. They just get in the way of correct configuration, and can cause port communication errors.  

    #FlexRadio IRC chat

For real-time discussions

        SDRgadgets

User created documentation.
           Volunteer!!

         73, Jay - NO5J

Photo of Doug K0DV

Doug K0DV

  • 134 Posts
  • 16 Reply Likes
When I check for hidden ports, no ports are added to the above list.
Photo of Doug K0DV

Doug K0DV

  • 134 Posts
  • 16 Reply Likes
I cleared all the "ghost ports" with COM Name Arbiter Tool. All my ports to port 92 where checked.  Running the Arbiter still leaves 92, 93 and 94. From the above list of COM ports the Arbiter shows that 9, 16, 92, 93, 109,192 and 193 are in use.  COM ports 5, 6,7,8,9 are also in use, 7 & 8 are hardware ports.
Photo of Doug K0DV

Doug K0DV

  • 134 Posts
  • 16 Reply Likes
I still get the configuration error warning when I run the Maestro
Photo of Doug K0DV

Doug K0DV

  • 134 Posts
  • 16 Reply Likes
Jay, thanks for all the help, with the clearing of ghost ports and unnecessary device managers from old software, we were able to get Maestro to use its DAX to provide TX audio when running FT8. I appreciate all the time you spent with me doing this. Everything is performing very well now.
Photo of Jay / NO5J

Jay / NO5J

  • 1577 Posts
  • 227 Reply Likes
Doug
Have you had any trouble with my personal WSJT-X settings? I never got around to setting things back to the defaults. Things like font choices, palettes, etc.

    #FlexRadio IRC chat

For real-time discussions

        SDRgadgets

User created documentation.
           Volunteer!!

         73, Jay - NO5J

Photo of Doug K0DV

Doug K0DV

  • 134 Posts
  • 16 Reply Likes
All FT-8 settings are the same.  I did call up a different font.