Uncertain decoding , WSJT-X v1.8.0 r8193, Flex5000a/HRD.

  • 1
  • Question
  • Updated 9 months ago

I start WSJT-X v1.8.0 r8193, it seems to work good in receive mode. Signals appear on the waterfall. However, decoding is uncertain. One time is very good refreshing every 15 seconds pass, but more often noting is decoded or only few lines.

Photo of Wojtek Daraz

Wojtek Daraz

  • 13 Posts
  • 0 Reply Likes

Posted 10 months ago

  • 1
Photo of AH0U

AH0U

  • 260 Posts
  • 31 Reply Likes
The Flex freq. should show in the little freq. box in the upper right of the Skimmer
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1185 Posts
  • 242 Reply Likes
Make sure your clock is accurate for WSJT-X
Photo of Ria - N2RJ

Ria - N2RJ, Elmer

  • 2255 Posts
  • 884 Reply Likes
Check your signal levels too. Too low or too high and you won't decode.

For the clock sync install Meinberg NTP:

https://www.meinbergglobal.com/english/sw/ntp.htm
(Edited)
Photo of Wojtek Daraz

Wojtek Daraz

  • 13 Posts
  • 0 Reply Likes
Thanks to all for advises. I am using Dimension 4 v. 5.31 for clock synchronization. Checking sync with time.is/pl  gives negligible faults(0.02-0.08sec). DT values are 0.0 - 1.5sec. Signal levels are 30 - 40dB. Ok, I will try Meinberg  NPT instead. What else can be wrong?
Photo of Ria - N2RJ

Ria - N2RJ, Elmer

  • 2255 Posts
  • 884 Reply Likes
Try stopping and starting DAX in case it is corrupted. Just close and reopen the software.
Photo of Wojtek Daraz

Wojtek Daraz

  • 13 Posts
  • 0 Reply Likes

Dear Ria. Thank You for assistance. I had reset and reinstall WSTJ-X and HRD many times. Sometime it helps, but not always. Now, I turn my attention for clock sync again and after I set synchronization every 15 minutes It seems to going better.

All the best in New Year Ria

73 Wojtek sp8buh   

Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9152 Posts
  • 3471 Reply Likes
You are running VAC.  Make sure your sampling rates are matched to prevent Windows from doing sample rate conversions

https://helpdesk.flexradio.com/hc/en-us/articles/202118418-Sample-Rate-Synchronization-between-VAC-a...
Photo of Wojtek Daraz

Wojtek Daraz

  • 13 Posts
  • 0 Reply Likes

Thank You Tim. But described audio set up was done property. It must be another reason.  

Happy New Year

Photo of Darrin - KE9NS

Darrin - KE9NS

  • 102 Posts
  • 20 Reply Likes
Assuming you have used your VAC before on other programs with no issues, look at the wsjt-x waterfall. Are the FT8 signals falling within the 15 sec time lines that appear in the waterfall? If signals overlap or hit the lines, they may not decode.

FYI
When I was on my old 4 core PC, wsjt-x (and JTAlert-x) I had timing issues over the VAC which prevented some decodes. To get it re-synced, I had to hit the STOP/START button in PowerSDR. And FT8 transmits caused big issues with 100% system cpu usage.

So, I purchased a new motherboard with a modern CPU, and all those problems went away completely.
Photo of Wojtek Daraz

Wojtek Daraz

  • 13 Posts
  • 0 Reply Likes

Thank You very much Darrin.

My processor Intel Core i7-2600 3,4GHz.  Also 4 core. Must I change it?

All the best in New Year!

Wojtek sp8buh

Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9152 Posts
  • 3471 Reply Likes
Being an I7, I would not think so.
Photo of Darrin - KE9NS

Darrin - KE9NS

  • 102 Posts
  • 20 Reply Likes
Yup, should be fast enough ( i7-2600 = 4 cores for 8 threads total).
My old PC was 4 cores (no extra threading) and only 2.5Ghz
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9152 Posts
  • 3471 Reply Likes
In WSJT-X there is an option (checkbox) in the waterfall display labeled "Flatten".  Make sure it is NOT checked when using Flex SDRs.
Photo of Wojtek Daraz

Wojtek Daraz

  • 13 Posts
  • 0 Reply Likes
Thanks to all, but problem still exist. Currently, on 40m only 2 or max 7 lines decoded. Looking on waterfall should be more than 20.   
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1182 Posts
  • 242 Reply Likes
Look at the WSJT-X waterfall. What do you have set for bins/pixel and n/avg. Both of mine are 4. I found if they are not adjusted right it can affect decoding.
Photo of Wojtek Daraz

Wojtek Daraz

  • 13 Posts
  • 0 Reply Likes
Bins/Pixel is 4. N/Avg was 1. I set 4 now, but still this same.
Photo of Wojtek Daraz

Wojtek Daraz

  • 13 Posts
  • 0 Reply Likes

Darrin. Thank You. Above actual screen shot with VAC Control Panel.

Wojtek sp8buh

Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9152 Posts
  • 3471 Reply Likes
Your sampling rate on VAC2 is not equal, an even multiple or divisor of the radio's sampling rate.  It is 11025.  And it is not the same as VAC1.  You have a mismatch.  And you have too many over and underruns.  I covered this in my post from a week ago where the article talks about odd sample rate down and up conversions.

I also recommend setting the MS/int to 7, not 5.

Refer to this HelpDesk article for more information
https://helpdesk.flexradio.com/hc/en-us/articles/206605196-How-to-Setup-Virtual-Audio-Cable-VAC-4-0x...
(Edited)
Photo of Wojtek Daraz

Wojtek Daraz

  • 13 Posts
  • 0 Reply Likes

Great . Thank You very much Tim. In the "Virtual Audio Cable Setup" section must be Driver MME instead WDM-KS. Sorry I had not turn my attention to this You wrote in the post a week ago. Now: 


Photo of Darrin - KE9NS

Darrin - KE9NS

  • 102 Posts
  • 20 Reply Likes
Nice. Looks much better now. :)
Photo of Wojtek Daraz

Wojtek Daraz

  • 13 Posts
  • 0 Reply Likes

Thank You Darrin for assistance. I am happy using your Power SDR v. 2.80.60. - very fine!

Wojtek


Photo of N0AZZ

N0AZZ

  • 38 Posts
  • 4 Reply Likes
All I use for time is Dimension 4 (v5.31) also with 0 problems and an i5 processor running Win 10.