Unable to create ports when upgraded to Smart CAT ver 1.2.17.0

  • 1
  • Problem
  • Updated 5 years ago
  • Solved
Upgraded to version 1.2.17.0, lost my virtual ports. Removed and reloaded a couple of times, nothing seems to help. My main "Connect to 3rd party Program To Port" is Comm4, however third part programs will not connect (Commander and N1MM), plus I'm not able to create any virtual ports.

Anyone else have issues with upgrade?

Lew

Photo of Lewis Cheek

Lewis Cheek

  • 240 Posts
  • 41 Reply Likes

Posted 5 years ago

  • 1
Photo of K6OZY

K6OZY, Elmer

  • 542 Posts
  • 212 Reply Likes
Verify that the services are started properly.   Do this:

Press WindowsKey-R to open the run dialog box:


Type in services.msc and click OK.

Scroll down and look for "Virtual Serial Port Kit service".




Make sure it is running.  If it is not, click the Start button at the top.   After that, go into SmartCAT, remove all ports and restart it.   See if that helps.
(Edited)
Photo of Lewis Cheek

Lewis Cheek

  • 240 Posts
  • 41 Reply Likes
SmartCAT assigns port 6 for third party programs, however Commander and N1MM report Invalid  port number.

Lew
Photo of K6OZY

K6OZY, Elmer

  • 542 Posts
  • 212 Reply Likes
If you open the device manager and look at the Ports section, what do you see?   What does SmartCAT list for your primary port and additional ports?
Photo of Lewis Cheek

Lewis Cheek

  • 240 Posts
  • 41 Reply Likes
Comm port 1 (hardware type)
FlexControl USB Control Knob (COM3)
USB Serial Port (COM4) used for USB WinKeyer
USB Serial Port (COM5) I don't know what it's used for, can't recall anything

SmartCat primary port is COM6

NO ADDITIONAL PORTS, however COM6 is paired with COM16, both listed as connected to "UNKNOWN"

THIS WAS WORKING UNTIL I DID THE UPGRADE

Lew
Photo of K6OZY

K6OZY, Elmer

  • 542 Posts
  • 212 Reply Likes
If you have existing ports occupying COM4 and 5, then SmartCAT will start at the next available port, which in your case is COM6.   It will then create a sister port COM16.   Please add an additional PTT Port and check the DTR/RTS boxes.  It should create a COM7/COM17 pair for PTT. 

In N1MM, setup COM4 as your WinKey, COM6 as your CAT port, and COM7 as your PTT port if you want a hardware based PTT.
Photo of Lewis Cheek

Lewis Cheek

  • 240 Posts
  • 41 Reply Likes
Stand corrected on port 6, I had assigned it to Secondary CAT Serial Port in Commander
Photo of K6OZY

K6OZY, Elmer

  • 542 Posts
  • 212 Reply Likes
If you need additional ports for commander at the same time, then add a COM8 as a "Dedicated" port, which will create a new CAT port plus COM18.  Or if you do not want a PTT port, you can make COM7/17 CAT only, by setting it as "dedicated".
Photo of Andrew O'Brien

Andrew O'Brien

  • 384 Posts
  • 44 Reply Likes
Hmm, I did NOT uninstall SmartCAT before doing the SmartSDR upgrade...because I thought the instructions said no uninstall was required if the SmartSDR version being upgraded was above a certain level.  Maybe I misread that.  However, SmartSDRcat seems just fine here. 

Photo of Lewis Cheek

Lewis Cheek

  • 240 Posts
  • 41 Reply Likes
I had early version installed. I sure have gotten hooked on rig control and log freq/mode input from the rig. SEEMS like the OLD days of paper logs without it! :)

Lew
Photo of K6OZY

K6OZY, Elmer

  • 542 Posts
  • 212 Reply Likes
The new version of SmartCAT incorporates a separate service for driver installation and port management.   This decouples the OS specific part of making com ports with the code behind SmartCAT and the radio.   Moving forward, this makes updates much less impactful.   But with this version,  it is described in the upgrade document that you must uninstall and reboot the old version of SmartCAT before installing this new version. 

"If you have SmartSDR CAT v1.2.10 or earlier installed on your PC, make sure to uninstall SmartSDR CAT and reboot your PC before installing SmartSDR v1.2.17. "
Photo of Lewis Cheek

Lewis Cheek

  • 240 Posts
  • 41 Reply Likes
Official Response
Followed instructions for installing from later version of software,. i.e. removed flex drivers, then reinstalled update, that seems to have corrected the problem.

Lew
Photo of K6OZY

K6OZY, Elmer

  • 542 Posts
  • 212 Reply Likes
Great! Glad that helped.

This conversation is no longer open for comments or replies.