Unable to make a SmartLink connection on iPhone

  • 2
  • Problem
  • Updated 2 years ago
I am using a iPhone 7 Plus with registered V2.0.17 software.  I enabled SmartLnk on the phone. 
I tap on the SmartSDR icon and I tap to connect.  I get the setting up SmartLink message and then under Discovering..... I see a SmartLink connection available to my Flex Radio.  If I tap on the SmartLink dialog box, it goes right back to the screen "You are currently not connected tap here to connect"  If  tap that, I again see the SmartLink connection available.  I again tap it and it goes right back to the not connected screen.  I also see a non-SmartLink connection available via wifi.  That connection works fine.  Also, when I use my iPhone for a personal wifi hotspot, all devices using that signal connect via SmartLink with no problem.

Thanks for your assistance.

Bob, KN4HH
Photo of Bob  KN4HH

Bob KN4HH

  • 95 Posts
  • 21 Reply Likes

Posted 2 years ago

  • 2
Photo of Ria - N2RJ

Ria - N2RJ, Elmer

  • 2278 Posts
  • 919 Reply Likes
Hi Bob,

SmartLink only works from outside of your network. Try on 4G cellular or another wifi away from home and see if it works. 

Ria
Photo of Rudy HB9MHB

Rudy HB9MHB

  • 12 Posts
  • 0 Reply Likes
Hi Ria,

in my own network I can choose to connect via Smart Link (IP 178.193.210.0) or my network (IP 192.168.1.x) and it works with my iPhone SE. With my iPhone 7 it is not ok (no sound and always disconnect after about 20 sec.)

Rudy
Photo of Bob  KN4HH

Bob KN4HH

  • 95 Posts
  • 21 Reply Likes
Ria, I forgot to mention that all connections were attempted in the 4G environment away from my home network.  When I am close to my home network I can get a non-SmartLink connection using the iPhone which tells me that the basic software functions are good.

Bob
Photo of Ken - NM9P

Ken - NM9P, Elmer

  • 4082 Posts
  • 1275 Reply Likes
Just a few things to double-check:

1) by "registered" V.2.0.17 software, do you mean that you went through the process of registering it at the radio site, pressing the PTT / CW key when requested, and getting the sweet alarm tone?

2) Are you sure that you are using the same log-in method (Facebook, Google Account, etc. and ysername & Password on both the rig and your Smartlink setup on your phone?

3) What does it say on your Setting page when you click the "Check SmartLink Status" button?  Does it list your Call, Login email address and tell you that the login is Confirmed?

4) Did your UPnP or Manual port forwarding work correctly at the home station router?

5) Have you done the power-down and cold restart of the rig since installing and registering the new software?

6) If you have set your local router's DHCP "Reserved IP" so that your rig always receives the same IP address, you can try setting your SSDR-IOS Settings>LAN Mode to "Fixed" and enter your rig's constant IP Address in the "Network" Line.  That seems to help some connections.  (This is what I do on my system.)

Hope this helps,

Ken - NM9P
Photo of Bob  KN4HH

Bob KN4HH

  • 95 Posts
  • 21 Reply Likes
1.  YES
2.  YES
3.  YES however next to Expiration it shows todays date and the current time indicating to me that it expires immediately.
4.  YES
5.  YES
6.  YES

Bob, KN4HH
Photo of Stan Hirson

Stan Hirson

  • 4 Posts
  • 2 Reply Likes
I am having the same problem on an iPad with no 4G, just wifi. Irt hangs in "Discovering" when I try to connect through SmartLink.  
Photo of Ria - N2RJ

Ria - N2RJ, Elmer

  • 2278 Posts
  • 919 Reply Likes
Which wireless carrier?
Photo of Stan Hirson

Stan Hirson

  • 4 Posts
  • 2 Reply Likes
Verizon.
Photo of Stan Hirson

Stan Hirson

  • 4 Posts
  • 2 Reply Likes
Problem solved when I went to a location away from my wifi.  Worked like a charm!
Photo of Justin - KL2D

Justin - KL2D

  • 107 Posts
  • 40 Reply Likes
I had this same thing happen... I don't know if my cause was the same as yours but I figured I'd share it. I set up SmartLink after upgrading, and had to do port forwarding through my Airport Extreme. No worries, the Forum had an easy to follow guide. Got the port forwarding set up and tested the link, perfect! For about a week everything was great and I could access from anywhere and LTE is plenty fast enough for one slice and one pan (at least in Anchorage). 

Today I was fiddling around and trying to access from outside my LAN via cell, and I experienced the same symptoms that Bob describes. I could see the radio as an option, but when I clicked on it I immediately dropped back to the SSDR for iOS "you are not connected" screen. I started thinking, and I had lost commercial power to my home this week... sure enough when everything powered back up the radio had taken another IP address, different from the one I port forwarded to. I looked on the forum, found a way to get the MAC address for the radio, set up a static or "reserved" IP inside my LAN for the Flex, and adjusted the port forwarding to go to this permanent IP. Now even with power cycles to all the equipment, when it comes back up the radio grabs its assigned IP, the ports forward, and everything works fine. :-) 

So, maybe look at your port forwarding and if it is to a static IP, check to see if the radio shifted to another IP at some point. Then set up a static IP for the radio inside your LAN and match it to your port forwarding, and if this is your problem then you should be set.

I know Ken mentioned having a "reserved IP" (# 6 in his post), but not necessarily in conjunction with the port forwarding. I just wanted to throw out that the two must match, and mine did initially and then the next time everything got assigned they switched and the port forwarding was no longer valid. 

Hope this helps some,

73
Justin 
KL2D