Unable to connect remotely to 6600

  • 1
  • Problem
  • Updated 1 month ago
  • (Edited)
I have a 6600; it works fine with PC on LAN. In the past, I have been able to connect my laptop to it remotely and use it OK. Since version v2.3.9, I have not been able to connect the laptop. It seems to see that there is a rig there (shows the rig and my callsign), but when I hit Connect, it hangs for a while and then gives the modal error box "Unable to connect to radio. Please try again". I have the iOS version of SDR on my iPhone, it can't connect either. I have tried reloading the default profile from local system. The desktop (which works), radio, and laptop are all running v2.3.9. What is wrong? Does the new version need me to open a port on my router that is not open currently? Or?
Photo of Bill Engelke

Bill Engelke

  • 6 Posts
  • 0 Reply Likes

Posted 1 month ago

  • 1
Photo of Bill -VA3WTB

Bill -VA3WTB

  • 2767 Posts
  • 610 Reply Likes
I beleive V2.3.9 has changed the IP add,,read the release notes.
Photo of Greg - N8GD

Greg - N8GD

  • 207 Posts
  • 76 Reply Likes
It's the MAC address scheme that changed, and this basically messes up SmartLink.  Read the release notes for 2.3.9 as Bill suggested.  If you have a static IP set, you'll need to redo it, and, I think, reboot your router to get things working again.  Check the notes for the actual procedures.
Photo of Bill Engelke

Bill Engelke

  • 6 Posts
  • 0 Reply Likes
I read the release notes about v2.3.9, and what I got out of it related to this was that I need to reboot the router.  I powered it off, waited 30 seconds, and powered it on; also did a cold boot on the 6600.   Still same result; I can connect to the radio locally but not remotely. What am I missing? BTW, I have no static IP assignments, everything is DHCP. I have never entered any port forwarding settings into the router (could it have set this up automatically??)
(Edited)
Photo of Greg - N8GD

Greg - N8GD

  • 207 Posts
  • 76 Reply Likes
If your router has UPNP capabilities (does all the port forwarding automatically for SmartLink), make sure it is ENABLED in the router.  If you don't have such a setting, you'll need to do port forwarding.  To do port forwarding, you'll first need to set your 6600 to a static IP address (within SmartSDR).  Next, go into the Port Forwarding settings of your router and forward TCP external port 21000 to TCP internal port 4994 with a forwarding LAN address the same as the static address you set for your 6600.  Finally, forward UDP external port 22000 to UDP internal port 4993, again with a forwarding LAN address the same as the static address you set for your 6600.  See if this resolves your problem.  I enable both UPNP and set the port forwarding addresses in my system, just to be sure.

IMPORTANT: Make a note of your 6600 static IP address in case you ever need that info for troubleshooting!

Photo of W5AP

W5AP

  • 39 Posts
  • 1 Reply Like
Greg,  Would you please expand on how to set up a static ip for the radio within SmartSDR.  I couldn't find any place to do that in SmartSDR or on the 6600M screen
Tnx, Jim - W5AP
Photo of Ted  VE3TRQ

Ted VE3TRQ

  • 99 Posts
  • 33 Reply Likes
Setting up a static IP address for the radio is not done in SSDR or the radio (as long as it is already set up for DHCP / dynamic IP address assignment). You do this in the router by assigning a fixed IP address to the radios' MAC address in the router. Typically, if you go to a router's DHCP configuration area, you will be able to view the MAC address of a device (the Flex in this case), and assign it to a fixed IP address. The steps to do this vary from router to router, so I will not try to describe the steps to do this.
Photo of Mark Thomas

Mark Thomas

  • 47 Posts
  • 14 Reply Likes
Hi.  To configure the Flex radio base with a static IP address using SmartSDR go to: Settings -> Radio Setup -> Network -> Advanced, then you can select whether the radio uses DHCP or a Static configured IP address.  If you enter a static IP address here, the radio will always use that LAN IP, instead of obtaining one with DHCP.

The alternative Ted is describing is to leave the radio configured for DHCP, but configure the router's internal DHCP server to give the radio a fixed IP address based, so the radio always gets the same known IP address via DHCP.

If your router supports UPNP and has UPNP enabled, it is not necessary to configure the radio with a static or fixed IP, since the radio should update the router port-forwarding necessary for SmartLink on the fly.

I'm not a big fan of UPNP, and you may find it easier to diagnose issues and get the router confirmed-correct if you use one of the above methods to configure the Flex radio with a known fixed IP address, be it static in the radio or fixed-assigned-by-dhcp from the router.  -Mark Thomas KC3DRE

Photo of George Molnar, KF2T

George Molnar, KF2T, Elmer

  • 1561 Posts
  • 552 Reply Likes
I would strongly recommend letting your DHCP server set the Flex IP. Setting a device in a network to a fixed value not coordinated by DHCP can (will) lead to duplicate addresses and singular headaches.