TX Monitor Function not saved - 6600M

  • 1
  • Question
  • Updated 9 months ago
(Ver 2.1.32) I find that I'm unable to save the TX Monitor setting.  I enable it, then save it & all seems well until I power cycle the radio.  Is this a known issue? I searched but didn't find it. Thanks.
Photo of Bill Garfield W1BG

Bill Garfield W1BG

  • 74 Posts
  • 15 Reply Likes
  • Perplexed

Posted 9 months ago

  • 1
Photo of Bill -VA3WTB

Bill -VA3WTB

  • 3032 Posts
  • 671 Reply Likes
I believe the TX monitor slider is working as planed.
Photo of Larry - W8LLL

Larry - W8LLL

  • 406 Posts
  • 78 Reply Likes
"I enable it, then save it "


How are you saving it?
Photo of Bill Garfield W1BG

Bill Garfield W1BG

  • 74 Posts
  • 15 Reply Likes
I enable it, then open the main menu, select Profiles and save both the Mic & TX profiles.
Then power-cycle the radio and find that it was not saved.  Apparently I'm doing something wrong??
Photo of Larry - W8LLL

Larry - W8LLL

  • 405 Posts
  • 78 Reply Likes
What happens if you manually select load up that mic profile, it the monitor on or off?
(Edited)
Photo of Bill Garfield W1BG

Bill Garfield W1BG

  • 74 Posts
  • 15 Reply Likes
If I manually load up the profile it shows to be there, but it won't survive a reboot. All else does.
Photo of Larry - W8LLL

Larry - W8LLL

  • 405 Posts
  • 78 Reply Likes
That was my understanding also but I did a test by turning monitor on and creating a new global profile without first saving the mic profile and the monitor is on every time I bring up that global profile. but it also seems to create a mic profile with the same name, so I guess the answer to bills question is save the global profile after turning monitor on and he should be good to go.
(Edited)
Photo of Bill Garfield W1BG

Bill Garfield W1BG

  • 74 Posts
  • 15 Reply Likes
Thanks Larry. I'll give that a try, as I'm otherwise somewhat perplexed. Of course I've only had the radio a bit over 24 hours so we're still on the steep side of the learning curve, hi hi.  The odd thing is I can enable the TX monitor function & save it to my active mic profile & note in the Profile Manager that upon bootup the correct profiles are in fact being loaded, but if I press the TX Mic/Pwr/Speed button that it comes up as [DIS]abled every time, though then I can [Load] that same Mic profile and then suddenly it's enabled. Looks like kind of a small bug & surprised no one else has reported it.  I'll report back as to how your suggested fix works.  73
Photo of Bill -VA3WTB

Bill -VA3WTB

  • 3002 Posts
  • 660 Reply Likes
We will have to wait to hear from Flex on this, I don't think it is a bug. It has worked like this for a long time I believe.
Photo of Larry - W8LLL

Larry - W8LLL

  • 405 Posts
  • 78 Reply Likes
Mic and TX profiles can be attached (saved) to global profiles so make your mic profile change (mon on) then re save the global, this always works for me.
Photo of Bill Garfield W1BG

Bill Garfield W1BG

  • 74 Posts
  • 15 Reply Likes
If not a bug, then it's an undocumented feature...  Seems if you create a new Global Profile that new profiles of the same name are also created in your TX profile and Mic profile groups, maybe implying those are the ones it's expecting you to use.   Anyhow, with Larry's help I now have the [MON] function working correctly.
Photo of Wayne

Wayne

  • 614 Posts
  • 84 Reply Likes

According to the manual section on profiles ANYTIME you change an existing setting in a Mic or Tx profile and resave that profile under the same name as before you made the changes then in order for a Global Profile to honor the new save changes in the Mic or Tx profile with the same name as the one it is assigned you MUST once again resave the Global Profile once you have changed and save the Mic or Tx profile with the same name the global profile has assigned.

Once this is done the next time the Global Profile is loaded or used you will see the new changes that you have made on the unit.

Photo of Bill Garfield W1BG

Bill Garfield W1BG

  • 74 Posts
  • 15 Reply Likes
Help me understand something.  Which profile(s) get loaded at boot time?? 
Photo of Rich McCabe

Rich McCabe

  • 1050 Posts
  • 222 Reply Likes
Last know state (not profile) gets loaded.  All the profiles are on the radio to select, however what comes up is last known setup. So whatever settings you had when you shut it down is what you should see.
Photo of Bill Garfield W1BG

Bill Garfield W1BG

  • 74 Posts
  • 15 Reply Likes
Thanks Rich. That makes sense.  So now what doesn't make sense is that I am still chasing my original issue with the TX MONitor function not surviving a power cycle. I thought I had it working, but apparently it's not. Try as I have, save as I have, reconfigure & re-save as I have, TX MON status (if Enabled) always comes up disabled after a power cycle. 

Also TX MON does not work if VOX is enabled. TX MON only works with PTT
6600M,  ver 2.1.33
Photo of Jay / NO5J

Jay / NO5J

  • 1577 Posts
  • 228 Reply Likes
My guess, just a guess really. Possibly, TX Mon settings default to off after every power cycle/SmartSDR restart, intentionally. I'd be embarrassed if my first SSB transmission of each day was a loud screech of mic feedback, I sometimes have my speaker volume cranked up from the previous days DX hunting. For me at least it works like I'd like it to. YMMV
 
#Flexradio

73, Jay / NO5J

Photo of Bill Garfield W1BG

Bill Garfield W1BG

  • 74 Posts
  • 15 Reply Likes
Thanks Jay.  Just the opposite here.  XYL recovering from knee surgery, trying to rest so I endeavor to keep the QTH as quiet as possible. Always use the cans.  Another issue (related) is TX MON does not work at all (period) whenever the VOX is enabled.

TX MON works OK when manually enabled & used with PTT, but does not survive a power-cycle

TX MON does not work at all (ever) when VOX is enabled.

TX MON (enabled) does come on during VOX operation if PTT button is pressed while VOX is keyed, but only for the duration of the PTT button press.

6600M - 2.1.33 (and prior) 

73 - Bill
W1BG
Photo of Wayne

Wayne

  • 614 Posts
  • 84 Reply Likes

If you do not want to operate as you did with the settings from when you last shut it down you need to touch Menu and touch Profiles and choose the Global profile which contains the Mic and Transmit profiles you wish to have loaded and then press Load.

Remember if you create a Transmit profile in SSB on say 20m and set the power to 20watts, that is the ONLY band the 20 watts is set on. So for a transmit profile you need to sequence through every band on the active slice and set the power to 20 watts if you want the Transmit profile to use 20 watts on every band, then save it then resave the Global profiles which use that Transmit profile.

I guess you could also set a Maximum Power setting to do the same but looking at the manual it is not saved as perisistence or in any profiles so it would be easy to forget that I did that!