To all soon receiving 6400 and 6600 radios...

  • 1
  • Praise
  • Updated 8 months ago
While I fully realize you will want to play with said radios and be all selfish about having the newest and snub the rest of us... (just kidding)

I do expect some unboxing videos, some really good pictures of where the new radios are in your shack, some reviews, detailed about connections, setup, how does it feel to operate?

Basically, in summary, when you get your new radio, give us whom are not so lucky some feedback and reports.   We want to know!

:-)
Photo of Mark - WS7M

Mark - WS7M

  • 1009 Posts
  • 360 Reply Likes

Posted 10 months ago

  • 1
Photo of Jim K4JAF

Jim K4JAF

  • 341 Posts
  • 91 Reply Likes
Great idea !!!!!
Photo of Mike, K7QDX

Mike, K7QDX

  • 24 Posts
  • 12 Reply Likes
I also like that idea. One of the testers has a blog but it seems he has updated it for a while or I haven't been to it lately.

However when I ordered my radio I was told I should be in the first batch. However I still have yet to hear anything. I'm hoping to hear from them this next week I hope.
Photo of Jim K4JAF

Jim K4JAF

  • 341 Posts
  • 91 Reply Likes
Also nice if Flexers who receive a tracking number, list their order date so we can roughly keep up with dates being shipped at that time..  Thanks..  
Photo of Gary Wise

Gary Wise

  • 74 Posts
  • 19 Reply Likes
My order date was Friday, May 19, 2017 at the Flex Booth at Dayton. Matt took my order (for a 6600) and a cash deposit that morning (after I learned of the new radios at the Flex dinner the night before).

73 - Gary - W4EEY
Photo of Robert Greene

Robert Greene

  • 16 Posts
  • 3 Reply Likes
Mine was May 19, 2017 @ 4:58, Told today I was #66 no tracking number, radio has not shipped still in box.
Photo of Scott Russell - N1SER

Scott Russell - N1SER

  • 61 Posts
  • 10 Reply Likes
Sounds like a good idea. I probably won't get mine for a couple more months since I ordered not too long ago but I'll try and document for you!

73 Scott N1SER
Photo of Rick Hadley - W0FG

Rick Hadley - W0FG

  • 579 Posts
  • 121 Reply Likes

Flex 6400 w/ATU, V2.1.30 Software.  Some lucky souls will be getting their's in a few days.  I've been Alpha testing this one for a couple of weeks.  It's a lovely radio, every bit as good as my 6500 with the only limitation being 2 Slices/Pans on the 6400 vs 4 on the 6500.  Works great with the Maestro (off screen to the right) too, as well as with the iPad and iPhone.   Works fine on all modes I've be running, CW/SSB/FT8, and I've been getting great audio reports off the included FHM-2 mic,  I need to get an adaptor to try it out with my AT3035 studio mic that I use on the 6500.  The new software has a couple of nice enhancements, the most obvious being the adjustable panadaptor fill.
Photo of Steve K9ZW

Steve K9ZW, Elmer

  • 1282 Posts
  • 656 Reply Likes
Like this:





73

Steve
K9ZW

http://K9ZW.wordpress.com
Photo of Clay N9IO

Clay N9IO

  • 527 Posts
  • 123 Reply Likes
Gives a different meaning to the term "ham sexy".
HA LOL!!!
Photo of Jd Dupuy

Jd Dupuy

  • 155 Posts
  • 60 Reply Likes
That should be x-rated. Enjoy!
Photo of Steve K9ZW

Steve K9ZW, Elmer

  • 1282 Posts
  • 656 Reply Likes
Photo of Jd Dupuy

Jd Dupuy

  • 155 Posts
  • 60 Reply Likes
Stop it!
Photo of Steve K9ZW

Steve K9ZW, Elmer

  • 1282 Posts
  • 656 Reply Likes
Photo of ka7gzr

ka7gzr

  • 215 Posts
  • 36 Reply Likes
Great views of the new radios. I do have a question. How does the 6700 plus a Maestro compare to these?
Photo of Bill -VA3WTB

Bill -VA3WTB

  • 2971 Posts
  • 653 Reply Likes
This is very hard to answer simply. The new radios have replaced the older 6000 radios. That is why they are there. But the M models opens up a very new space in were the radios sit in the market place.
The performance seems to be very close, but the 6700 has 2M built in. If you add a Maestro to the 6600? then the features and performance are close.
Photo of Mark WS7M

Mark WS7M

  • 415 Posts
  • 114 Reply Likes
Still no new software yet... sigh...
Photo of KY6LA - Howard

KY6LA - Howard, Elmer

  • 3570 Posts
  • 1430 Reply Likes

V2.1 is done

BUT my best guess is that they are putting final touches on 2.1 Release Notes and New Documentation as they had to do a huge amount of work to get 2.1 tested on 7 different radios + Maestro's

Photo of Clay N9IO

Clay N9IO

  • 529 Posts
  • 123 Reply Likes
Yep and the Bouvet ship getting closer to the shore.
Photo of Robert Greene

Robert Greene

  • 16 Posts
  • 3 Reply Likes
Bouvet, still 600 nautical miles to make the island.
Photo of Rick Hadley - W0FG

Rick Hadley - W0FG

  • 579 Posts
  • 121 Reply Likes
If you already have a 6K series radio, and V2.0.19, there's nothing in V2.1 that is so significant that it will improve your chances of working Bouvet.  If you're waiting for a 6400/6600 then that's a different matter.
Photo of Clay N9IO

Clay N9IO

  • 529 Posts
  • 123 Reply Likes
Bingo!
Fingers crossed:-)
Photo of KM1E

KM1E

  • 2 Posts
  • 0 Reply Likes
Here is my 6400 with Maestro and iPad Pro. Still figuring out how to use it. I have a question: Is it OK to leave the radio on all day / all night while I play with my iPad or iPod around the house, or with SmartLink away from home? Or, should I try to figure a way to turn on my Flex Radio remotely?
Photo of Mike, K7QDX

Mike, K7QDX

  • 24 Posts
  • 12 Reply Likes
Its been discussed in earlier posts. But a lot of people leave the radios on for days end. More so with the guys that runs and operators the radio remotely. 
Photo of Mark - WS7M

Mark - WS7M

  • 1000 Posts
  • 356 Reply Likes
Yes my 6500 has been on for over a year now.  I have the fan issue sporadically so leaving it on actually avoids part of that issue as the fans seem to have issues starting up.
Photo of Wim

Wim

  • 90 Posts
  • 17 Reply Likes
The 6600 working great at K6TE, experimenting already with Full Duplex using both antenna inputs.
Right now I don't seem to have enough isolation between the Groundplane and rooftop doublet.

Photo of KM1E

KM1E

  • 2 Posts
  • 0 Reply Likes
Like I said in my post, I am trying to figure out how to use this machine. I can use my iPhone at home on my own network, but at work, with another wifi, I log in through my SmartLink, and get blank Panadapter, and no waterfall. Hopefully it's just a setting. Still learning.