Third time is a charm ! Thanks for Flex support.

  • 2
  • Praise
  • Updated 9 months ago
A new 6600 to replace the previous 6600m's that I had issues with arrived yesterday. 

It is working flawlessly and I could not be happier with it. I was a little shocked as I took it out of the box when I saw the the silver accents on the front panel. I noticed this in the pictures on the Flex site but thought they were reflections. Never the less, it looks great.

Want to give a shout out to everyone involved in getting me taken care of including Matt, Dudley, Tim and Katie.You guys are the best and just one of the reasons I cant seem to look at other brands of transceivers.

Thank you !

Rich
kd0zv

Photo of Rich McCabe

Rich McCabe

  • 1050 Posts
  • 222 Reply Likes
  • Super Happy

Posted 9 months ago

  • 2
Photo of Reggie-k6xr

Reggie-k6xr

  • 413 Posts
  • 32 Reply Likes
@Rich. right now at this very moment and often, I push the button to change the filter and it will not cycle past 1.0 in cw no matter how often I click it. the problem alternates from b to a slice. one will work and one will not. I wonder if that is what you saw or had?  curious?
Photo of Rich McCabe

Rich McCabe

  • 1050 Posts
  • 222 Reply Likes

My issue was that it would pop up the menu to adjust the filter instead of just toggling between the presets. 


I assume you have several presets selected in your menu for it to change?

Have you tried doing the knob adjustment as others have? 


Rich

Photo of Reggie-k6xr

Reggie-k6xr

  • 413 Posts
  • 32 Reply Likes
I am using the preset's and  I get the pop up menu to adjust the filter instead of just toggling between the presets as you did. My issue is not consistent though. sometimes they work and sometimes they don't! And then the presets get stuck and will not cycle! Guess I should give a help desk note and see what they say about that. Thanks for that info.
Photo of Rich McCabe

Rich McCabe

  • 1050 Posts
  • 222 Reply Likes

Yes, mine worked on occasion but more often than not it didn't.  If you are getting the menu I am betting your radio will have to go back Reggie.


Rich


Photo of Reggie-k6xr

Reggie-k6xr

  • 413 Posts
  • 32 Reply Likes
I just ran a test and in ssb mode the A slice gets the menu once in awhile but I can cycle through the presets. But, on the B slice in cw, it will sometime show the menu and also the presets do not cycle at all. will rotate to 1.o and just hang until I change modes. so will do a help desk note in the morning
Photo of John - K3MA

John - K3MA

  • 280 Posts
  • 81 Reply Likes
Why did you not get a 6600M replacement for your 6600M?
Photo of Rich McCabe

Rich McCabe

  • 1050 Posts
  • 222 Reply Likes

John, there are a couple reasons. The main reason is I was frustrated after receiving two radios in a row with four problems (2 problems /radio).

There are also several things I really hate about the M radios and I am doubting that Flex will do anything about it in the near future.

So I chose to go back to something that I know Flex does really well.

I am perfectly happy with the 6600 and Flex was more than helpful when it came to either fixing the M or downgrading me.

Yea, I am disappointed but its fine.

Rich

Photo of John - K3MA

John - K3MA

  • 280 Posts
  • 81 Reply Likes
TU for the explanation.  I personally think the 6400/6600 non-M and a Maestro is a better option that gives more flexibility for about the same total cost.