T-Mobile Wireless Hotspot and Maestro

  • 1
  • Question
  • Updated 7 months ago
  • Answered
For the first time I tried to connect my Maestro to my T-Mobile Aristo phone using the phone as a wireless hotspot.  The phone as a wireless hotspot works with other devices without issue.

The LG-Aristo hotspot shows up on the Maestro WiFi network available list.  When I try to connect to it from the Maestro I get the wireless password selection box.  I type in the correct wireless password and it goes blank for a few seconds and then comes back to the same password selection box.  I have tried changing the password but still I cannot log into the T-Molbile LG-Aristo mobile wireless hot spot.

Does anyone have a similar problem or any suggestions on how to get a connection to the hotspot?
Photo of John - K3MA

John - K3MA

  • 280 Posts
  • 81 Reply Likes

Posted 10 months ago

  • 1
Photo of John Pfeifer

John Pfeifer

  • 13 Posts
  • 1 Reply Like
I had a similar issue when connecting to my openspot but I have consumer cellular, I ended up turning on the blue tooth in the cell phone and wala it connected
Photo of John - K3MA

John - K3MA

  • 280 Posts
  • 81 Reply Likes
I discovered that changing the security protocol from "WPA PSK" to "WPA2 PSK" worked,  Connection good with no issue.  TU. 
Photo of David Marotti

David Marotti

  • 26 Posts
  • 9 Reply Likes
John, I have the same problem with my iPhone.  Although it worked before.  For some reason the hotspot no longer works.  Now I have the exact same problem you described in the message above.  Where did you change the security protocol?  I can't find that on the Maestro.  David.
(Edited)
Photo of John - K3MA

John - K3MA

  • 280 Posts
  • 81 Reply Likes
David, it was a setting on the TMobile Hotspot in Android.  I do not have a iPhone so I cannot offer any help on what to do in this case.
Photo of W9WLX-Chuck

W9WLX-Chuck

  • 33 Posts
  • 8 Reply Likes
Be sure there is no apostrophe in the network name.  Some iPhones do this by default.  The network name is the same as your phone's name.  If you have an apostrophe in the network name, you can change your phone's name and remove it by going under Settings>>General>>About.  Tap the name and remove the apostrophe.